CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   FLUENT (http://www.cfd-online.com/Forums/fluent/)
-   -   Cooper meshing error: intersecting edge (http://www.cfd-online.com/Forums/fluent/50654-cooper-meshing-error-intersecting-edge.html)

Stuart February 23, 2009 21:06

Cooper meshing error: intersecting edge
 
Hi,

I'm attempting to mesh a volume using the Cooper scheme. It's basically a tube with detailed ends (mostly mapped, but a couple of paved faces). It's been meshed successfully before using Cooper, but I've had to split a connected volume, splitting a couple of the 'side' faces. I've re-meshed the edges running along the length of the volume, either side of the new split, and even got the side faces re-meshed using a Map scheme.

When attempting to re-mesh the volume, I get an error:

"Error: Projection intersection attempted without any free nodes on the intersecting edge. Volume volume.80 could not be meshed."

Any clues on what I need to look at/do to get this volume meshed again?

Many thanks in advance.

Stuart

Stuart February 23, 2009 21:11

Re: Cooper meshing error: intersecting edge
 
I'm using Gambit 2.4.6 by the way, if that makes any difference.

Ralf Schmidt February 24, 2009 11:27

Re: Cooper meshing error: intersecting edge
 
Hi!

I did not really get the geometry of your problem...

However, what I do when I want to create a cooper mesh is the following:

1. create the source face solo, without any volume. And mesh that face as you want.

2. create an edge, that corresponds to the third dimension of the volume (attached to one vertices of the source face)

3. mesh the edge with the mesh line tool

3. in volume commands, use the "sweep face" command and sweep the face along the edge, the button "with mesh" must be turned on!!

4. you gut your volume! -(you ma delete that edge)

Best wishes Ralf


Ralf Schmidt February 24, 2009 11:31

Re: Cooper meshing error: intersecting edge
 
Hi!

I did not really get the geometry of your problem...

However, what I do when I want to create a cooper mesh is the following:

1. create the source face solo, without any volume. And mesh that face as you want.

2. create an edge, that corresponds to the third dimension of the volume (attached to one vertices of the source face)

3. mesh the edge with the mesh line tool

4. in volume commands, use the "sweep face" command and sweep the face along the edge, the button "with mesh" must be turned on!!

5. you got your volume! -(you may delete that edge)

Best wishes Ralf


Stuart Barlow February 26, 2009 07:20

Re: Cooper meshing error: intersecting edge
 
Hi,

Thanks for the advice. Unfortunately I'm working with imported CAD geometry, the volume was created by splitting an existing one with swept surfaces of the outline of the new one... never again CAD!

Ralf Schmidt February 26, 2009 07:46

Re: Cooper meshing error: intersecting edge
 
Hi

ok.. another idea:

you may pre-mesh the side faces of you volume. Either with mapping scheme... or with Quat/Tir option.

That may help...

Ralf


All times are GMT -4. The time now is 09:59.