CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > FLUENT

Running Existing Code: Commands Grayed Out

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By Michael Rasche

Reply
 
LinkBack Thread Tools Display Modes
Old   March 2, 2009, 21:35
Default Running Existing Code: Commands Grayed Out
  #1
Michael Rasche
Guest
 
Posts: n/a
I have some Fluent simulations that I'd like to modify. I've been given (via email by a former student) the .cas and .dat files for the simulations as well as some .c files which are UDFs that specify a dynamic mesh and micromixing/crystal size distribution within the cells. At this point, I'm just trying to run the simulation. The code was originally written for Fluent 6.1.22 and the mesh created in Gambit 2.2. I'm using Fluent 6.3.24 and Gambit 2.4. If I read the .cas file, I get a few errors, but I also have a lot of grayed out (unselectable) options like solve->iterate, solve->initialize as well as the define->boundary conditions, write->case, etc. Options like display->grid, etc. work fine. I've followed the tutorials, and I am able to compile the UDFs which removes the "library does not exist" error, but does not solve the problem of grayed-out commands, so I'm not really able to initialize the problem (or check to see what's going on with the boundary conditions). There's only one remaining error upon reading the .cas file; i.e. "Error: Arg(3rd) out of range in substring. Error object 5." I haven't determined what this means yet.

I'm looking for a reason that solve->initialize and define->boundary conditions would be unavailable or what "Error : Arg(3rd) out of range in substring" means. Thanks. Can you explain why some options are unselectable and give me some direction for running this simulation? Thanks, Michael Rasche
Richard Parker likes this.
  Reply With Quote

Old   July 25, 2012, 07:11
Default
  #2
New Member
 
Richard Parker
Join Date: Jul 2012
Posts: 10
Rep Power: 5
Richard Parker is on a distinguished road
Hi Michael,

Did you figure it out, finally?

I've encountered the same problem, but using the same version of fluent and gambit i used to create the .cas file.

Not a big problem to me, as I can re-do the case quickly. But I feel curious about it, nonetheless.

Did you manage to solve it?

Josep
Richard Parker is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Self implemented code is not running in parallel michi OpenFOAM Running, Solving & CFD 2 November 6, 2008 06:09
Workbench Simulation Grayed out - Not installed? Stewart Long Main CFD Forum 0 October 28, 2008 07:42
problem in running code yaseer Main CFD Forum 0 March 23, 2007 12:08
Error showed up when running code tangd OpenFOAM Running, Solving & CFD 1 July 14, 2006 04:26
Running MPI code on a multiprocessor node wen Main CFD Forum 7 April 19, 2006 16:35


All times are GMT -4. The time now is 19:04.