CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   FLUENT (http://www.cfd-online.com/Forums/fluent/)
-   -   changing default unit in Gambit (http://www.cfd-online.com/Forums/fluent/50799-changing-default-unit-gambit.html)

NISHIKANT TAMRAKAR March 8, 2009 01:12

changing default unit in Gambit
 
hi, Fluent by default works in SI system with meter as length. Gambit by default works in millimeter. I have made a pathline in Fluent in .ibl format(which is in meter by default). I want to superimpose this on the geometry i had made in Gambit. But Gambit reads it as though it is written in "mm" as there is no description in .ibl format about units.

What may be the way out.

I think there must be some approach to change default of Gambit to meter then it will be solved.

Can anyone knows how to change default unit from "mm" to "m" in Gambit. Thanks in advance.

Freeman March 8, 2009 08:34

Re: changing default unit in Gambit
 
And why not as easy as scaling your mesh directly in Fluent? Go to Grid->Scale and tell Fluent that your "mesh was created in mm". Just click scale and that's it: I allways work like this.

Good luck

Regards, Freeman

NISHIKANT TAMRAKAR March 8, 2009 14:27

Re: changing default unit in Gambit
 
Thanks for the reply. I have other problem. 1) Created mesh in Gambit in "mm". 2) Read the mesh in Fluent. 3) Done the scaling. 4) Done analysis. 5) Got the pathline profile in "m". 6) Exported this pathline to .ibl. The problem is here. This .ibl file does not say that it was made in "m". It just gives the coordinates of all the points of all the curves. My domain in from -7 m to + 1.5 m. So .ibl file says that the points are from -7 to +1.5 (without unit). 7) Read this .ibl file in Gambit. Gambit reads as though it is in "mm". So for Gambit the domain becomes -7mm to +1.5mm. This is the problem.

Please give me some solution for this.

I tried to just read it in Gambit then convert in to igs format (because igs format records which unit it was made). Then manually changed igs file units from "mm" to "m" and again tried to read in Gambit. But Gambit does not recognize the changed file.

So this was the problem. I am sure that you may have the solution, and earlier I did not put it properly. Thanks

kuba March 9, 2009 09:59

Re: changing default unit in Gambit
 
GAMBIT does not operate with units! It is non-dimensional drawing tool ... That is why you got -7 to +1.5


NISHIKANT TAMRAKAR March 9, 2009 11:30

Re: changing default unit in Gambit
 
Yes I got it. But is there any way that Gambit read it in some scaling of 1000 i.e. it read it -7000 to +1500.



All times are GMT -4. The time now is 14:45.