CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > FLUENT

changing default unit in Gambit

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   March 8, 2009, 01:12
Default changing default unit in Gambit
  #1
NISHIKANT TAMRAKAR
Guest
 
Posts: n/a
hi, Fluent by default works in SI system with meter as length. Gambit by default works in millimeter. I have made a pathline in Fluent in .ibl format(which is in meter by default). I want to superimpose this on the geometry i had made in Gambit. But Gambit reads it as though it is written in "mm" as there is no description in .ibl format about units.

What may be the way out.

I think there must be some approach to change default of Gambit to meter then it will be solved.

Can anyone knows how to change default unit from "mm" to "m" in Gambit. Thanks in advance.
  Reply With Quote

Old   March 8, 2009, 08:34
Default Re: changing default unit in Gambit
  #2
Freeman
Guest
 
Posts: n/a
And why not as easy as scaling your mesh directly in Fluent? Go to Grid->Scale and tell Fluent that your "mesh was created in mm". Just click scale and that's it: I allways work like this.

Good luck

Regards, Freeman
  Reply With Quote

Old   March 8, 2009, 14:27
Default Re: changing default unit in Gambit
  #3
NISHIKANT TAMRAKAR
Guest
 
Posts: n/a
Thanks for the reply. I have other problem. 1) Created mesh in Gambit in "mm". 2) Read the mesh in Fluent. 3) Done the scaling. 4) Done analysis. 5) Got the pathline profile in "m". 6) Exported this pathline to .ibl. The problem is here. This .ibl file does not say that it was made in "m". It just gives the coordinates of all the points of all the curves. My domain in from -7 m to + 1.5 m. So .ibl file says that the points are from -7 to +1.5 (without unit). 7) Read this .ibl file in Gambit. Gambit reads as though it is in "mm". So for Gambit the domain becomes -7mm to +1.5mm. This is the problem.

Please give me some solution for this.

I tried to just read it in Gambit then convert in to igs format (because igs format records which unit it was made). Then manually changed igs file units from "mm" to "m" and again tried to read in Gambit. But Gambit does not recognize the changed file.

So this was the problem. I am sure that you may have the solution, and earlier I did not put it properly. Thanks
  Reply With Quote

Old   March 9, 2009, 09:59
Default Re: changing default unit in Gambit
  #4
kuba
Guest
 
Posts: n/a
GAMBIT does not operate with units! It is non-dimensional drawing tool ... That is why you got -7 to +1.5

  Reply With Quote

Old   March 9, 2009, 11:30
Default Re: changing default unit in Gambit
  #5
NISHIKANT TAMRAKAR
Guest
 
Posts: n/a
Yes I got it. But is there any way that Gambit read it in some scaling of 1000 i.e. it read it -7000 to +1500.

  Reply With Quote

Old   May 19, 2016, 04:28
Smile Gambit Units
  #6
Member
 
shahid
Join Date: Oct 2013
Posts: 88
Rep Power: 4
shahid nadeem is on a distinguished road
As per my understanding i think gambit works on the Unit's which were used to create the model in any other software and imported in Gambit.

Any idea about this guys
shahid nadeem is offline   Reply With Quote

Old   May 20, 2016, 01:22
Default
  #7
Senior Member
 
Lucky Tran
Join Date: Apr 2011
Location: Orlando, FL USA
Posts: 1,271
Rep Power: 20
LuckyTran will become famous soon enough
Quote:
Originally Posted by shahid nadeem View Post
As per my understanding i think gambit works on the Unit's which were used to create the model in any other software and imported in Gambit.

Any idea about this guys
Gambit is non-dimensional, it has no units. It reads in coordinates and simply uses them as is. Likewise, when it writes a mesh file, it simply writes the coordinates with no units. Other software that reads these unitless fields will typically assume a default unit. For example, Fluent automatically assumes meters. It's also not uncommon for geometry file to be unitless. Actually many common cad file formats are dimensionless formats or they assume certain units no matter what. Parasolid is an example, it always assumes everything is always in meters so the units are not specified.
LuckyTran is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gambit default settings frank FLUENT 5 December 11, 2009 22:05
Changing default values dcwnj CFX 1 February 6, 2008 16:46
change default lable in Gambit suti FLUENT 0 August 24, 2005 21:40
GAMBIT default parameters?? JB FLUENT 3 January 28, 2005 09:50
Gambit Default Numbers Ritesh Chhabra FLUENT 2 August 30, 2004 13:24


All times are GMT -4. The time now is 17:17.