CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   MPICH2 (

Alfonso March 9, 2009 14:12

I have a problem with the combination Fluent+Mpich2 for work in paralel mode.

I don't know if the users need to be network users or they can be locals of the machine. With local users don't work.

If I launch fluent from Fluent launcher seems to function properly but when I open a case+data show me an error when reads it: read-case&data:
:invalid machine


Daniel March 11, 2009 19:40

Alfonso -

I have this EXACT same problem. I am running a new XEON-based workstation with Vista-64 installed. It took a while to find a version of the MPICH2 that runs properly, but I downloaded one from the Argonne website that did work finally. I am only trying to run MPI on this single machine (8 threads), so my host file is very simple, like: graddome03x graddome03x graddome03x graddome03x graddome03x graddome03x graddome03x graddome03x

I finally got no errors to show when I use the "check" button in the launcher - and then got it to "successfully" launch FLUENT, only to have it give the following error when I try to open a file:

Loading "C:\Fluent.Inc\fluent6.3.26\lib\fl114-64.dmp" Done. Warning: -path flag not specified. Defaulting to -pathC:\Fluent.Inc

Welcome to Fluent 6.3.26

Copyright 2006 Fluent Inc.

All Rights Reserved Loading "C:\Fluent.Inc\fluent6.3.26\lib\flprim1119-64.dmp" Done.
: Error: read-case-data: invalid machine Error Object: #f

That last part occurs when I try to open a file!

I will tell you when I figure anything else out - meanwhile, if anybody else can guess what stupid mistake I'm making, please reply!!!

Cheers, -Daniel

Thank you so much Daniel... March 13, 2009 12:48

Thank you so much Daniel...
Hello Daniel First all I want to thank you so much for answer me and help me I will try to do what you advice me and we could be in touch I trying to do a cluster with four Computer to run 4000000 elements so I hope it work Kindly Regard Alfonso

All times are GMT -4. The time now is 04:28.