CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > FLUENT

Compile UDF

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 29, 2009, 00:05
Default Compile UDF
  #1
New Member
 
Alkulkarni
Join Date: Jul 2009
Posts: 6
Rep Power: 9
Alkulkarni is on a distinguished road
Dear All,

I am trying compile UDF from tutorial in Fluent. The error message displayed is as below

Deleted old libudf\win64\2d\libudf.dll
1 file(s) copied.
(system "copy C:\Fluent.Inc\fluent6.3.26\src\makefile_nt.udf libudf\win64\2d\makefile")
1 file(s) copied.
(chdir "libudf")()
(chdir "win64\2d")()
'nmake' is not recognized as an internal or external command,
operable program or batch file.
'nmake' is not recognized as an internal or external command,
operable program or batch file.

Does anyone have idea to solve it?

Thank you,
Abhijit Kulkarni
Alkulkarni is offline   Reply With Quote

Old   August 4, 2009, 12:07
Default
  #2
Member
 
Dongzi Wei
Join Date: Mar 2009
Posts: 33
Rep Power: 9
Jiuan is on a distinguished road
I had the same problem bofore. When I check the UDF manual, it is noted that we have install microsoft visual studio to compile UDF.


Quote:
Originally Posted by Alkulkarni View Post
Dear All,

I am trying compile UDF from tutorial in Fluent. The error message displayed is as below

Deleted old libudf\win64\2d\libudf.dll
1 file(s) copied.
(system "copy C:\Fluent.Inc\fluent6.3.26\src\makefile_nt.udf libudf\win64\2d\makefile")
1 file(s) copied.
(chdir "libudf")()
(chdir "win64\2d")()
'nmake' is not recognized as an internal or external command,
operable program or batch file.
'nmake' is not recognized as an internal or external command,
operable program or batch file.

Does anyone have idea to solve it?

Thank you,
Abhijit Kulkarni
Jiuan is offline   Reply With Quote

Old   August 5, 2009, 04:37
Default
  #3
New Member
 
Alkulkarni
Join Date: Jul 2009
Posts: 6
Rep Power: 9
Alkulkarni is on a distinguished road
I have installed Microsoft visual studio on both 64 bit and 32 bit machine. The window for commond prompt is not available.
Alkulkarni is offline   Reply With Quote

Old   August 5, 2009, 07:49
Default
  #4
Member
 
Daniel Tanner
Join Date: Apr 2009
Posts: 54
Rep Power: 9
Daniel Tanner is on a distinguished road
Try opening fluent from a Visual studio terminal, something like:
start -> All Programs -> Visual Studio -> Visual studio Tools ...

This will ensure that the environment is properly configured and that the Visual Studio compilers are available to fluent.

launch fluent using the standard command line options, something like:
fluent 3ddp -64

If you want 64-bit you should open the 64-bit Visual Studio terminal.

Let me know if this works!
Daniel Tanner is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATTN ALL: SOLUTON TO UDF COMPILE PROBLEM Rizwan Fluent UDF and Scheme Programming 32 May 8, 2015 06:05
Error compile file udf czfluent Fluent UDF and Scheme Programming 24 September 26, 2009 13:24
udf compile in parallel system tahereh FLUENT 1 December 9, 2008 10:48
Can someone PLEASE document the development version installation bernd OpenFOAM Installation 76 November 14, 2008 22:51
compile the UDF Li Jingping FLUENT 2 April 14, 2003 21:18


All times are GMT -4. The time now is 02:18.