CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   FLUENT (http://www.cfd-online.com/Forums/fluent/)
-   -   Mesh Projection (http://www.cfd-online.com/Forums/fluent/69298-mesh-projection.html)

trompies October 19, 2009 06:10

Mesh Projection
 
1 Attachment(s)
Hi,

Please help here. I attached a pic of the model. The problem is in the triangular phases. I created face mesh, projected it in the first volume and it worked well. But the problem is when I want to mesh the mid-volume. Apparently there's a problem with the end face where the mesh is projected to. This particular face is face 575 in my model, the error reads as follows: Face face.575 of volume 113 is not appropriate for use as a face to project along. Either it is not submapped or the choice of source faces is incorrect.
In one of the quad volumes, this is separate from the error above, created I got a message saying that the mesh was created. At the end of the mesh message line. There's a message that says the volume contains inverted elements(negative volume).

In this exercise I was trying to refine the previous mesh I used. I don't know if there's a way I could have used to refine the mesh to avoid the situation that I'm in now.

Could you please advise?

Philipov October 19, 2009 07:03

In the triangular region it is difficult to mesh with quad elements and all the sides to have different meshing.... try to correct the number of nodes at each edge to be consistent....

trompies October 19, 2009 08:51

I checked the number of nodes and elements between the source and projection face. The problem is the mid-volume mesh, it's 3 volumes in a row. The first one is the heat source, mid-section is fluid, and the third is heat sink. Generating mesh in the fluid section gives errors that are associated with the face on the heat sink.
When I meshed this volume for the first analysis it was fine. Now that I've refined the mesh I encounter these problems.


All times are GMT -4. The time now is 07:30.