CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > FLUENT

Problem with function Compute_Force_And_Moment

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   December 12, 2009, 17:23
Default Problem with function Compute_Force_And_Moment
  #1
New Member
 
Evaldas
Join Date: Dec 2009
Posts: 1
Rep Power: 0
zedas is on a distinguished road
Hi, Im not very good in english, but I will try to explain my problem.

My work problem is aeroelastic instability in bridge deck which modeled in 2D. Im wrote UDF wich include function Compute_Force_And_Moment. So, problem is that, this function in my udf return same force value like from return>forces in fluent, but moment value from this function is very very lower than report (moment from udf isnt realistic). Center of gravity I set center of profile. Maybe someone had same broblem or know how this function works? Is there another way to get moment of proflie in UDF? Any advise is welcome.

First part of my UDF.

include"udf.h"
#include"f_wall.h"
#include"dynamesh_tools.h"
static real v_y=0.0,omega_z=0.0;
real dy,da;
DEFINE_CG_MOTION(profilis,dt,vel,omega,time,dtime)
{
face_t f;
cell_t c;
real f_glob[ND_ND],m_glob[2],x_cg[ND_ND],theta[ND_ND],dv_y,domega_z;
Domain *domain=Get_Domain(1);
Thread *tf1=Lookup_Thread(domain, 6);
int i;

NV_S(vel, =, 0.0);
NV_S(omega, =, 0.0);
if (!Data_Valid_P())
return;

for(i=0;i<=ND_ND;i++)
{
f_glob[i]=0.0;
m_glob[i]=0.0;
}

for(i=0;i<ND_ND;i++)
{
x_cg[i]=DT_CG(dt)[i];
theta[i]=DT_THETA(dt)[i];
}

Compute_Force_And_Moment (domain, tf1, x_cg, f_glob, m_glob, TRUE);



Message (
"\ntime=%f ,x=%.1f ,y=%.10lf ,theta=%.10lf ,force_y=%.5f ,moment_z=%.10lf ,Vy=%.10lf ,omega_z=%.10lf ,moment_x=%.10lf, moment_y=%.10lf\n",time ,x_cg[0] ,x_cg[1] ,theta[2] ,f_glob[1] ,m_glob[2] ,v_y ,omega_z ,m_glob[0] ,m_glob[1]);
zedas is offline   Reply With Quote

Old   October 15, 2012, 00:36
Default
  #2
New Member
 
Join Date: Mar 2010
Posts: 25
Rep Power: 7
Dorit is on a distinguished road
Hello zedas,

I know it's a long time ago that you sent your post but did you find a solution to your problem? I'm having a very similar problem. My Compute_Force_And_Moment doesn't work.

Thanks,
Dorit
Dorit is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compile problem ivanyao OpenFOAM Running, Solving & CFD 1 October 12, 2012 09:31
LiencubiclowRemodel nzy102 OpenFOAM Bugs 14 January 10, 2012 09:53
Problem with compiling my boundary conditions peita OpenFOAM Running, Solving & CFD 4 February 21, 2008 09:48
DecomposePar links against liblamso0 with OpenMPI jens_klostermann OpenFOAM Bugs 11 June 28, 2007 17:51
HELP! Problem compiling UDF function Syrakus FLUENT 6 April 7, 2006 10:48


All times are GMT -4. The time now is 10:23.