CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > FLUENT

Spalart Allmaras nan error

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   January 22, 2010, 20:43
Default Spalart Allmaras nan error
  #1
New Member
 
Join Date: Sep 2009
Posts: 27
Rep Power: 6
ghost is on a distinguished road
Hi,

I am running a case of injection and suction on the surface of the aerofoil using the Spalart Allmaras model. Mass flow inlet and pressure outlet gauge pressure is set to 0.

I get this error after about 2000 iterations.

"Error: > (greater-than): invalid argument [2]: wrong type [not a number] Error Object: nan"

May I know what is the problem?

Previously I ran a case with inlet gauge pressure of 500Pa, and outlet of 0Pa and there is no such problem.

Thank you

ghost is offline   Reply With Quote

Old   January 23, 2010, 10:58
Default
  #2
New Member
 
Join Date: Sep 2009
Posts: 27
Rep Power: 6
ghost is on a distinguished road
these are the last 3 iterations before the error.

iter continuity x-velocity y-velocity energy nut cl cd time/iter
2489 1.3316e-01 7.3148e-01 9.7446e-01 1.2804e-01 3.3772e-05 1.9984e+01 -1.0886e+00 29:29:07 17511
2490 1.3265e-01 7.3308e-01 9.7280e-01 1.2752e-01 3.3780e-05 1.9979e+01 -1.0898e+00 29:29:46 17510
2491 1.3223e-01 7.3466e-01 9.7201e-01 1.2709e-01 3.3790e-05 1.9974e+01 -1.0911e+00 29:30:39 17509

none of them is approaching 0, so why is there such an error?

appreciate if someone could help. thank you.
ghost is offline   Reply With Quote

Old   January 29, 2010, 09:01
Default
  #3
New Member
 
Join Date: Sep 2009
Posts: 27
Rep Power: 6
ghost is on a distinguished road
can anyone help?
ghost is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compile problem ivanyao OpenFOAM Running, Solving & CFD 1 October 12, 2012 09:31
Problem with compile the setParabolicInlet ivanyao OpenFOAM Running, Solving & CFD 6 September 5, 2008 20:50
DecomposePar links against liblamso0 with OpenMPI jens_klostermann OpenFOAM Bugs 11 June 28, 2007 17:51
user subroutine error CFDUSER CFX 2 December 9, 2006 06:31
Could anybody help me see this error and give help liugx212 OpenFOAM Running, Solving & CFD 3 January 4, 2006 18:07


All times are GMT -4. The time now is 16:09.