CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   FLUENT (http://www.cfd-online.com/Forums/fluent/)
-   -   "divergence detected in AMG solver: omega" (http://www.cfd-online.com/Forums/fluent/77118-divergence-detected-amg-solver-omega.html)

Sidewinder June 14, 2010 05:13

"divergence detected in AMG solver: omega"
 
I am having a problem with my simulation for university. I keep getting this error:

divergence detected in AMG solver: omega

I have tried changing the relaxation factors for the turbulence and the specific dissipation rate. But to no success. the gas is compressbile and I have specified a mass flow inlet and a pressure outlet. I am using the k-omega model for this simulation.
But i cant seem to get away from this error. I am thinking to turn off the energy equation.

Does enybody have some help or hints for me? I would greatly appreciate it.

Thanks!

arunintn March 6, 2012 17:41

Hi,
I have the same error. I'm doing analysis on T106A turbine blade simuli. I think you have the solution for that. If it so please let me know what is the solution.
Thank you :)

arjun3020 March 7, 2012 01:11

in URF go to advance settings, and change the cycle to F.

arunintn March 7, 2012 04:45

Quote:

Originally Posted by arjun3020 (Post 348027)
in URF go to advance settings, and change the cycle to F.

thanks for replying.. I have another problem divergence detected in AMG solver: Temperature". I like to know this troubleshooting method. I quit new to CFD.

arjun3020 March 9, 2012 00:57

Reduce URf for temperature. and check all Boundary conditions. hope it will help.

arunintn March 9, 2012 06:50

I solved the problem.. I made some mistake in boundary.. thank you for you help :)

arjun3020 March 10, 2012 01:15

Ok... these are common errors with fluent, to resolve it 1. check URF.
2. Check BC
3. Change advance cycle to F.

wujinlao5 March 10, 2012 06:33

hi ,man
there are 5 to 6 dropdown list in urf advance setting ,x-momnetum\y-momnetum...
when you say " change cycle to F" for this problem, which one do you refer to?
dont tell me it is the omega relevant one.
Quote:

Originally Posted by arjun3020 (Post 348656)
Ok... these are common errors with fluent, to resolve it 1. check URF.
2. Check BC
3. Change advance cycle to F.


faudiS8 June 9, 2012 10:02

I've the same problem
what do you mean by advanced cycle while there is not such a thing in Under relaxation factors section!?
Thanks for clarification

arunintn June 10, 2012 02:07

Quote:

Originally Posted by faudiS8 (Post 365601)
I've the same problem
what do you mean by advanced cycle while there is not such a thing in Under relaxation factors section!?
Thanks for clarification

you need to find this option in advanced settings and you'll get a pop-up window.

My case i don't need to switch on energy equation because i'm not finding temperature. My problem converged after i switched off the energy equation. If possible you can tell me what you are doing?

faudiS8 June 10, 2012 03:35

Quote:

Originally Posted by arunintn (Post 365648)
you need to find this option in advanced settings and you'll get a pop-up window.

My case i don't need to switch on energy equation because i'm not finding temperature. My problem converged after i switched off the energy equation. If possible you can tell me what you are doing?

hi
I'm modeling combustion and when I change the density calculation method to ideal gas this problem happens. How do I cope with? I let incompressible ideal gas method to iterate enough (about 300) and then it's residuals are little enough. So by changing to ideal gas method, it converges.
but it's still a question for me!
where is the advanced setting option in the window you say!?
Do we talk about the following link's window!?(Under relaxation window)
http://hpce.iitm.ac.in/website/Manua...ution_Controls

thanks alot

arunintn June 10, 2012 04:02

1 Attachment(s)
I have attached a picture file. I think you can find now. Pleas let me know your fluent version. I'm using Fluent 13.

I like to say URF is is an advanced settings. Try to be careful when you work in that.

faudiS8 June 10, 2012 07:57

goood!:)
I found out why! I use Fluent 6.3.26! the last dedicate fluent version:))
Ansys in 13 version change it too much! Also I think This option- means F cycle- is available for multigrid, isn't it?
by the way....thank you for your attachment!:)

faudiS8 June 27, 2012 04:31

hi every body
the problem i found! for changing the solver scheme to F-cycle in fluent 6.3.26 you may go to this path:
Solve>Control>Multigrids...>
here a window will be opened and you may change to F-cycle.

Note: I would appreciate any one who help me to find out the exact mechanism change by this method. In the other words I want to know how this mechanism works, why it diverges, and what does this scheme change do. I heard of a CFD book by someone like choe(?!?) on this. but i'm not sure.


All times are GMT -4. The time now is 02:32.