CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   FLUENT (http://www.cfd-online.com/Forums/fluent/)
-   -   Problem with modelling contact in ansys fluent 12.1 (http://www.cfd-online.com/Forums/fluent/79158-problem-modelling-contact-ansys-fluent-12-1-a.html)

mak86 August 14, 2010 14:29

Problem with modelling contact in ansys fluent 12.1
 
Hi,
I am modelling a 3 zone problem (2 Solid zones and one fluid).
It is consisted of a steel die that is in contact with an aluminium tube which contains a fluid. The die is heated up and as a result the temperature of the tube and fluid goes up.
I am using Ansys 12.1 and I have imported the model from solidworks to ansys workbench fluent.
In the meshing cell the contacts between solids and fluid are defined(automatically) but in the setup cell(fluent), when I try to set the BCs for the contact surfaces to coupled, there is no coupled choice.
I have checked the contacts(at Meshing) several times and everything seems to be ok.
What is the problem?
Thanks

xrs333 August 14, 2010 22:35

The interface between two cell zones -- steel die-alum & alum-fluid -- should be set as the type of wall. On read into fluent, a shadow wall will be created automatically for those two-sided walls repectively. If there is no type of 'wall' in your mesher, just assign any type for the interface, and then change to wall type in fluent.by the way, the situation what you called 'contact' is usually referred to as 'conjugated' heat transfer.

mak86 August 15, 2010 01:39

Quote:

Originally Posted by xrs333 (Post 271506)
The interface between two cell zones -- steel die-alum & alum-fluid -- should be set as the type of wall. On read into fluent, a shadow wall will be created automatically for those two-sided walls repectively. If there is no type of 'wall' in your mesher, just assign any type for the interface, and then change to wall type in fluent.

Dear xrs333,
Thanks for your reply
I know about the shadow walls and I had set the interface type to wall but I think the problem is caused by this:
I have imported the files from solidworks, infact it is a 3 part assembley (at this step) so each part has its own walls. After importing the geometry the contacts are automatically recognized by Ansys Meshing module but fluent does not recognize them as contacts.
So what should I do now?
Thanks for reminding me about the true name, but I used contact because I thought the origin of the problem is in the Meshing cell (defining contacts between parts).
Thanks again for your reply.

xrs333 August 15, 2010 02:26

I guess that the mesh of the wall pair of the contact is non-conformal, that is the nodes on two side do not coincide. Non-conformal interface can be used whether or not non-conformal is the mesh. Try to follow these steps: 1>change the boundary type of the walls on both side of the contact to interface. 2>go to mesh interface panel to define a mesh interface for each contact surface pair with coupled wall option checked.

mak86 August 15, 2010 05:33

Thanks alot.:)

mak86 August 16, 2010 04:20

I tried your solution and it worked but what it will be a little confusing for models with too many parts and contact surfaces.
Is there a better solution?
I mean the Mesher recognizes the contacts but that is ignored by fluent.
What can be done about this?
thanks

xrs333 August 16, 2010 08:24

I use Gambit, but the idea is similar. I usually create the geometry as a whole solid body for all parts, then split it with surfaces into original shape, remember keep 'connected' between different part, and then assign wall boundary type for the interface of the contact parts. These walls will be recognized as 'two-sided wall' because they have cell zone adjacent on both side.

jhthoh February 20, 2011 01:08

Sorry for disturb, can i ask how about 2 zone prob? 1 fluid and 1 solid.
I m doing on car drag coefficient simulation in ANSYS 12.0 Fluent. Do i need to set the car body boundary to interface?

eddiejohn February 20, 2011 11:27

mac86,

I am working on a similar model where i have heat transfer between two solids then a cooling flow over the surface.

I can get each zone to talk to each other by changing walls to interfaces then coupling the wall. This provides a good plot of heat transfer. However when the contours for velocity are plotted, there is no zero velocity boundary layer where the flow passes over the solid, which isnt right.

I would be gratefull for any more experienced users ideas how to overcome this?

Kind regards,

John

nipunkothare July 23, 2012 07:58

hey i`m making a design of 4 tubes- fluid solid solid fluid.
the walls were not getting coupled automatically in fluent
their were no coupled or wall boundaries formed.only interiors.
so i named each surface in the mshr and applied mesh interface in fluent for each coupling(3').
finally i got those boundaries in the boundary condition as interface and 6 walls +3 shadows ( which is as expected) but still i`m getting a calculation error.


can anyone please confirm if it is a coupling error : error in line 199, store still has data

Mahboobe365 June 14, 2013 23:42

i have the same problem,can you explain about mesh interface in fluent?

satishverma November 16, 2013 13:57

while genetaring a wall inside a duct
there is automaticaly a wall shadow is generated in the fluent, which is not desired.
if you have any idea to this problem please share it i will be very thankful.

AlexT December 3, 2013 21:26

Creating a wall shadow from mesh
 
Hey, if someone is interested i solved this issue in the following way:

Fluent recognizes automatically the shadow coupling when the mesh is appropriate, this is, when mesh nodes are aligned.

I tried the creating interface option but this didnt work out to good for me because fluent didnt correctly assign the boundary conditions and created some ficticious extra boundaries.

The solution was to go to the mesh and solve it from there. From what i understand , the mesh was not topologically connected, so this nodes were independent. So, at least in ansys workbench, there is an option to connect mesh, called mesh connection, in the connection tab. This should solve at least some issues.

I think that pinch control also solves mesh tolerance problems, but that is more advanced and from my experience more troublesome to use.

Hope it works,

jpharvey December 4, 2014 00:48

Your problem is that you need conformal meshes across the different regions. This link should explain how to accomplish this:

https://www.sharcnet.ca/Software/Flu...esh_Parts.html


All times are GMT -4. The time now is 06:30.