CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   FLUENT (http://www.cfd-online.com/Forums/fluent/)
-   -   Parallel Error in ANSYS FLUENT 12 (http://www.cfd-online.com/Forums/fluent/79853-parallel-error-ansys-fluent-12-a.html)

zeusxx September 6, 2010 21:59

Parallel Error in ANSYS FLUENT 12
 
I always get error message when I using ANSYS FLUENT 12 with a Windows 7 x64 system and ANSYS 12 x64.



unable to read the cmd header on the pmi context, Undefined dynamic error code.

999999 (..\src\mpsystem.c@1149): mpt_read: failed: errno = 10054

999999: mpt_read: error: read failed trying to read 4 bytes: Invalid argument
unable to read the cmd header on the pmi context, Undefined dynamic error code.
unable to read the cmd header on the pmi context, Undefined dynamic error code.
unable to read the cmd header on the pmi context, Undefined dynamic error code.

job aborted:
rank: node: exit code[: error message]
...
The Parallel FLUENT process could not be started.


-------------------------------------------


999999 (..\src\mpsystem.c@1149): mpt_read: failed: errno = 10054

999999: mpt_read: error: read failed trying to read 4 bytes: No such file or directory
unable to read the cmd header on the pmi context, Undefined dynamic error code.
SuspendThread failed with error 5 for process 2:627A4F0C-CA4B-4435-B90A-4D110B465C35:'D:\ANSYSI~1\v121\v121\fluent\fluent1 2.1.2\win64\3ddp_node\fl_mpi1212.exe -mport 10.10.10.193:10.10.10.193:49174:0 node -mpiw mpich2 -pic ethernet'
unable to suspend process.
unable to read the cmd header on the pmi context, Undefined dynamic error code.
unable to read the cmd header on the pmi context, Undefined dynamic error code.
unable to read the cmd header on the pmi context, Undefined dynamic error code.
received kill command for a pmi context that doesn't exist: unmatched id = 1
received kill command for a pmi context that doesn't exist: unmatched id = 0

job aborted:
rank: node: exit code[: error message]
...
The Parallel FLUENT process could not be started.





Can anyone help me or provide ideas to fix this problem?

Thank you very much~

Stone December 20, 2010 05:31

tem
 
hi ,
did u solve your problem in fluent .
I too got the same problem.If u got the solution please help me.



my email id :dy-369@163.com

thank you!

sunflower December 24, 2010 06:02

Hi Zeusxx,

Have you solved your problem? Actually I have the same problem as yours. If you find the solution, would you please tell me? Thanks.

skinnyfluid January 18, 2011 09:04

Do some PrtScrn (print screen) with your setting up parallel and send me. I can help you only if i see your steps in setup window.

zeusxx January 18, 2011 09:47

thank u very much. I solved this problem several months ago. Thank u all the same.

ADI January 26, 2011 18:34

Same error - How did you solve it?
 
Hello All,

I get the same error only when I run a Composition PDF transport model in the species / transport modelling. Every other model has no problem running in parallel. Can you please tell me how I can solve this problem?

ADI January 26, 2011 18:37

Screen-shot
 
1 Attachment(s)
Here is a screen shot attached.

Kevin.C March 5, 2011 09:06

Hello All,

I got the same problem when I read mesh file in fluent 6.3, and my PC's Cpu is Inter i7 930 which has 8 processes. if all of 8 processes turned on , this problem would appeard. And if less than 7 processes turned on, it will be no problem. But i don't know why.

i think this maybe useful for you.

Kevin. C

ADI March 7, 2011 20:24

Hello Kevin,

I have a Core i7 860 myself and it is the same setup basically. I tried your trick but I was unsuccessful. Let me know what else you had to modify.

Kevin.C March 9, 2011 08:49

Hi,Adi,

Maybe you need to turn off more processers and try again. And i found another route lately, you can setup all options and save case file firstly in single process environment, then iterate it in parallel environment, it will be ok. if still unsccessful, try rebuild your mesh.

Kevin.C

aleisia June 27, 2011 20:11

hi zeuxxx, can you please share with us what you did to solve the problem?
Thanks!

Quote:

Originally Posted by zeusxx (Post 290943)
thank u very much. I solved this problem several months ago. Thank u all the same.


Vaglio August 27, 2011 07:47

Hi,
I know this is the fluent forum, and i0m asking about Star-CCM but my problem is the same when i try to start a parallel simulation in Star-CCM 4.04...
For Fluent is a problem of the software itself or something related to external program like Mpich?

Many Thanks.
Tiziano

Solarberiden June 8, 2012 10:41

possible solution
 
Regulate up your pagefile as follow:

My computer>properties>advanced>Performance>Configura tion>
advanced>modify
Regulate up your possible pagefile scale by 1.0~2.0 time size of physical memory

akshaydongre February 15, 2013 08:48

Having the same problem. Reduced number of processors to 4. Not helping! I am using GRI 2.11 mechanism to describe chemistry.
Is it because the CHEMKIN mechanism which fails when used in parallel FLUENT Version 13.0?

Akshay

amjadfirst March 13, 2013 09:48

Seems to be a problem all around the web but I can't figure out a solution to it. I've got it installed on a number of computers and what I've noticed is that I get this error on AMD processors and Intel ones seem to run fine. Anyone had a similar case?

Error code:

999999 (..\src\mpsystem.c@1149): mpt_read: failed: errno = 10054

999999: mpt_read: error: read failed trying to read 4 bytes: Invalid argument
MPI Application rank 0 exited before MPI_Finalize() with status -1073741819
The Parallel FLUENT process could not be started.

Amjad

zeusxx March 13, 2013 11:10

My solution
 
I am so sorry that I didn't come back this forum for a long time

Now I post my experience and I hope it can help someone

I am not sure whether my experience works well...



if you use Win7, try to go to the [Control Panel] --> [Program and function] --> [Open or Close Windows function]

under the menu, MAKE SURE you select ALL terms in "Microsoft .NET Framework 3.5.1"

then it is OK


Maybe the translation I wrote above is not completely correct, because I use a Win7 in Chinese version. but I think you can understand what I mean

amjadfirst March 13, 2013 14:45

Thanks for your reply, I tried that and didn't work for me :(
I tried restarting the computer and still nothing. Maybe it was a slightly different problem that you had.

Amjad

zeusxx March 14, 2013 00:54

u'd better check UDF
 
Quote:

Originally Posted by amjadfirst (Post 413759)
Thanks for your reply, I tried that and didn't work for me :(
I tried restarting the computer and still nothing. Maybe it was a slightly different problem that you had.

Amjad

maybe u'd better check ur UDF firstly

try to find whether u use codes about UDM or UDS in the UDF, and make sure you open UDM in the DEFINE menu

amjadfirst March 14, 2013 11:17

I don't use UDF's, I haven't actually gotten around to open a case.. I just try to read a mesh or a simple case that I prepared on another computer and nothing opens, same error for everything I try to open.

Kanarya June 18, 2013 06:29

hi,
I have the same problem...what did you mean with 'open UDM in the DEFINE menu' because I am using in define_mass_transfer function C_UDMI but it doesnt work in parallel...

thanks in advance!!!
Quote:

Originally Posted by zeusxx (Post 413844)
maybe u'd better check ur UDF firstly

try to find whether u use codes about UDM or UDS in the UDF, and make sure you open UDM in the DEFINE menu



All times are GMT -4. The time now is 20:35.