CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > FLUENT

MPI problem with fluent

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   October 15, 2010, 01:32
Default MPI problem with fluent
  #1
New Member
 
aryanet
Join Date: Oct 2010
Posts: 5
Rep Power: 7
aryanet is on a distinguished road
Hi there,
I am new to run fluent in linux centOS. I have installed fluent 6.3 on three machines. but when I run the command below:
/data/Fluent.Inc/bin/fluent -g 3d -cnf=/root/host -t4

It ends up with the following output:

Code:
[root@MDS1 ~]# /data/Fluent.Inc/bin/fluent -g 3d -cnf=/root/host -t4
/data/Fluent.Inc/fluent6.3.26/bin/fluent -r6.3.26 -g 3d -cnf=/root/host -t4
/data/Fluent.Inc/fluent6.3.26/cortex/lnamd64/cortex.3.7.3 -f fluent -g (fluent "3d -pethernet  -host -r6.3.26 -t4 -mpi=hp -cnf=/root/host -path/data/Fluent.Inc")
Loading "/data/Fluent.Inc/fluent6.3.26/lib/fluent.dmp.114-64"
Done.
/data/Fluent.Inc/fluent6.3.26/bin/fluent -r6.3.26 3d -pethernet -host -t4 -mpi=hp -cnf=/root/host -path/data/Fluent.Inc -cx MDS1:47715:35420
Starting /data/Fluent.Inc/fluent6.3.26/lnamd64/3d_host/fluent.6.3.26 host -cx MDS1:47715:35420 "(list (rpsetvar (QUOTE parallel/function) "fluent 3d -node -r6.3.26 -t4 -pethernet -mpi=hp -cnf=/root/host ") (rpsetvar (QUOTE parallel/rhost) "") (rpsetvar (QUOTE parallel/ruser) "") (rpsetvar (QUOTE parallel/nprocs_string) "4") (rpsetvar (QUOTE parallel/auto-spawn?) #t) (rpsetvar (QUOTE parallel/trace-level) 0) (rpsetvar (QUOTE parallel/remote-shell) 0) (rpsetvar (QUOTE parallel/path) "/data/Fluent.Inc") (rpsetvar (QUOTE parallel/hostsfile) "/root/host") )"

     Welcome to Fluent 6.3.26

     Copyright 2006 Fluent Inc.
     All Rights Reserved

Loading "/data/Fluent.Inc/fluent6.3.26/lib/flprim.dmp.1119-64"
Done.

Host spawning Node 0 on machine "MDS1" (unix).
/data/Fluent.Inc/fluent6.3.26/bin/fluent -r6.3.26 3d -node -t4 -pethernet -mpi=hp -cnf=/root/host -mport 127.0.0.1:127.0.0.1:45271:0
Starting /data/Fluent.Inc/fluent6.3.26/multiport/mpi/lnamd64/hp/bin/mpirun -TCP -f /tmp/fluent-appfile.16803
mpirun: No route to host
mpirun: Bad file descriptor
I don't know what is wrong with hpmpi!?
aryanet is offline   Reply With Quote

Old   October 22, 2010, 16:02
Default
  #2
Member
 
Basharat
Join Date: Feb 2010
Posts: 37
Rep Power: 8
elbasharat is on a distinguished road
the error is not with your mpi but with the parallel connectivity. check your ssh or rsh then run it again and make sure to stop the firewall. tell me then if you get any error again.
__________________
Rgds
Martin
elbasharat is offline   Reply With Quote

Old   October 23, 2010, 16:39
Unhappy
  #3
New Member
 
aryanet
Join Date: Oct 2010
Posts: 5
Rep Power: 7
aryanet is on a distinguished road
Quote:
Originally Posted by elbasharat View Post
the error is not with your mpi but with the parallel connectivity. check your ssh or rsh then run it again and make sure to stop the firewall. tell me then if you get any error again.
Wooow! thanx, It was a problem with the firewall. But after solving that another problem comes up:

Code:
[root@MDS1 bin]# /data/Fluent.Inc/bin/fluent -g 3d -cnf=/root/host -t2
/data/Fluent.Inc/fluent6.3.26/bin/fluent -r6.3.26 -g 3d -cnf=/root/host -t2
/data/Fluent.Inc/fluent6.3.26/cortex/lnamd64/cortex.3.7.3 -f fluent -g (fluent "3d -pethernet  -host -r6.3.26 -t2 -mpi=hp -cnf=/root/host -path/data/Fluent.Inc")
Loading "/data/Fluent.Inc/fluent6.3.26/lib/fluent.dmp.114-64"
Done.
/data/Fluent.Inc/fluent6.3.26/bin/fluent -r6.3.26 3d -pethernet -host -t2 -mpi=hp -cnf=/root/host -path/data/Fluent.Inc -cx MDS1:44145:40097
Starting /data/Fluent.Inc/fluent6.3.26/lnamd64/3d_host/fluent.6.3.26 host -cx MDS1:44145:40097 "(list (rpsetvar (QUOTE parallel/function) "fluent 3d -node -r6.3.26 -t2 -pethernet -mpi=hp -cnf=/root/host ") (rpsetvar (QUOTE parallel/rhost) "") (rpsetvar (QUOTE parallel/ruser) "") (rpsetvar (QUOTE parallel/nprocs_string) "2") (rpsetvar (QUOTE parallel/auto-spawn?) #t) (rpsetvar (QUOTE parallel/trace-level) 0) (rpsetvar (QUOTE parallel/remote-shell) 0) (rpsetvar (QUOTE parallel/path) "/data/Fluent.Inc") (rpsetvar (QUOTE parallel/hostsfile) "/root/host") )"

     Welcome to Fluent 6.3.26

     Copyright 2006 Fluent Inc.
     All Rights Reserved

Loading "/data/Fluent.Inc/fluent6.3.26/lib/flprim.dmp.1119-64"
Done.

Host spawning Node 0 on machine "MDS1" (unix).
/data/Fluent.Inc/fluent6.3.26/bin/fluent -r6.3.26 3d -node -t2 -pethernet -mpi=hp -cnf=/root/host -mport 127.0.0.1:127.0.0.1:37906:0
Starting /data/Fluent.Inc/fluent6.3.26/multiport/mpi/lnamd64/hp/bin/mpirun -TCP -f /tmp/fluent-appfile.16143
HP-MPI licensed for execution of Fluent.

0: mpt_connect: error: connect failed: Connection refused

0: mpt_establish_connection: error: unable to connect: Illegal seek

0: mpt_connect: error: connect failed: Connection refused

0: mpt_establish_connection: error: unable to connect: Illegal seek

0: mpt_connect: error: connect failed: Connection refused

0: mpt_establish_connection: error: unable to connect: Illegal seek

0: mpt_connect_to_server: error: cannot establish connection; bye.: Illegal seek
MPI Application rank 0 exited before MPI_Finalize() with status 0
By the way, I have installed fluent on both machines!

Would you help plz?
aryanet is offline   Reply With Quote

Old   October 24, 2010, 01:45
Default
  #4
Member
 
Basharat
Join Date: Feb 2010
Posts: 37
Rep Power: 8
elbasharat is on a distinguished road
ok ..


you must check your proper connectivity there not dynamics IP but static.

then if you know about ssh configuration then do it for the parallel computing.

I suggest you to use the -ssh in your command to run fluent. and also do the permissive of SElinux also. sometimes it also stops the suspicious connectivity. anyways do the following and let me know.
cheers
__________________
Rgds
Martin
elbasharat is offline   Reply With Quote

Old   October 24, 2010, 01:57
Default
  #5
New Member
 
aryanet
Join Date: Oct 2010
Posts: 5
Rep Power: 7
aryanet is on a distinguished road
Quote:
Originally Posted by elbasharat View Post
ok ..


you must check your proper connectivity there not dynamics IP but static.

then if you know about ssh configuration then do it for the parallel computing.

I suggest you to use the -ssh in your command to run fluent. and also do the permissive of SElinux also. sometimes it also stops the suspicious connectivity. anyways do the following and let me know.
cheers
Well, I have set all the IP addresses manually and there is no dynamic IP address.
I ran the fluent with -ssh switch, but nothing happened new.
SElinux is completely disabled also.

I've really get stuck...
aryanet is offline   Reply With Quote

Old   October 24, 2010, 05:40
Default
  #6
Member
 
Basharat
Join Date: Feb 2010
Posts: 37
Rep Power: 8
elbasharat is on a distinguished road
ok then check whether your fluent is installed proper i mean there sometimes mpi folder doesnt exist.

I didnt experience that kind of error before.

there must be some human error.
__________________
Rgds
Martin
elbasharat is offline   Reply With Quote

Old   October 24, 2010, 14:37
Default
  #7
New Member
 
Grzegorz Kondora
Join Date: Oct 2010
Posts: 13
Rep Power: 7
kondora is on a distinguished road
Check if MPI is correctly installed. Run FLUENT with -ssh option. Before that do: cd ~; cd .ssh;
ssh-keygen -dsa; {blank passphare - ENTER, ENTER}; cat id_dsa.pub > authorized_keys2; ssh 127.0.0.1; {confirm with yes}; ssh 127.0.1.1; {confirm with yes}; check if you can ssh to 127.0.0.1 and 127.0.1.1 without typing a password. Generally: google -> "ssh without password".
Try: fluent 2d -ssh -mpi=intel when MPI is not working. Hope I helped.
kondora is offline   Reply With Quote

Old   October 24, 2010, 14:45
Default
  #8
New Member
 
Grzegorz Kondora
Join Date: Oct 2010
Posts: 13
Rep Power: 7
kondora is on a distinguished road
Sorry, i didn't read that you are using different machines, so instead of doing ssh without password to localhost, try this: http://linuxproblem.org/art_9.html
kondora is offline   Reply With Quote

Old   October 24, 2010, 15:13
Default
  #9
New Member
 
aryanet
Join Date: Oct 2010
Posts: 5
Rep Power: 7
aryanet is on a distinguished road
Well, I'm sure ssh has configured properly.
But, thanx from your helps.
aryanet is offline   Reply With Quote

Old   December 23, 2015, 13:35
Default
  #10
New Member
 
mohammad
Join Date: Mar 2014
Posts: 14
Rep Power: 4
mmkkeshavarzi is on a distinguished road
Hi
since i am new in Linux,Ubuntu i have some sort of same problem
I try to open Fluent on my device, but i encounter with this error:

999999: mpt_get_dot_address: warning : UNI - SERVER _ > 127.0.0.1 check your system network configuration!

999999: mpt_get_dot_address: warning : UNI - SERVER _ > 127.0.0.1 check your system network configuration!

starting / user/ansys_inc/v150/fluent/fluent15.0.0/(.....), mpirun: rsh: command not found

if anyone can help me to get through this problem i would really appreciate it
thanks in advance
mmkkeshavarzi is offline   Reply With Quote

Old   February 6, 2016, 10:53
Post
  #11
Member
 
John
Join Date: Jul 2011
Location: My home :)
Posts: 70
Rep Power: 6
villager is on a distinguished road
Your problem is possibly solved by adding
Code:
-ssh
switch to the start command/script:
Code:
fluent -ssh ....
If you really want rsh you should have it installed!
Code:
which rsh
should find it. But note, that it is often symlink to ssh. Do not know, if this strange config would work with FLUENT.

Using rsh on Ubuntu:
on each computing node:
Code:
sudo apt-get install rsh-server
sudo apt-get install rsh-client
and on the submit node (if differs from computing node)
Code:
sudo apt-get install rsh-client
Quote:
Originally Posted by mmkkeshavarzi View Post
Hi
since i am new in Linux,Ubuntu i have some sort of same problem
I try to open Fluent on my device, but i encounter with this error:

999999: mpt_get_dot_address: warning : UNI - SERVER _ > 127.0.0.1 check your system network configuration!

999999: mpt_get_dot_address: warning : UNI - SERVER _ > 127.0.0.1 check your system network configuration!

starting / user/ansys_inc/v150/fluent/fluent15.0.0/(.....), mpirun: rsh: command not found

if anyone can help me to get through this problem i would really appreciate it
thanks in advance

Last edited by villager; February 6, 2016 at 11:10. Reason: added info about rsh
villager is offline   Reply With Quote

Old   February 6, 2016, 11:05
Post
  #12
Member
 
John
Join Date: Jul 2011
Location: My home :)
Posts: 70
Rep Power: 6
villager is on a distinguished road
1) The first thing to try is to run without cnf option.
FLUENT would not make him wait to spawn so much process on your current machine, that you specify with -t option:
Code:
 /data/Fluent.Inc/bin/fluent -g 3d -t2
2) The second thing to try is to login to target machines. I suggest using ssh.

E.g., your machines are machine1 and machine2.
Code:
ssh machine1
(should give you shell on this machine without(!!!) any confirmation - i.e., without password, yes/no and soon)
Code:
ssh machine2
(too)
Run via ssh with explicit node list (for example, we would require two processes on each machine):
Code:
 /data/Fluent.Inc/bin/fluent -g 3d -t2 -ssh -cnf=machine1:2,machine2:2
3) The third thing is to use file like you did with "-ssh" option.

You could change ssh to rsh everywhere, though. I didn't use it, but I think the workaround is almost the same.

Cheers, John.

Quote:
Originally Posted by aryanet View Post
Wooow! thanx, It was a problem with the firewall. But after solving that another problem comes up:

Code:
[root@MDS1 bin]# /data/Fluent.Inc/bin/fluent -g 3d -cnf=/root/host -t2
/data/Fluent.Inc/fluent6.3.26/bin/fluent -r6.3.26 -g 3d -cnf=/root/host -t2
/data/Fluent.Inc/fluent6.3.26/cortex/lnamd64/cortex.3.7.3 -f fluent -g (fluent "3d -pethernet  -host -r6.3.26 -t2 -mpi=hp -cnf=/root/host -path/data/Fluent.Inc")
Loading "/data/Fluent.Inc/fluent6.3.26/lib/fluent.dmp.114-64"
Done.
/data/Fluent.Inc/fluent6.3.26/bin/fluent -r6.3.26 3d -pethernet -host -t2 -mpi=hp -cnf=/root/host -path/data/Fluent.Inc -cx MDS1:44145:40097
Starting /data/Fluent.Inc/fluent6.3.26/lnamd64/3d_host/fluent.6.3.26 host -cx MDS1:44145:40097 "(list (rpsetvar (QUOTE parallel/function) "fluent 3d -node -r6.3.26 -t2 -pethernet -mpi=hp -cnf=/root/host ") (rpsetvar (QUOTE parallel/rhost) "") (rpsetvar (QUOTE parallel/ruser) "") (rpsetvar (QUOTE parallel/nprocs_string) "2") (rpsetvar (QUOTE parallel/auto-spawn?) #t) (rpsetvar (QUOTE parallel/trace-level) 0) (rpsetvar (QUOTE parallel/remote-shell) 0) (rpsetvar (QUOTE parallel/path) "/data/Fluent.Inc") (rpsetvar (QUOTE parallel/hostsfile) "/root/host") )"

     Welcome to Fluent 6.3.26

     Copyright 2006 Fluent Inc.
     All Rights Reserved

Loading "/data/Fluent.Inc/fluent6.3.26/lib/flprim.dmp.1119-64"
Done.

Host spawning Node 0 on machine "MDS1" (unix).
/data/Fluent.Inc/fluent6.3.26/bin/fluent -r6.3.26 3d -node -t2 -pethernet -mpi=hp -cnf=/root/host -mport 127.0.0.1:127.0.0.1:37906:0
Starting /data/Fluent.Inc/fluent6.3.26/multiport/mpi/lnamd64/hp/bin/mpirun -TCP -f /tmp/fluent-appfile.16143
HP-MPI licensed for execution of Fluent.

0: mpt_connect: error: connect failed: Connection refused

0: mpt_establish_connection: error: unable to connect: Illegal seek

0: mpt_connect: error: connect failed: Connection refused

0: mpt_establish_connection: error: unable to connect: Illegal seek

0: mpt_connect: error: connect failed: Connection refused

0: mpt_establish_connection: error: unable to connect: Illegal seek

0: mpt_connect_to_server: error: cannot establish connection; bye.: Illegal seek
MPI Application rank 0 exited before MPI_Finalize() with status 0
By the way, I have installed fluent on both machines!

Would you help plz?
villager is offline   Reply With Quote

Old   February 7, 2016, 07:29
Default
  #13
New Member
 
mohammad
Join Date: Mar 2014
Posts: 14
Rep Power: 4
mmkkeshavarzi is on a distinguished road
Thank you Villager, my problem solved


Quote:
Originally Posted by villager View Post
Your problem is possibly solved by adding
Code:
-ssh
switch to the start command/script:
Code:
fluent -ssh ....
If you really want rsh you should have it installed!
Code:
which rsh
should find it. But note, that it is often symlink to ssh. Do not know, if this strange config would work with FLUENT.

Using rsh on Ubuntu:
on each computing node:
Code:
sudo apt-get install rsh-server
sudo apt-get install rsh-client
and on the submit node (if differs from computing node)
Code:
sudo apt-get install rsh-client
mmkkeshavarzi is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem running Fluent on amd64 Manfred FLUENT 10 March 23, 2013 07:47
Problem running fluent with InfiniBand blackpuma FLUENT 11 September 20, 2012 05:35
Fluent boundary conditions problem bobo FLUENT 2 July 3, 2009 06:28
Problem in running fluent 6.3 (64 bit) on ubuntu 8.1 (64 bit) Mir5 FLUENT 3 April 29, 2009 10:32
Problem using parallel Fluent Gustavo FLUENT 0 June 27, 2004 23:12


All times are GMT -4. The time now is 06:49.