CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   Fluent Batch Mode Reg_ Urgent Help Required (

alligngr8 January 9, 2012 14:11

Fluent Batch Mode Reg_ Urgent Help Required
1 Attachment(s)

I am trying to run fluent in batch mode on windows platform. for that I have written batch file as

fluent -g -i case.jou

Howe ever when I run this batch file fluent starts its launcher, reads the journal file. Till that steps it works fine.But after that I need to manually press 'OK' to start fluent.
I have attached snap shot of what I am getting on running the batch file(also in image)

I have tried fluent 3d -g -i case.jou as well as
fluent 3d -gu -i case.jou but in both case same prob.

In fact when I write 3d or 3ddp in in front of -g and press "OK" to start running fluent it shows error that command 3ddp or 3d not recognized. So I intentionally have removed 3d.

But how to counter this.
I mean how to automate that I may not have to press "ok" again and again for multiple cases
Please guide its extremely urgent


stuart23 January 10, 2012 11:29

You should not be using the '-i' flag for running a standard journal file.

Also your syntax is incorrect, you must pipe the journal file into fluent. Try:

fluent 3d -g < yourjournalfile.jou

This is correct for Unix systems, I am unsure if there is a different syntax for Windows.


PS, Please refrain from posting your question in multiple threads next time.

alligngr8 January 10, 2012 12:03

I will keep note of not posting it in multiple forums.I apologize to all members reg same.

Could you please tell me what you mean when you standard journal file.Actually I saw the syntax in their documentation that's why I preferred to go that way. But still I will try what you have mentioned..


stuart23 January 10, 2012 21:52

From what I remember, the "-i" flag is used when you are passing an XML document to Fluent with session parameters. If you are passing just the journal file, you do not need the "-i" flag.

srjp January 12, 2012 09:21

fluent 3ddp -g -i case.jou is a valid batch command for Windows.

You can test this by typing "fluent 3ddp" in Start > Run
and see if Fluent starts.
there may be some problem with the fluent settings in the environmental variables for windows.

All times are GMT -4. The time now is 14:47.