CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > FLUENT

Fluent Batch Mode Reg_ Urgent Help Required

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   January 9, 2012, 14:11
Default Fluent Batch Mode Reg_ Urgent Help Required
  #1
New Member
 
deewakar
Join Date: Dec 2011
Posts: 12
Rep Power: 5
alligngr8 is on a distinguished road
Sir,

I am trying to run fluent in batch mode on windows platform. for that I have written batch file as

fluent -g -i case.jou

Howe ever when I run this batch file fluent starts its launcher, reads the journal file. Till that steps it works fine.But after that I need to manually press 'OK' to start fluent.
I have attached snap shot of what I am getting on running the batch file(also in image)

I have tried fluent 3d -g -i case.jou as well as
fluent 3d -gu -i case.jou but in both case same prob.

In fact when I write 3d or 3ddp in in front of -g and press "OK" to start running fluent it shows error that command 3ddp or 3d not recognized. So I intentionally have removed 3d.

But how to counter this.
I mean how to automate that I may not have to press "ok" again and again for multiple cases
Please guide its extremely urgent


thanks
Attached Images
File Type: jpg Snapshot.JPG (57.3 KB, 17 views)
alligngr8 is offline   Reply With Quote

Old   January 10, 2012, 11:29
Default
  #2
Senior Member
 
Stuart Buckingham
Join Date: May 2010
Location: United Kingdom
Posts: 267
Rep Power: 16
stuart23 will become famous soon enough
You should not be using the '-i' flag for running a standard journal file.

Also your syntax is incorrect, you must pipe the journal file into fluent. Try:

fluent 3d -g < yourjournalfile.jou

This is correct for Unix systems, I am unsure if there is a different syntax for Windows.

Stu

PS, Please refrain from posting your question in multiple threads next time.
stuart23 is offline   Reply With Quote

Old   January 10, 2012, 12:03
Default
  #3
New Member
 
deewakar
Join Date: Dec 2011
Posts: 12
Rep Power: 5
alligngr8 is on a distinguished road
Sir,
I will keep note of not posting it in multiple forums.I apologize to all members reg same.

Could you please tell me what you mean when you standard journal file.Actually I saw the syntax in their documentation that's why I preferred to go that way. But still I will try what you have mentioned..

Thanks
alligngr8 is offline   Reply With Quote

Old   January 10, 2012, 21:52
Default
  #4
Senior Member
 
Stuart Buckingham
Join Date: May 2010
Location: United Kingdom
Posts: 267
Rep Power: 16
stuart23 will become famous soon enough
From what I remember, the "-i" flag is used when you are passing an XML document to Fluent with session parameters. If you are passing just the journal file, you do not need the "-i" flag.
stuart23 is offline   Reply With Quote

Old   January 12, 2012, 09:21
Default
  #5
Member
 
JP
Join Date: Mar 2009
Posts: 57
Rep Power: 9
srjp is on a distinguished road
fluent 3ddp -g -i case.jou is a valid batch command for Windows.

You can test this by typing "fluent 3ddp" in Start > Run
and see if Fluent starts.
there may be some problem with the fluent settings in the environmental variables for windows.
srjp is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stopping a Fluent batch job AND saving the data! Possible? Volker Pawlik FLUENT 7 May 22, 2014 22:30
Batch mode for a VOF Touré FLUENT 1 August 17, 2012 22:48
DPM model in parallel batch mode Prashanth FLUENT 2 March 6, 2009 08:54
how to convert .par to .geomturbo in batch mode xiaoruofu NUMECA 0 December 30, 2004 05:22
Run Fluent in batch mode Shengping LUO FLUENT 2 October 24, 2000 05:42


All times are GMT -4. The time now is 21:44.