CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   FLUENT (http://www.cfd-online.com/Forums/fluent/)
-   -   walls that should be interior (http://www.cfd-online.com/Forums/fluent/96304-walls-should-interior.html)

yochule January 18, 2012 21:10

walls that should be interior
 
3 Attachment(s)
hi guys. i'm working in a VAWT. i did make the mesh in gambit and imported it into fluent. the problem is that i have some interior faces and when i imported the mesh i have walls instead of interior bc.

i have two main zones: the one that its' close to the blades and the other one that's away. i set up a interface in between this two because the interior one is moving while the exterior is fixed. (first attachment)

the problem is in the interior zone. i split the interior face into a lot of faces, so i can have control on the mesh close the airfoil. i liked every straight edges in around the blades so i have "interior bc" when i import the mesh into fluent.
but, with the circular edges i can not link it (because they are not coincident). so as result i have a wal (like this in red thick line in the second attachment).

one solution is to set it as interface without setting the periodic or coupled options. as result i have a lot of errors concerning to this interfase (third screenshot)

what shoul i do? can anybody help me?
thanks!

delaneyluke January 20, 2012 02:03

One problem could be that you have 2 overlapping surfaces at that region and hence FLUENT considers both as walls, try and locate these 2 surfaces and fuse them, FLUENT will automatically create the fused surface as an interior.

Regards
Luke

yochule January 20, 2012 18:55

the solution! and extra question
 
2 Attachment(s)
i could not do that, in the zone list to fuse, i just have the options for inlet, oulet, blades, interfase1, interfase2 and the wall (the inner edges close the blades). so, because i don't have the interior fluid zone in this list i can not fuse it with this walls.
i did do the next. i go back some steps in gambit, and split every circle of the fluid zone in such of parts as i have in the "close to the blades" zones. so i have a circle maded with some (5) arcs pieces. them, i linked every arc with the face's arc around the blade fluid zone. the result work fine when i imported it in fluent.

by the way, i did run the problem in fluent and i have like a error zone close to the interface (i think). i did make a mesh refinement and the weird velocity distribution persist. what should i do?

-mAx- January 23, 2012 03:06

connection problem.
To persuade you: in gambit select one small disk and move it with a translation vector.
If gambit does it without error, then your 2 domains aren t connected (and then at the "interface" between both domains, you have superposed edges (circles) treated as wall in Fluent.

mali28 January 23, 2012 14:11

Quote:

Originally Posted by yochule (Post 340386)
i could not do that, in the zone list to fuse, i just have the options for inlet, oulet, blades, interfase1, interfase2 and the wall (the inner edges close the blades). so, because i don't have the interior fluid zone in this list i can not fuse it with this walls.
i did do the next. i go back some steps in gambit, and split every circle of the fluid zone in such of parts as i have in the "close to the blades" zones. so i have a circle maded with some (5) arcs pieces. them, i linked every arc with the face's arc around the blade fluid zone. the result work fine when i imported it in fluent.

by the way, i did run the problem in fluent and i have like a error zone close to the interface (i think). i did make a mesh refinement and the weird velocity distribution persist. what should i do?


You have to connect the faces that are overlapping, otherwise when you export the mesh Fluent will treat the overlapping faces as wall.

yochule January 23, 2012 17:33

hi guys
-mAx- : that's a good way to be sure about that. i did fix the problem (last post), but i'd try your suggestion and it's totally true: you can not move it if it is connected.
mali28: thanks. but i'd know which the problem was. the issue it was that i did not make any idea how to fix it. but i finally did.

so, muchas gracias chi@os. suerte con sus simulaciones!


All times are GMT -4. The time now is 10:23.