CFD Online Discussion Forums

CFD Online Discussion Forums (
-   Hardware (
-   -   Performance AMD Processor (

-mAx- January 14, 2013 02:53

Performance AMD Processor
I am in front of an issue.
I have an HP Proliant DL785 G6 (8x Sixcore AMD Opteron 8439-SE) at my disposal, and I ran several tests on it (OF on caelinux - Ubuntu 10.04)
But unfortunately the performance are very disappointing in comparison with Intel Processors. Some results here:

In summary, a run on a HP-Z420 (Intel Xeon E5-1620 @ 3.6GHz) with 8 Cores (although this is a quadcore processor) is almost 3 times faster than same run on 26 cores (Proliant)
Any idea? :rolleyes:

CapSizer January 14, 2013 09:24

Well, you are not really giving enough information. There are many things which can affect the results that you are getting. For one thing, small benchmark problems don't do well on many cores. You also cannot expect a 2009 era CPU to be competitive with a modern one, quite apart from the fact that the current generation Intel processors are particularly good. There have been big advances in memory architecture, for example. As a rule of thumb, my experience is that you do better with new low end hardware than obsolete heavy duty equipment.

-mAx- January 14, 2013 09:43

Thanks for answering.
I did benchmarks from 100K till 10 millions cells mesh, and watched especially speed up for my largest mesh.
I am aware that there are many factors which may influence the speedup, but I always proceed in same maner each time I want to test a hardware: install caelinux, copy case, and run
Now what you write makes also sense, but I never thought this Proliant was already obsolete. And more, the results on this Proliant are at same order than my OLD P4 Cluster (4x Intel P4 3.2GHz - 5x P4 3.0GHz - 2x P4 2.8GHz - 2x P4 2GHz - 1x P4 1GHz) with Gigabit/s switch.
This last comparison is disturbing me

CapSizer January 14, 2013 09:57


Originally Posted by -mAx- (Post 401737)
Thanks for answering.
.... I never thought this Proliant was already obsolete. ....

There is always a temptation to buy old used server hardware for a fraction of the original price. On paper such a system looks good, and the quality of the hardware is such that it will probably give you troublefree service for several years. Unfortunately, hardware technology advances so quickly that you just end up with a noisy hot system that uses a lot of power and is slower than a modern commodity desktop (or cluster of desktops).

-mAx- January 14, 2013 10:03

I agree
But it cannot be slower than a more older desktop cluster (4x Intel P4 3.2GHz - 5x P4 3.0GHz - 2x P4 2.8GHz - 2x P4 2GHz - 1x P4 1GHz), isn't it?

scipy January 14, 2013 10:45


Originally Posted by -mAx- (Post 401663)
Any idea? :rolleyes:

Throw that shit out onto the street, set it on fire, pee on it and then do a little dance. Then go get yourself what I already mentioned in the URL you've listed.

I'm on fire with advice today. :D

On a serious note: you shouldn't be so surprised.. realize that the OLD Opteron (no matter how impressive 8 processors with 6 cores each might sound) is still built around several generations old architecture (45 nm) and uses DUAL CHANNEL DDR2 of all things. :) You could have 75 processors and they'd all still bottleneck at the goddamn dual channel DDR2. In fact, I'd bet it's not even DDR2-800 MHz, prolly some "server grade" slowpoke of 667 or even lower.

Replace the dinosaur and have a nice day.

-mAx- January 14, 2013 12:59

And I thought my IT-department gave me something hot... :rolleyes:

CapSizer January 14, 2013 18:02


Originally Posted by scipy (Post 401761)
Replace the dinosaur and have a nice day.

Back in the late 1980's our department invested heavily in some state of the art Apollo workstations. Problem was, three years later they were really only good for propping the lab door open, as the new cheap 486's simply blew them away. It was actually fun watching the head of department's agony as he tried desperately to convince people to continue using the dinosaurs that he had blown his budget on only three years earlier :)

abdul099 January 18, 2013 19:19

Haha, I don't want to mention what our current Sandy Bridge E cluster is doing with our older X5550 cluster - and that was pretty fast compared to the even older AMD cluster. It was just two or two and a half years between the purchase of each of them.

It's like seeing my "old" (2.5 years) 8-core workstation suffering benchmarks against a "new" (6 months) 6-core workstation, just because the CPU is faster for the newer one. And the 8-core (X5550) workstation is still almost twice as fast compared to my 4-core desktop (Phenom II 956) at home (when running both on 4 cores).

So never underestimate how fast computer hardware can be outdated, even when it's not really old hardware.

wyldckat January 18, 2013 19:55

Greetings to all!


Originally Posted by -mAx- (Post 401787)
And I thought my IT-department gave me something hot... :rolleyes:

After reading the whole thread and the other one about the various benchmark results, I've got a feeling that you haven't properly pushed that machine to its real limits. I say this because:
  1. You mentioned CAE Linux, namely Ubuntu 10.04. You don't specify which exact version and build of OpenFOAM you've used, so I'm going to assume you tested with the one that came with CAE Linux. Long story short: if you didn't build OpenFOAM from source, then it isn't optimized for your machine.
    Additionally, Ubuntu 10.04 is a bit old right now, so you might want to get a more recent version that has a more up-to-date GCC, so that you can try and take more advantage of the latest compiler options.
  2. On the other thread, you gave this description: AMD SixCore Opteron 8439SE 2.8GHz (Server WMWare) - does this mean that you used virtualization software to run CAE Linux?
  3. Ubuntu+OpenFOAM architecture: 32bit or 64bit, which one did you use?
  4. I know there is a thread on this sub-forum that talks about AMD processors and poor performance in CFD applications... it's this one: - post #5 points to a page that shows a trick in the BIOS that seems to unleash some additional firepower, but it's not a silver bullet.
    Either way, it's been a year and a couple of months since that post and Intel processors already had more prestige than AMD ones...
Best regards,

-mAx- January 21, 2013 02:55

Hello Bruno thanks for replying,
I will try to reply to each point:

1. For sure I dind't rebuild OpenFOAM from source, but I also didn't do it on the other machines (desktop). Worst : on the Intel Xeon E5-1620 (HP Z420) I couldn't install caelinux, so I only started on a old OpenSuse with old OF (OS installed for another old desktop; I mean I took the harddisk from old desktop and I placed it on Z420. Then boot and run...)

2. Yes I forgot to mention, that caelinux is installed on Virtual Machines (VM Ware)

3. 64 bit

4. I have no chance to do some tricks with BIOS on the server ( disinclined IT). The server isn't reserved only for CFD, and I don't know exactly what IT is doing with this server.
Else for sure, I already would have installed latest Linux disto with latest OF (no VM) :rolleyes:

All times are GMT -4. The time now is 00:45.