CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   Hardware (http://www.cfd-online.com/Forums/hardware/)
-   -   Slow CFD (http://www.cfd-online.com/Forums/hardware/83875-slow-cfd.html)

ad281 January 13, 2011 14:57

Slow CFD
 
Hi,
I am a final year Mech. Eng. student performing CFD simulations for my thesis. I am running several versions of a 2D simulation. They are transient and are each taking about 24 hours to solve.
My issue is that, when I look at my computer's performance while running the solver, I can see that only half of the RAM is operating. The solver is taking up over 500MB of RAM, but I'd like it to be able to take up more, to improve computation time.
I know it's not an issue with a slow CPU, as this is running between 50% and 70%.
I use 32-bit architecture, 667Hz and 4GB RAM.
I would appreciate any suggestions on how i can improve compute time.
Thanks.

Adren022 January 15, 2011 05:52

generally limiting the number of process running in the background and using a larger pagefile size should help speed things

but it still depends on the speed/core of your processor...faster the speed less computational time

ad281 January 15, 2011 07:43

I get what you're saying, but the issue isn't really with trying to procure available memory, it's more to do with the fact that the CPU and RAM are only running at about 50% of their full capacity when running CFD. I want to be able to get the program to take up more RAM and CPU.

sail January 15, 2011 22:12

wich operative system are you using?

wich is the size of the mesh? are you using multicore paralleling?

ComputerGuy January 16, 2011 00:46

Sounds like you're not running parallel. Fluent will grind your machine to a halt, both in terms of RAM and CPU, if you're giving it the necessary resources. Additionally, 32-bit windows can only address 2 GB of the available (almost) 4 gb of RAM, unless the /3GB switch is used in the Boot.ini file.

See the following: http://www.microsoft.com/whdc/system...ae/paemem.mspx

for more info.

ComputerGuy

Quote:

Originally Posted by ad281 (Post 290536)
I get what you're saying, but the issue isn't really with trying to procure available memory, it's more to do with the fact that the CPU and RAM are only running at about 50% of their full capacity when running CFD. I want to be able to get the program to take up more RAM and CPU.


ad281 January 16, 2011 06:47

Quote:

Originally Posted by sail (Post 290590)
wich operative system are you using?

wich is the size of the mesh? are you using multicore paralleling?

What do you mean by operative system? Like the programme? I'm using ANSYS-CFX.
The mesh is generally around 200,000-300,000 nodes.
I'm actually doing the simulations on my own HP pavillion laptop, it has only a single-core processor.

daveatstyacht January 20, 2011 17:40

In answer to your question, the operating system would be the overarching system your computer is using. Examples would include windows (xp, vista, 7, etc), Linux operating systems like Debian, Ubuntu, Fedora. It sounds like you are using windows if you are using CFX on single core. As an aside I have found that when programs try and exceed the memory usage limit of a 32 bit windows OS, it tends to crash the program or windows.

RossFS January 28, 2011 21:23

Quote:

Originally Posted by ad281 (Post 290608)
'm using ANSYS-CFX.
The mesh is generally around 200,000-300,000 nodes.

If the mesh isn't sufficiently large to warrant the use of more RAM, the computer won't use it as it doesn't need it.
Consider reading up on the various settings you can set just before starting the simulation in xref.pdf or xmod.pdf or the like in the ANSYS directory (not in the most logical location).

Another thing to check when running CFX is whether you have a process running called java.exe (via task manager). On our machines at uni (dual core) this process would sit in the background (generated via CFX to run the news updates I think) and gobble around 50% of the total CPU power of the machine. Killing this process off had no ill effect other than making a lot more processing power available.

ad281 January 29, 2011 10:15

That explains it.
Thanks man.


All times are GMT -4. The time now is 18:03.