CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   Hardware (http://www.cfd-online.com/Forums/hardware/)
-   -   Rocks 5.4 Rsh Connection Refused for Fluent 6.3 (http://www.cfd-online.com/Forums/hardware/91130-rocks-5-4-rsh-connection-refused-fluent-6-3-a.html)

bucnikf90 August 1, 2011 11:03

Rocks 5.4 Rsh Connection Refused for Fluent 6.3
 
Dear All,
I am new to CFD and for linux. I have a 8 node machine. I was advised that I should install a cluster software for performing fluent 6.3 version in parallel.
I have installed rocks 5.4 on the frontend and subsequently installed on all the 8 nodes. I have checked the interconnectivity with ganglia and all the nodes are up.
I have then installed on fluent 6.3.26 on the frontend. when I run fluent in parallel i get rsh connection refused error.
I have researched a bit on that on internet and found that by default rsh is disabled in rocks and need to be enabled. I have setup a .rhosts file, hosts.equiv file, changed the settings in pam.d directory, installed rsh server, disabled firewall. Still the fluent does not work. I have even tried rsh on the bash prompt. still the same error. initially the error says that krb5 is refused, the krb4 is refused then normal rlogin is refused.
I have tried ssh it works fine with password. i linked rsh and ssh by ln command. still i get connection refused. When I try rsh from the nodes to the frontend somehow it works. again between nodes rsh doesnot work.
please suggest what I am supposed to do. Any other cluster software which is a bit user friendly. I am more interested in running fluent than working on the operating system.

kami146 March 29, 2012 05:00

Dear

I am facing same problem as u, but i change the script to use ssh instead of rsh, i.e. add -ssh in your fluent command script to run job using ssh. in this way my job runs smoothly & got the results.

CapSizer March 29, 2012 17:24

Quote:

Originally Posted by bucnikf90 (Post 318327)
Dear All,
--- snip ---
I have installed rocks 5.4 on the frontend and subsequently installed on all the 8 nodes. I have checked the interconnectivity with ganglia and all the nodes are up.
I have then installed on fluent 6.3.26 on the frontend. when I run fluent in parallel i get rsh connection refused error.
I have researched a bit on that on internet and found that by default rsh is disabled in rocks and need to be enabled. I have setup a .rhosts file, hosts.equiv file, changed the settings in pam.d directory, installed rsh server, disabled firewall. Still the fluent does not work.
---snip--
I am more interested in running fluent than working on the operating system.

OK, the first thing you need to realise is that you shouldn't fiddle with those permissions and settings if you are using Rocks - you will break the system. If you are going to do this manually, just install the equivalent Centos or Scientific Linux and tweak it from there. Do not mess around with Rocks settings and permissions if you don't know exactly how Rocks works. You may detect the voice of experience here. Having said that, a straightforward Rocks installation (start from scratch) works fine with fluent, just add -ssh in the script, as described by kami146.


All times are GMT -4. The time now is 12:19.