CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   Main CFD Forum (http://www.cfd-online.com/Forums/main/)
-   -   On Parallel ? (http://www.cfd-online.com/Forums/main/12953-parallel.html)

Kate Frack February 8, 2007 10:30

On Parallel ?
 
Dear Dr.

On runing a program compiled by CHARMC, the information on the terminal look as follows:

$ charmrun +p2 ++debug ++nodelist ./nodes ./sq1 Charmrun> charmrun started... Charmrun> using ./nodes as nodesfile Charmrun> adding client 0: "node1", IP:192.168.0.1 Charmrun> adding client 1: "node2", IP:192.168.0.2 Charmrun> Charmrun = 192.168.0.1, port = 32865 Charmrun> Sending "0 192.168.0.1 32865 17477 0" to client 0. Charmrun> find the node program "./sq1" at "/export/home/srms/sq1" for 0. Charmrun> Starting rsh node1 -l srms /bin/sh -f Charmrun> rsh (node1:0) started Charmrun> Sending "1 192.168.0.1 32865 17477 0" to client 1. Charmrun> find the node program "./sq1" at "/export/home/srms/sq1" for 1. Charmrun> Starting rsh node2 -l srms /bin/sh -f Charmrun> rsh (node2:1) started Charmrun> node programs all started Charmrun> waiting for rsh (node1:0), pid 17478 Charmrun> waiting for rsh (node2:1), pid 17481 Charmrun> Waiting for 0-th client to connect. Charmrun rsh(node1.0)> remote responding... Charmrun rsh(node1.0)> using xterm /usr/X11R6/bin/xterm Charmrun rsh(node1.0)> using debugger /usr/bin/gdb Charmrun rsh(node2.1)> remote responding... Charmrun rsh(node2.1)> using xterm /usr/X11R6/bin/xterm Charmrun rsh(node2.1)> using debugger /usr/bin/gdb /usr/X11R6/bin/xrdb: Connection refused /usr/X11R6/bin/xrdb: Can't open display '192.168.0.1:0.0' Charmrun rsh(node1.0)> Cannot contact X Server 192.168.0.1:0.0. You probably Charmrun rsh(node1.0)> need to run xhost to authorize connections. Charmrun rsh(node1.0)> (See manual for xhost for security issues) Charmrun rsh(node1.0)> Exiting with error code 1 /usr/X11R6/bin/xrdb: Connection refused /usr/X11R6/bin/xrdb: Can't open display '192.168.0.1:0.0' Charmrun rsh(node2.1)> Cannot contact X Server 192.168.0.1:0.0. You probably Charmrun rsh(node2.1)> need to run xhost to authorize connections. Charmrun rsh(node2.1)> (See manual for xhost for security issues) Charmrun rsh(node2.1)> Exiting with error code 1

I can I resolve this problem???


All times are GMT -4. The time now is 05:04.