CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Main CFD Forum

blockMesh error

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   May 24, 2009, 16:21
Default blockMesh error
  #1
New Member
 
Join Date: May 2009
Posts: 8
Rep Power: 9
JohanOlivier is on a distinguished road
Good day,

When I try to run the cavity tutorial in icoFoam, i get the following error when running blockMesh:

/*---------------------------------------------------------------------------*\
| ========= | |
| \\ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \\ / O peration | Version: 1.5 |
| \\ / A nd | Web: http://www.OpenFOAM.org |
| \\/ M anipulation | |
\*---------------------------------------------------------------------------*/
Exec : blockMesh
Date : May 22 2009
Time : 23:01:49
Host : johano-laptop
PID : 15708
Case : /home/johano/OpenFOAM/johano-1.5/FOAM_RUN/tutorials/icoFoam/cavity/constant/polyMesh
nProcs : 1

// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
Create time



cannot open file

file: /home/johano/OpenFOAM/johano-1.5/FOAM_RUN/tutorials/icoFoam/cavity/constant/polyMesh/system/controlDict at line 0.

From function regIOobject::readStream(const word&)
in file db/regIOobject/regIOobjectRead.C at line 66.

FOAM exiting


Anyone knows what the problem might be? I cannot find the "..system/controlDict" directory within polyMesh... maybe that is the problem..but how do i get around this?

Thank you.
JohanOlivier is offline   Reply With Quote

Old   May 25, 2009, 03:01
Smile
  #2
Senior Member
 
Ahmed
Join Date: Mar 2009
Location: NY
Posts: 251
Rep Power: 10
Ahmed is on a distinguished road
I am not an expert OpenFOAM user, but I checked the directory structure of the cavity problem on my computer, the file you are missing is into the directory /cavity/system/
I guess you need to check your PATH
Let us Know if that helps and Good Luck
Ahmed is offline   Reply With Quote

Old   May 26, 2009, 10:13
Default
  #3
Senior Member
 
N/A
Join Date: Mar 2009
Posts: 189
Rep Power: 9
harishg is on a distinguished road
You have to be in the cavity directory when you run the case. The problem is your pwd is polyMesh directory. change your directory and run

/home/johano/OpenFOAM/johano-1.5/FOAM_RUN/tutorials/icoFoam/cavity

not

/home/johano/OpenFOAM/johano-1.5/FOAM_RUN/tutorials/icoFoam/cavity/constant/polyMesh
harishg is offline   Reply With Quote

Old   May 28, 2009, 16:21
Default
  #4
New Member
 
Join Date: May 2009
Posts: 8
Rep Power: 9
JohanOlivier is on a distinguished road
Thank you harishg!
JohanOlivier is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compile problem ivanyao OpenFOAM Running, Solving & CFD 1 October 12, 2012 09:31
Problem with compile the setParabolicInlet ivanyao OpenFOAM Running, Solving & CFD 6 September 5, 2008 20:50
Compiling problems with hello worldC fw407 OpenFOAM Installation 21 January 6, 2008 18:38
DecomposePar links against liblamso0 with OpenMPI jens_klostermann OpenFOAM Bugs 11 June 28, 2007 17:51
user subroutine error CFDUSER CFX 2 December 9, 2006 07:31


All times are GMT -4. The time now is 07:19.