CFD Online Discussion Forums

CFD Online Discussion Forums (
-   NUMECA (
-   -   AutoGrid5 Axial Turbine Meshing Error (

zoeburton1987 July 13, 2012 12:43

AutoGrid5 Axial Turbine Meshing Error
1 Attachment(s)
I am currently meshing a last steam turbine stage in AutoGrid5. I have generated meshes using the Basic Mode but have encountered an error as there is a significant overlap between the stator outlet and rotor inlet - shown in attached image and I'm getting the error "overlap in row: row2". I assume this stems from the automatic definition of the stator/rotor interface but I don't know how to fix it.

I imported the stator and rotor blade surfaces with accompanying single curve defining the hub and another single curve defining the shroud from an .igs file create in Solidworks.

Does anyone have any suggestions on how I can fix this?

Thanks in advance :)


Hamidzoka July 13, 2012 14:06

Dear Zoe;
please give a more detailed description of your meshing process in Autogrid5.
however, this error is not usual. normally, when you import the blade geometries, hub and shroud curves, if the blades intersect with hub and shroud curves, a default interface curve will be generated per each rotor-stator interface. in other words it is quite an automatic process! so more information about the method you have applied is needed.

zoeburton1987 July 13, 2012 15:08

Hi Hamid,

Thank you so much for getting back in touch!

I added an additional row (in FINE/Turbo) and selected row 1 and selected to import form CAD. From here I selected the pressure and suction surfaces of the blade and linked them to the Main Blade in row 1. I linked the leading edge curve to the leading edge and the same with the trailing edge. I selected the hub contour and linked to the hub and the same with the shroud.

I then selected row 2 and selected the pressure and suction surfaces of the blade and linked them to the Main Blade in row 2 and the same with the leading and trailing edges - as I did with row 1. I then selected the hub contour (which spans the whole stage/diffuser and the same curve I selected for the stator/row1blade) and linked this to the hub and the same with the shroud contour. I wondered if this was the right approach as I was effectively defining the hub and shroud contours twice? I wondered if I should have had two separate contours, one for the stator hub and one for the rotor hub?

I then moved the stage outlet positioning to the Z location I required (further upstream) - but am I right in thinking this wouldn't effect the rotor/stator interface location?

I then went through the Row Wizard process for the stator - but didn't generate a 3D Mesh and repeated the same process for the rotor - this was where the errors began to appear. Do you need more details of this process - i.e. the number of spanwise grid points etc? Is it during this process that the rotor/stator interface position is defined?

Once again thank you so much for your help.


Hamidzoka July 14, 2012 01:06

Dear Zoe;
please note that hub and shroud curves are just defined one time. in other words you do not need to redefine it when introducing the second blade row.
one more thing that comes to my mind is that did you specifiy the number of blades per each row? when you work with .igs files you should consider it carefully. please check this simply by right click on row1>properties.

zoeburton1987 July 16, 2012 10:15

1 Attachment(s)
Hamid, thank you so so much for your help, this solved my problem and defining the hub and shroud once means I now have a mesh which doesn't overlap.

Just another quick question, my .igs files are defined in mm, and so when I import the geometries from the CAD file, the software requires I change the units in the menu to mm. Does this therefore mean that when I am using the Row Wizard, all the dimensions are in mm and not m? i.e. for setting the wall cell width and the tip gap? I have made this change when using the row wizard but wanted to check that I had done this correctly, i.e. my first cell width is defined as 0.213 (mm) rather than 0.000213 m.

I've got some negative cells, but thought I had defined sensible cell counts, spanwise cells and wall cell widths. I wondered if you had any thoughts on this?

I set up as follows:
STATOR: 61 spanwise cells, 0.314 mm first wall cell width giving an expansion of 1.232647. Reducing the level to -5 gave 480863 cells, with a minimum skewness of 48.879 and a min expansion of 1.441.

ROTOR: 4.2mm tip gap from leading edge to trailing edge, with 89 spanwise cells and a 0.213mm first wall cell width giving an expansion of 1.238. This gave a minimum skewness of 40.5 and a max expansion of 1.771.

I've attached the quality report for reference.

Thank you once again for all your help.


Hamidzoka July 16, 2012 23:10

Dear Zoe;
Regarding the dimensions you did the right thing. All lengths are in mm.
Regarding the negative cells, if you have a look on the image you have attached you can see that row 1 has no negative cell and all 87 negative cells exists in row2.
this is probably due to the gap region mesh settings. try changing mesh parameters in the gap region. number of spanwise elements in both tip gap and the blade its self has great influence on it.
please note that this is in fact a try and error process!


zoeburton1987 July 17, 2012 12:26

2 Attachment(s)

Once again thank you so much for your suggestions! Another productive day in the office and thanks to your pointers, I have successfully eliminated the negative cells in the tip region of row 2.

I moved the "Expert Mode" which gave greater control over the tip mesh. However, I have a dramatically different blade profile at the hub to at the tip and I have highly skewed cells in the hub region, shown in the attached file. Is there any way to control the clustering along the blade? I've tried various optimisations with no success.

I've experimented all afternoon and found that changing the topology gave the best hub mesh with HOH topology (rather than default used in the above example), however I do not have the same control over the trailing edge location, and as shown in the 2nd attached image, it is not in the right place. In my geometry file, the trailing edge curve does not spilt the trailing edge exactly in half (something I have not been able to change since I got the geometry over a year ago). I have also experimented with the "Blade Points Distribution" - also shown in the attached figure - but again have not been able to successfully move the trailing edge location as I did previously with 'the red dot'.

Any further advice would be greatly appreciated. Thank you so much once again for your time and consideration on the problem :)

zoeburton1987 July 17, 2012 13:22

Hamid, I stumbled across something useful in the manual - by turning off the "Highly Staggered Blade Optimisation" I was able to reduce the highly skewed cell at the hub and generate a high quality mesh.

Thank you once agian for all your help!


Hamidzoka July 17, 2012 23:21

Dear Zoe;
glad to hear that!
normally HOH configuration is a better choice for highly staggered profiles


All times are GMT -4. The time now is 21:36.