CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Bugs (http://www.cfd-online.com/Forums/openfoam-bugs/)
-   -   OpenFOAM-2.1 instability problems? (http://www.cfd-online.com/Forums/openfoam-bugs/102222-openfoam-2-1-instability-problems.html)

aliqasemi May 25, 2012 07:35

OpenFOAM-2.1 instability problems?
 
I had some problems with using OpenFOAM-2.1, and I was wondering if anybody else had similar problems, or if they have worked on finding the solution.

I have noticed when I run my two phase simulations using OpenFOAM-2.1 they are more prone to instability, specially when run in parallel. When using the OpenFOAM-1.6-extend, however, my simulation are more stable,

The instabilities occur after some time from the beginning of the simulation and appear in terms of some non-physical velocities slowly increasing and finally destroying the simulation results. When I run my code in serial if I just use smaller time-steps then the simulations are less likely to diverge. I haven't seen these instabilities when using OF-1.6-ext. So my first question is what has made the OF-1.6-ext more stable. It should be some improvements in discretization algorithms, but it would be great if we know more exactly what are these improvements.

There is another problem which is more an issue for me. It happens when using OF-2.1 in parallel, where I have seen instabilities mainly occurring in the processor boundaries. This time the problem can be due to a looser coupling of the linear equation solvers (I use GAMG most of the times), or maybe improper handling of the boundary conditions. I don't have this problem when using OF-1.6-ext, with identical algorithm, so this is not a problem with my code. My simulations are two-phase flow at low capillary numbers, and these instabilities happen when capillary forces are active on the processor boundaries.

At this time, I use OF-2.1 for preprocessing and post processing, while OF-1.6-ext for running my simulations. So it is not that bad, but it would be better if I could figure out what is the problem.

Is there anybody else having similar problems?

olivierG May 25, 2012 07:55

hello,

If i remember correctely, Co calculation has changed with the 2.0/2.1 version, so this may be a starting point to investigate : try with lower time step and compare with 1.6-ext .

regards,
olivier

wyldckat May 25, 2012 16:42

Greetings to both of you!

I knew I had seen reports about this sometime ago in OpenFOAM.org bug tracker and here they are:
Best regards,
Bruno

alberto May 26, 2012 15:07

What solver(s) is showing this problem? InterFoam?

aliqasemi May 26, 2012 16:38

Dear Alberto, Bruno and Olivier

Thanks for your help. The modification on Courant number calculation can explain my problem, or part of it at least. I didn't know about it and were using the same maxCo for both OF1.6 and the OF2.1. Nevertheless, I have put an additional constraint on time step size myself, so I need to check to see whether fixing this solves the problem.

The code is something based on the interFoam code, but heavily modified.

I will test this out further and post back.

Thanks again,
Ali

aliqasemi September 24, 2012 13:23

update
 
Just to confirm that this problem is NOT due to the time-step size. I have to mention that this happens for parallel cases; the difference is not that significant for the single-CPU simulations. I suspect it is due to the linear eqn solver (the computed pressure is different from the beginning of the simulation), or I may have done something with the boundary conditions which is not consistent with the new version. Anyway, I rather stick to the old OF for now; I might spend more time on this if I have got the time.


All times are GMT -4. The time now is 02:07.