CFD Online Logo CFD Online URL
Home > Forums > OpenFOAM Bugs

Strange results in damBreak4phase using multiphaseInteFoam from foam-extend-3.1

Register Blogs Members List Search Today's Posts Mark Forums Read

LinkBack Thread Tools Display Modes
Old   July 30, 2015, 07:33
Default Strange results in damBreak4phase using multiphaseInteFoam from foam-extend-3.1
New Member
Join Date: Mar 2010
Posts: 1
Rep Power: 0
guin is on a distinguished road
I faced a strange behaviour of multiphaseInterFoam in the damBreak4phase case during a benchmark test. The results seem too chaotic to me and I have the impression that they also get influenced by the cells with different form factor at the middle section. Apart from that, the calculation takes around 10 times longer than using OF-2.1.1 or OF2.3.1 with the same machine. I am more familiar with ESI's OpenFOAM release and from what I perceive in the multiphaseMixture class there is a remarkable difference in the way solveAlphas() is structured. I wonder whether multiphaseMixture class is up to date or if in contrast any bug correction might be lost in the course of the code migration from OpenFOAM-1.3...

The issue can be reproduced using the damBreak4phase tutorial case provided in foam-extend-3.1 without any modification. Apparently I am not the first who did such benchmark, since there are a couple of videos in youtube showing the same comparison:
coarse case:
fine case:
guin is offline   Reply With Quote


dambreak4phase, foam-extend-3.1, multiphaseintefoam

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
simpleFoam parallel AndrewMortimer OpenFOAM Running, Solving & CFD 12 August 7, 2015 18:45
Incompatible dimensions for operation ruben23 OpenFOAM Running, Solving & CFD 2 June 12, 2015 04:14
refineWallLayer Error Yuby OpenFOAM Meshing & Mesh Conversion 0 April 27, 2015 18:25
problem during mpi in server: expected Scalar, found on line 0 the word 'nan' muth OpenFOAM Running, Solving & CFD 2 April 10, 2015 05:42
How to define to right point for locationInMesh Mirage12 OpenFOAM Native Meshers: snappyHexMesh and Others 4 April 10, 2014 10:12

All times are GMT -4. The time now is 09:58.