CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Bugs (http://www.cfd-online.com/Forums/openfoam-bugs/)
-   -   Problems with tutorialcase multiphaseInterFoam damBreak4phaseFine (http://www.cfd-online.com/Forums/openfoam-bugs/62497-problems-tutorialcase-multiphaseinterfoam-dambreak4phasefine.html)

jfb February 27, 2008 09:45

Dear OpenFOAM users I'm usi
 
Dear OpenFOAM users

I'm using OpenFOAM-1.4.1_patched (incl. patches till end of january) and compiled for 32- (Intel Pentium M processor 2.13GHz stepping 08) and 64-bit (2 AMD Athlon 64 X2 Dual Core Processor 5200+ processors) x86 environment.

When I run the tutorial case "damBreak4phaseFine" using the following commands:

$ run
$ cd tutorials/multiphaseInterFoam
$ blockMesh . damBreak4phaseFine
$ multiphaseInterFoam . damBreak4phaseFine

i get the following error (at the indicated timestep):

Courant Number mean: 0.048008 max: 0.488295
deltaT = 0.00158513
Time = 0.0278082

smoothSolver: Solving for alphaoil, Initial residual = 0.000294176, Final residual = 6.15158e-10, No Iterations 4
oil volume fraction, min, max = 0.1255 -4.51411e-05 1.00001
smoothSolver: Solving for alphamercury, Initial residual = 0.00026317, Final residual = 5.71493e-09, No Iterations 3
mercury volume fraction, min, max = 0.0423612 -4.54823e-05 1.00001
smoothSolver: Solving for alphaair, Initial residual = 0.000172765, Final residual = 1.50997e-09, No Iterations 3

...[snip/snap to save trees]...

smoothSolver: Solving for alphamercury, Initial residual = 2.91204e-07, Final residual = 7.7132e-09, No Iterations 1
mercury volume fraction, min, max = 0.0423612 -0.000129903 1.00001
air volume fraction, min, max = 0.749 -2.2947e-05 1.00032
smoothSolver: Solving for alphawater, Initial residual = 1.00512e-05, Final residual = 4.97933e-09, No Iterations 2
water volume fraction, min, max = 0.0831388 -0.00012306 1.00014
#0 Foam::error::printStack(Foam:http://www.cfd-online.com/OpenFOAM_D...part/proud.gifstream&) in "/home/jfb/OpenFOAM/OpenFOAM-1.4.1/lib/linux64GccDPOpt/libOpenFOAM.so"
#1 Foam::sigFpe::sigFpeHandler(int) in "/home/jfb/OpenFOAM/OpenFOAM-1.4.1/lib/linux64GccDPOpt/libOpenFOAM.so"
#2 ?? in "/lib64/libc.so.6"
#3 Foam::GAMGSolver::scalingFactor(Foam::Field<double >&, Foam::Field<double> const&, Foam::Field<double> const&, Foam::Field<double> const&) const in "/home/jfb/OpenFOAM/OpenFOAM-1.4.1/lib/linux64GccDPOpt/libOpenFOAM.so"
#4 Foam::GAMGSolver::scalingFactor(Foam::Field<double >&, Foam::lduMatrix const&, Foam::Field<double>&, Foam::FieldField<foam::field,> const&, Foam::UPtrList<foam::lduinterfacefield> const&, Foam::Field<double> const&, unsigned char) const in "/home/jfb/OpenFOAM/OpenFOAM-1.4.1/lib/linux64GccDPOpt/libOpenFOAM.so"
#5 Foam::GAMGSolver::Vcycle(Foam::PtrList<foam::lduma trix::smoother> const&, Foam::Field<double>&, Foam::Field<double> const&, Foam::Field<double>&, Foam::Field<double>&, Foam::Field<double>&, Foam::PtrList<foam::field<double> >&, Foam::PtrList<foam::field<double> >&, unsigned char) const in "/home/jfb/OpenFOAM/OpenFOAM-1.4.1/lib/linux64GccDPOpt/libOpenFOAM.so"
#6 Foam::GAMGSolver::solve(Foam::Field<double>&, Foam::Field<double> const&, unsigned char) constsmoothSolver: Solving for alphamercury, Initial residual = 8.72123e-06, Final residual = 4.66017e-09, No Iterations 2
mercury volume fraction, min, max = 0.0423612 -3.98569e-05 1.00001
in "/home/jfb/OpenFOAM/OpenFOAM-1.4.1/lib/linux64GccDPOpt/libOpenFOAM.so"
#7 Foam::fvMatrix<double>::solve(Foam::Istream&) in "/home/jfb/OpenFOAM/OpenFOAM-1.4.1/lib/linux64GccDPOpt/libfiniteVolume.so"
#8 main in "/home/jfb/OpenFOAM/OpenFOAM-1.4.1/applications/bin/linux64GccDPOpt/multiphaseIn terFoam"
#9 __libc_start_main in "/lib64/libc.so.6"
#10 Foam::regIOobject::readIfModified()

Please note, that this sigFpe occurs on both architecturs but when I try to run it on MAC OS X (running a port of OpenFOAM-1.4.1_patched) the problem occurs not that early in the calculation.

Could somebody please comment on that? I'm using openSUSE 10.3 with gcc-4.2.1, flex++ 2.5.33, etc.

Thanks a lot for any help!

msrinath80 February 28, 2008 17:52

Already discussed here --> htt
 
Already discussed here --> http://www.cfd-online.com/OpenFOAM_D...tml?1200608520

jfb February 29, 2008 07:20

Thanks a lot! Stupid me ...
 
Thanks a lot!

Stupid me ... I should have employed the search-function befor asking :-(


All times are GMT -4. The time now is 21:35.