CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Bugs

Problem with foam utilities in foamx

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   January 14, 2008, 09:36
Default hi, i just reinstalled OpenFo
  #1
New Member
 
alan fergus
Join Date: Mar 2009
Location: galway, ireland
Posts: 23
Rep Power: 8
alan_fergus is on a distinguished road
hi,
i just reinstalled OpenFoam 1.3 on fedora core 8, everything seems to be fine.

Checking basic setup...
-------------------------------------------------------------------------------
Shell: bash
Host: localhost.localdomain
OS: Linux version 2.6.23.9-85.fc8
User: alan
User_config: /home/alan/.bashrc
Foam_config: /home/alan/.OpenFOAM-1.3/bashrc sourced correctly.
-------------------------------------------------------------------------------


Checking main FOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/alan/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /home/alan/OpenFOAM/alan-1.3 yes no
$FOAM_JOB_DIR /home/alan/OpenFOAM/jobControl no yes
-------------------------------------------------------------------------------


Checking the FOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /home/alan/OpenFOAM/OpenFOAM-1.3 yes yes yes

$FOAM_USER_APPBIN ...-1.3/applications/bin/linuxGcc4DPOpt yes yes no
$FOAM_APPBIN ...-1.3/applications/bin/linuxGcc4DPOpt yes yes yes
$WM_DIR /home/alan/OpenFOAM/OpenFOAM-1.3/wmake yes yes yes
$FOAMX_PATH ...ations/utilities/preProcessing/FoamX yes no yes
$CEI_HOME /usr/local/ensight/CEI no no

$JAVA_PATH /usr yes yes no
$MICO_ARCH_PATH ...mico-2.3.11/platforms/linuxGcc4DPOpt yes yes yes
$LAM_ARCH_PATH ...c/lam-7.1.1/platforms/linuxGcc4DPOpt yes yes yes
$MPICH_ARCH_PATH --------- env variable not set --------- no
-------------------------------------------------------------------------------


Checking the FOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...FOAM/OpenFOAM-1.3/lib/linuxGcc4DPOpt yes yes yes
$FOAM_USER_LIBBIN ...OpenFOAM/alan-1.3/lib/linuxGcc4DPOpt yes yes no
$LAM_ARCH_PATH ...c/lam-7.1.1/platforms/linuxGcc4DPOpt yes yes yes
-------------------------------------------------------------------------------


Software versions
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
gcc 4.1.2 /usr/bin/gcc
java 1.7.0 /usr/bin/java
gzip 1.3.12 /usr/bin/gzip
tar 1.3.12 /bin/tar
icoFoam ...M/OpenFOAM-1.3/applications/bin/linuxGcc4DPOpt/icoFoam
-------------------------------------------------------------------------------


Checking file/directory permissions...
-------------------------------------------------------------------------------
File/directory Set Reqd Crit
-------------------------------------------------------------------------------


Checking networking...
-------------------------------------------------------------------------------
Action Result Crit
-------------------------------------------------------------------------------
...localhost.localdomain Successful yes
Pinging_localHost Successful yes
Test_rsh: Unsuccessful_connection_refused* yes
Test_ssh: Successful yes
(*) Only one of rsh or ssh is required by the Foam enviroment.

-------------------------------------------------------------------------------

Base configuration ok.

Critical systems ok.


[alan@localhost bin]$


and running the cases on the command line works fine but when i go into a case in foamx the foam utilities menu will not appear.

i was wondering has anyone come across this and may have a solution to it. its not the end of the world but i would prefer to be able to run blockmesh etc from foamx rather than having to do it on the command line
alan_fergus is offline   Reply With Quote

Old   January 14, 2008, 13:55
Default I am no expert but it happened
  #2
New Member
 
Bernardo D Flores
Join Date: Mar 2009
Posts: 21
Rep Power: 8
david_flo1 is on a distinguished road
I am no expert but it happened to me on OF 1.4.1 and I solved it by installing sun java jre and dev using the package manager in Ubuntu. Obviously you have do the modifications to the OpenFOAM's .bash file as the test finds java under usr/bin, which is ok.

Hope this helps.

Bernardo
david_flo1 is offline   Reply With Quote

Old   January 15, 2008, 07:38
Default thanks that worked
  #3
New Member
 
alan fergus
Join Date: Mar 2009
Location: galway, ireland
Posts: 23
Rep Power: 8
alan_fergus is on a distinguished road
thanks that worked
alan_fergus is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem Starting FoamX kumar2 OpenFOAM Installation 1 January 9, 2008 10:14
Problem about FoamX williamscn OpenFOAM Installation 8 September 17, 2007 23:18
FoamX problem richardhsieh OpenFOAM Installation 4 September 17, 2007 22:41
FoamX problem joegi OpenFOAM Installation 8 November 5, 2006 07:06
problem in running FoamX in Open FOAM Gaurav Main CFD Forum 3 May 10, 2006 05:06


All times are GMT -4. The time now is 17:36.