CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Bugs (http://www.cfd-online.com/Forums/openfoam-bugs/)
-   -   Problems with foamLog and interFoam OF 14 (http://www.cfd-online.com/Forums/openfoam-bugs/62581-problems-foamlog-interfoam-14-a.html)

sinusmontis June 1, 2007 08:09

Hello, I've discovered the
 
Hello,

I've discovered the following problem with foamLog when processing logs generated from interFoam. The result is a error message like this:

Executing: awk -f ./settling_mg_initg/logs/foamLog.awk settling_mg_initg/log
awk: ./settling_mg_initg/logs/foamLog.awk:10: MULES:Cnt=0
awk: ./settling_mg_initg/logs/foamLog.awk:10: ^ syntax error
awk: ./settling_mg_initg/logs/foamLog.awk:11: MULES:FinalResCnt=0
awk: ./settling_mg_initg/logs/foamLog.awk:11: ^ syntax error
awk: ./settling_mg_initg/logs/foamLog.awk:12: MULES:ItersCnt=0
awk: ./settling_mg_initg/logs/foamLog.awk:12: ^ syntax error


Proposed solution:
change the line

Info<< "MULES: Solving for " << psi.name() << endl;

to

Info<< "MULES: Solving for " << psi.name() << "," << endl;

in src/finiteVolume/lnInclude/MULESTemplates.C


Greetings,

Malte

mattijs June 1, 2007 08:56

Another solution is to filter
 
Another solution is to filter out solver messages that don't include a ','



mattijs June 1, 2007 08:57

(cancelled posting to late ;-)
 
(cancelled posting to late ;-)
The attached file is a replacement for bin/foamLog

http://www.cfd-online.com/OpenFOAM_D...hment_icon.gif foamLog


All times are GMT -4. The time now is 06:53.