CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Bugs

nonNewtonianIcoFoam - problem with parallel run

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   April 1, 2009, 03:48
Default nonNewtonianIcoFoam - problem with parallel run
  #1
New Member
 
Chris
Join Date: Mar 2009
Location: Europe
Posts: 19
Rep Power: 9
chris_sev is on a distinguished road
Hallo,

When I run nonNewtonianIcoFoam in parallel transient results are not beeing written on nodes other than master.
I have never experienced this in case of other solvers. I am sure that I didn't messed with settings because when I use other solver for the same simulation and number of processors everything works fine.

Is that bug?
chris_sev is offline   Reply With Quote

Old   April 1, 2009, 05:16
Default
  #2
Super Moderator
 
Mattijs Janssens
Join Date: Mar 2009
Posts: 1,416
Rep Power: 17
mattijs is on a distinguished road
I cannot repeat this with the offsetCylinder tutorial.

All the field writing is done in the same way regardless of the solver so it is unlikely it is a problem of nonNewtonianIcoFoam itself. Is your problem only for one case or also for the tutorial case?
mattijs is offline   Reply With Quote

Old   April 1, 2009, 07:10
Default
  #3
New Member
 
Chris
Join Date: Mar 2009
Location: Europe
Posts: 19
Rep Power: 9
chris_sev is on a distinguished road
Hi Mattijs,

Thanks a lot for response.
With tutorial case (offsetCylinder) it's the same. I've just checked this, used 2computers with 2 processors on each.
I got transient results only on my master machine (processor0 and processor1).

I am using standard nonNewtonianIcoFoam that comes with installations package. I didn't played with the code (apart from implementation of time step adjustment).
I am using 1.5 version.

Do you have any ideas/hints ?

Thanks in advance,
Chris
chris_sev is offline   Reply With Quote

Old   April 1, 2009, 07:32
Default
  #4
Super Moderator
 
Mattijs Janssens
Join Date: Mar 2009
Posts: 1,416
Rep Power: 17
mattijs is on a distinguished road
Run all (4?) your processes on your local computer and check. Maybe your second computer does not allow writing to the disk.

Switch on debug flag for objectRegistry. You'll get messages from all processors of the form

objectRegistry::write() : Considering writing object ...
mattijs is offline   Reply With Quote

Old   April 1, 2009, 09:13
Default
  #5
New Member
 
Chris
Join Date: Mar 2009
Location: Europe
Posts: 19
Rep Power: 9
chris_sev is on a distinguished road
I am not very familiar with parallel run in OF so i don't realy know what does it mean and how to manage this:

Quote:
Originally Posted by mattijs View Post

Switch on debug flag for objectRegistry. You'll get messages from all processors of the form

objectRegistry::write() : Considering writing object ...
But anyway thanks for help. I am sure it's helpfull, so now I will search through the forum trying to figure out what's the meaning of above

I am wondering also how it's possible that other computer doesn't allow to write data when use nonNewtonianIcoFoam but when use rasInterFoam everything is fine :/

Chris
chris_sev is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
RSH problem for parallel running in CFX Nicola CFX 5 June 18, 2012 18:31
Cannot run Star-CCM+ parallel in Linux dburns CD-adapco 9 April 27, 2010 12:01
Parallel run with engineFoam francesco OpenFOAM Bugs 1 November 25, 2008 08:06
Moving Mesh Run problem - Scientific Linux G. SE CD-adapco 2 May 7, 2008 07:15
Problem on Parallel Run Setup Hamidur Rahman CFX 0 September 23, 2007 17:11


All times are GMT -4. The time now is 00:51.