CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Bugs

OpenFOAM-1.5-extend checkMesh problem

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   June 23, 2009, 05:50
Default OpenFOAM-1.5-extend checkMesh problem
  #1
Member
 
Johan Spång
Join Date: Mar 2009
Location: Stockholm, Sweden
Posts: 35
Rep Power: 7
josp is on a distinguished road
In openfoam extend:

cd $FOAM_TUTORIALS/icoFoam/cavity
blockMesh
checkMesh
...
Mesh OK.

transformPoints -scale "(0.001 0.001 0.001)"
checkMesh
...
***Max skewness = 116.905, 1542 highly skew faces detected which may impair the quality of the results Threshold = 4
<<Writing 1542 skew faces to set skewFaces
Failed 1 mesh checks.

The same procedure works fine under 1.5.x with no errors and the mesh looks ok (which it doesn't in -extend) I did recompile everything but the problem persists. Is there some tolerance settings that I have to change? -scale "(0.01 0.01 0.01)" works fine?
josp is offline   Reply With Quote

Old   June 23, 2009, 17:03
Default
  #2
Senior Member
 
Martin Beaudoin
Join Date: Mar 2009
Posts: 328
Rep Power: 12
mbeaudoin will become famous soon enough
Hi,

I did the exact same sequence of commands you did with my local installation of OpenFOAM-1.5-dev (revision 1294). No tolerances tweaking.

Got no error messages, and the mesh I got after calling transformPoints looks fine too.

My max skewness went from 1e-08 (before transformPoints) to 2 (after transformPoints), which seems to be OK for checkMesh.

" Max skewness = 2 OK. "



Martin

Quote:
Originally Posted by josp View Post
In openfoam extend:

cd $FOAM_TUTORIALS/icoFoam/cavity
blockMesh
checkMesh
...
Mesh OK.

transformPoints -scale "(0.001 0.001 0.001)"
checkMesh
...
***Max skewness = 116.905, 1542 highly skew faces detected which may impair the quality of the results Threshold = 4
<<Writing 1542 skew faces to set skewFaces
Failed 1 mesh checks.

The same procedure works fine under 1.5.x with no errors and the mesh looks ok (which it doesn't in -extend) I did recompile everything but the problem persists. Is there some tolerance settings that I have to change? -scale "(0.01 0.01 0.01)" works fine?

Last edited by mbeaudoin; June 24, 2009 at 08:18.
mbeaudoin is offline   Reply With Quote

Old   June 24, 2009, 11:41
Default
  #3
Member
 
Johan Spång
Join Date: Mar 2009
Location: Stockholm, Sweden
Posts: 35
Rep Power: 7
josp is on a distinguished road
Hi Martin,

I just tried with a fresh opensuse (x64) install + latest version from svn and now I get the same output as you. Problem was on my side but it's unclear what caused it.

Thank you for your attention!

Regards

Johan

Quote:
Originally Posted by mbeaudoin View Post
Hi,

I did the exact same sequence of commands you did with my local installation of OpenFOAM-1.5-dev (revision 1294). No tolerances tweaking.

Got no error messages, and the mesh I got after calling transformPoints looks fine too.

My max skewness went from 1e-08 (before transformPoints) to 2 (after transformPoints), which seems to be OK for checkMesh.

" Max skewness = 2 OK. "



Martin
josp is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem running paraFoam on OpenFOAM 1.5 sonny OpenFOAM 3 June 6, 2009 20:24
Eureka, OpenFoam 1.5 is running on OpenSUSE11.1 Ahmed Main CFD Forum 0 March 7, 2009 22:20
OpenFOAM Version 1.5 Released OpenFOAM discussion board administrator OpenFOAM Announcements from ESI-OpenCFD 0 July 14, 2008 18:22
CheckMesh error using a tutorial from OpenFOAM 114 with openFOAM 13 martapajon OpenFOAM Native Meshers: blockMesh 7 January 21, 2008 12:52
CFX4.3 -build analysis form Chie Min CFX 5 July 12, 2001 23:19


All times are GMT -4. The time now is 01:00.