CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Bugs (http://www.cfd-online.com/Forums/openfoam-bugs/)
-   -   splitMeshRegions doesn't work. (http://www.cfd-online.com/Forums/openfoam-bugs/67972-splitmeshregions-doesnt-work.html)

PetSul September 2, 2009 04:55

splitMeshRegions doesn't work.
 
Hello,

here is the original thread

http://www.cfd-online.com/Forums/ope...shregions.html

I have a fluent mesh (.msh) imported to OpenFOAM, I used fluent3DMeshToFoam to convert it and it went nicely. Also meshCheck went ok.

mattijs asked me to send a testcase here, but the attachment exceeds the limit so I can't put it here. It's about 0.5M. Can I email it to someone?

Regards,

Petri Sulasalmi

mattijs September 2, 2009 05:17

Just send it to me directly. The domain is opencfd.co.uk, username is m.janssens

mattijs September 2, 2009 06:15

It wasn't clearing out the fvMesh geometric data. I pushed a fixed splitMeshRegions.C to 1.6.x.

PetSul September 2, 2009 06:26

Quote:

Originally Posted by mattijs (Post 228244)
It wasn't clearing out the fvMesh geometric data. I pushed a fixed splitMeshRegions.C to 1.6.x.

Where can I get the code? Do I just replace the old splitMeshRegions.C with the fixed code?

mattijs September 2, 2009 07:06

See the git instructions on http://www.opencfd.co.uk/openfoam/download.html.

You could probably just replace the 1.6 splitMeshRegions.C but 1.6.x contains quite a few bug fixes.


All times are GMT -4. The time now is 03:46.