CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Bugs

patch injection problem, a possible bug?

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   September 23, 2009, 16:33
Default patch injection problem, a possible bug?
  #1
New Member
 
Cheng
Join Date: Apr 2009
Posts: 6
Rep Power: 7
jsltlx is on a distinguished road
Hello everyone,

I'm trying to use patch injection in Lagrangian modeling. I found some strange things in my cases.
1. For one case, I defined patch injections at three inlets. However, for one of the three inlets, I didn't see any particles injected (the other two worked fine).
2. For another case, I defined one patch injection and it seems to be working fine with 32 processors. However, I don't see any particles injected if I use 64 or 128 processors (cone injection still works).

What could be the possible reason for this? Could this be a bug? Any help will be highly appreciated. Thanks.

Cheng
jsltlx is offline   Reply With Quote

Old   September 24, 2009, 17:59
Default
  #2
Super Moderator
 
Mattijs Janssens
Join Date: Mar 2009
Posts: 1,416
Rep Power: 15
mattijs is on a distinguished road
It is not just a matter of the patch not being present on your domain? Do you have a testcase that you can post or send?
mattijs is offline   Reply With Quote

Old   September 25, 2009, 11:02
Default
  #3
New Member
 
Cheng
Join Date: Apr 2009
Posts: 6
Rep Power: 7
jsltlx is on a distinguished road
Quote:
Originally Posted by mattijs View Post
It is not just a matter of the patch not being present on your domain? Do you have a testcase that you can post or send?
Hi Mattijs,

I'll email you the second case soon. Thanks.

Cheng
jsltlx is offline   Reply With Quote

Old   November 3, 2009, 14:40
Default
  #4
Super Moderator
 
Mattijs Janssens
Join Date: Mar 2009
Posts: 1,416
Rep Power: 15
mattijs is on a distinguished road
The injected mass and volume was not adapted for parallel running. Fixed in 1.6.x.
mattijs is offline   Reply With Quote

Old   April 20, 2010, 09:42
Default
  #5
New Member
 
sankarv
Join Date: Feb 2010
Posts: 26
Rep Power: 6
sankarv is on a distinguished road
Dear mattijs

I have a question on PatchInjection too.

It is not cleat to me how to set parcelPersecond, when I use the patchInjection.

What is its relationship of parcelspersecond with volume flow rate and totalmass of particles ?

Can you please tell me ?

Thanks
Vaidya
sankarv is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
GmshToFoam keyword patch0 is undefined steve999 Open Source Meshers: Gmsh, Netgen, CGNS, ... 5 September 14, 2008 14:45
Problem with rhoSimpleFoam matteo_gautero OpenFOAM Running, Solving & CFD 0 February 28, 2008 06:51
Convergence moving mesh lr103476 OpenFOAM Running, Solving & CFD 30 November 19, 2007 14:09
Problem with cyclic patch and createPatch mattijs OpenFOAM Mesh Utilities 12 August 24, 2006 04:57
Multicomponent fluid Andrea CFX 2 October 11, 2004 05:12


All times are GMT -4. The time now is 12:39.