CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Bugs

moveDynamicMesh broken ?

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 11, 2009, 09:57
Default moveDynamicMesh broken ?
  #1
Senior Member
 
Pierre-Olivier Dallaire
Join Date: Mar 2009
Location: Montreal, Quebec, Canada
Posts: 185
Rep Power: 8
podallaire is on a distinguished road
Hi,

tried to run moveDynamicMesh today and it seems that it's now broken, happened last month because this behaviour was not observed back in September. As an example, running tutorial SnakeRiverCanyon will give this :

Create time

Create mesh for time = 0

Selecting dynamicFvMesh dynamicMotionSolverFvMesh
Selecting motion solver: displacementSBRStress


--> FOAM FATAL IO ERROR:
wrong token type - expected word found on line 57 the label -1

file: SnakeRiverCanyon/0/pointDisplacement::wedgePlane at line 57.

From function operator>>(Istream&, word&)
in file primitives/strings/word/wordIO.C at line 77.

FOAM exiting


Any idea ?

Regards,

PO
podallaire is offline   Reply With Quote

Old   November 11, 2009, 11:03
Default
  #2
Super Moderator
 
Mattijs Janssens
Join Date: Mar 2009
Posts: 1,416
Rep Power: 16
mattijs is on a distinguished road
Thanks for reporting. Was bug in reading the optional wedge axis. Fixed in 1.6.x.
mattijs is offline   Reply With Quote

Old   November 11, 2009, 14:44
Default
  #3
Senior Member
 
Pierre-Olivier Dallaire
Join Date: Mar 2009
Location: Montreal, Quebec, Canada
Posts: 185
Rep Power: 8
podallaire is on a distinguished road
Thanks, tested and it worked
podallaire is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
"spanwise line broken ?" liang NUMECA 1 March 13, 2010 02:06
Help for Broken dam problem JSS Main CFD Forum 2 November 20, 2009 17:42
SOLA-VOF and Broken Dam Problem SOLA-VOF and Broken Dam problem Main CFD Forum 6 November 20, 2009 17:27
broken contour at 1920*1200 monitor kris FLUENT 1 April 19, 2007 04:00
[Ref. Vel. in Broken dam prob.] Beginner Main CFD Forum 1 June 20, 2001 11:28


All times are GMT -4. The time now is 09:14.