CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Bugs (http://www.cfd-online.com/Forums/openfoam-bugs/)
-   -   On compiling - CompactListListI.H (expected type-specifier before ‘>’) (http://www.cfd-online.com/Forums/openfoam-bugs/70678-compiling-compactlistlisti-h-expected-type-specifier-before.html)

kjetil December 2, 2009 08:19

On compiling - CompactListListI.H (expected type-specifier before ‘>’)
 
I'm trying to compile 1.6.x, but I get an error:
/home/kjetil/OpenFOAM/OpenFOAM-1.6.x/src/OpenFOAM/lnInclude/CompactListListI.H:74: error: expected type-specifier before ‘>’ token
.. and I get a make error. Performing a text search in the lnInclude-dir reveals that this is the only file that doesn't have a type-specifier. Is this on purpose? I'm using system compiler on Ubuntu 9.10 64bit.

kjetil December 2, 2009 08:39

As there are several other "*ListI.H" in that directory, I compared the content, and made a change in the CompactListListI.H:
CompactListList<T>* nullPtr = reinterpret_cast< >(0);
to
CompactListList<T>* nullPtr = reinterpret_cast<CompactListList<T>*>(NULL);

The ./Allwmake is currently running, but has so far not experienced the same errors as before.

kjetil December 2, 2009 10:22

Done. Seemed to work. Also, had to disable (<- remove) tecplot360 directory, as it was nagging about files that could not be found. True, as they (i.e TECIO.H) are now placed in a subfolder.

mattijs December 2, 2009 12:16

Thanks. 1.6.x should now build cleanly (on linux64 at least) , including foamToTecplot360.

kjetil December 2, 2009 13:43

The only problem when making the PV3FoamReader, is when using 'system' compiler, it looks for '/bin/c++', not '/usr/bin/c++'. If I change to compiler in settings.sh to 'OpenFOAM', it works. Should I add a symbolic link in '/bin/ to fix this?

mattijs December 3, 2009 13:16

Bit complex. Since cmake produces non-relocatable cmake files the buildParaview script replaces some hardcoded paths with environment variables, one of which is WM_COMPILER_DIR

workaround 1:
change in the paraview build directory, in platforms/linux64Gcc/Common/KWCommon/KWCommonBuildSettings.cmake the setting for

CMAKE_BUILD_SETTING_C_COMPILER
CMAKE_BUILD_SETTING_CXX_COMPILER

workaround 2:
make a directory structure with a bin/c++ and bin/c in it (can be softlinks to your real compiler) and set WM_COMPILER_DIR to it.


All times are GMT -4. The time now is 09:25.