CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Bugs (http://www.cfd-online.com/Forums/openfoam-bugs/)
-   -   same old trouble with paraFoam (http://www.cfd-online.com/Forums/openfoam-bugs/78387-same-old-trouble-parafoam.html)

vaina74 July 20, 2010 09:51

same old trouble with paraFoam
 
I made a fresh install of OpenFOAM-1.7 by the great Ubuntu pack. I made an icoFoam test and paraView doesn't show anything. I fixed the problem adding
Code:

export LC_ALL=C
to the top of /opt/openfoam170/bin/paraFoam, under the comment lines. Maybe it's time for editing that damned file :-)

mattijs July 20, 2010 14:43

Thanks for reporting.

Why do you think this system setting (setting the locale) belongs in one particular script (paraFoam) in one particular application (OpenFOAM)?

Mattijs

wyldckat July 20, 2010 18:04

Greetings to all!

Quote:

Originally Posted by mattijs (Post 268223)
Why do you think this system setting (setting the locale) belongs in one particular script (paraFoam) in one particular application (OpenFOAM)?

I can answer that :) AFAIK, in English the decimal point is the official decimal separator, and I believe it's also according to the scientific notation. Nonetheless, this varies from locale to locale: mainly it's either the comma or the point used as decimal separator.

Anyway, so far OpenFOAM seems impervious this locale issue, but ParaView isn't, leading it to misread the ASCII files, even when using OpenFOAM's PV3FoamReader plugin! This has happened in ParaView until recently, but so far it has only been fixed in ParaView's git version.

So, the usual fix we've been using (many users of this forum and OpenFOAM) is to do the locale change directly in the paraFoam script, since it's the usual way to access ParaView under OpenFOAM's environment! But like I said, this fix will probably only apply for another year or so, until OpenFOAM 1.8.0 comes out with the then latest ParaView version :)

Best regards,
Bruno

vaina74 July 20, 2010 18:49

Thanks for the deep explanation, Bruno. I'm not so Ubuntu expert for that. I just fixed the problem with previous versions of OpenFOAM and Ubuntu, as described above. In internet and in this forum I read many comments about that - all not-anglosaxon users? I don't know that :-)
Anyway, it works.

mattijs July 23, 2010 06:23

Thanks for the explanation.

I've (temporarily) added the LC_ALL setting to 17x bin/paraFoam but not fully happy with it. Remind me to remove it ;-)

Mattijs

wyldckat June 25, 2011 14:08

Greetings Mattijs,

Since I couldn't reopen the bug report http://www.openfoam.com/mantisbt/view.php?id=225 and this is the thread related to it, so I'll post my findings here:

I've tracked down the post where I read that this would be fixed in the next version and found it: http://www.cfd-online.com/Forums/ope...tml#post261715 post #218.
The respective patch was this: http://www.paraview.org/pipermail/pa...attachment.obj
I've just checked if the patch was applied and it is applied to 3.10.1, so the problem should be fixed.

I've just tested your latest deb packages of OpenFOAM 2.0.0 and ParaView 3.10.1 on Ubuntu 10.04 i686 with a French installation on a VM and the same cavity tutorial worked fine, with both readers and without any LC_* flags set in the environment nor paraFoam... so I believe that there must be something else going wrong on that machine of the user that posted the bug report...

Nonetheless, I also tried contaminating the environment by sourcing the 1.7.1 deb version of OpenFOAM, right before 2.0.0, but it didn't result in error either.

But I suppose that since the bug is fixed anyway with LC_ALL, why bother figuring out where the real problem could be :(

Best regards,
Bruno


All times are GMT -4. The time now is 16:18.