CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Bugs

SnappyHexMesh OF-1.6-ext crashes on a parallel run

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 30, 2010, 10:25
Default SnappyHexMesh OF-1.6-ext crashes on a parallel run
  #1
Member
 
norman1981's Avatar
 
Norman Del Puppo
Join Date: Mar 2009
Location: Hinwil, CH
Posts: 57
Rep Power: 8
norman1981 is on a distinguished road
Dear all,

I got a crush running snappyHexMesh in parallel on 1.6-ext on one of my cases. I run snappyHexMesh in parallel on the motorBike tutorial to test the OF-1.6-ext snappyHexMesh version and it crushed too reporting these errors:
===
Truncating neighbour list at 12041 for backward compatibility

From function void polyMesh::initMesh()
in file meshes/polyMesh/polyMeshInitMesh.C at line 82
Truncating neighbour list at 12560 for backward compatibility

From function void polyMesh::initMesh()
in file meshes/polyMesh/polyMeshInitMesh.C at line 82
Truncating neighbour list at 12560 for backward compatibility

From function void polyMesh::initMesh()
in file meshes/polyMesh/polyMeshInitMesh.C at line 82
Truncating neighbour list at 12560 for backward compatibility
[0]
[0]
[0] --> FOAM FATAL ERROR:
[0] Problem. oldPointI:5728 newPointI:-1
[0]
[0] From function fvMeshDistribute::mergeSharedPoints()
[0] in file directTopoChange/fvMeshDistribute/fvMeshDistribute.C at line 612.
[0]
FOAM parallel run aborting
[0]
--------------------------------------------------------------------------
MPI_ABORT was invoked on rank 0 in communicator MPI_COMM_WORLD
with errorcode 1.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.
--------------------------------------------------------------------------
[1]
[1]
[1] --> FOAM FATAL ERROR:
[1] Problem. oldPointI:5432 newPointI:-1
[1]
[1] From function fvMeshDistribute::mergeSharedPoints()
[1] in file directTopoChange/fvMeshDistribute/fvMeshDistribute.C at line 612.
[1]
FOAM parallel run aborting
[1]
====

The same case run well in parallel in 1.5-dev.

Kind Regards

Norman
norman1981 is offline   Reply With Quote

Old   November 30, 2010, 11:47
Default
  #2
Senior Member
 
Elvis
Join Date: Mar 2009
Location: Sindelfingen, Germany
Posts: 577
Blog Entries: 5
Rep Power: 13
elvis is on a distinguished road
Hi Norman,
there is a Bug Tracker made for the Extend version.
read http://www.extend-project.de/project...nd-bug-tracker

Your Bug Report should go to http://sourceforge.net/apps/mantisbt.../main_page.php

greets

elvis
elvis is offline   Reply With Quote

Old   December 1, 2010, 04:24
Default
  #3
Member
 
norman1981's Avatar
 
Norman Del Puppo
Join Date: Mar 2009
Location: Hinwil, CH
Posts: 57
Rep Power: 8
norman1981 is on a distinguished road
Quote:
Originally Posted by elvis View Post
Hi Norman,
there is a Bug Tracker made for the Extend version.
read http://www.extend-project.de/project...nd-bug-tracker

Your Bug Report should go to http://sourceforge.net/apps/mantisbt.../main_page.php

greets

elvis
Hi Elvis,

thank you. Yesterday I had a look at sourceforge mantis bug tracker before posting my message but there's not a "Core" (or something related) element in the "Choose Project" combo box therefore I thought this was still the right place to post core-related bugs :-)

Regards

Norman
norman1981 is offline   Reply With Quote

Old   November 25, 2011, 09:55
Default
  #4
New Member
 
Ali Q Raeini
Join Date: Feb 2010
Posts: 21
Rep Power: 7
aliqasemi is on a distinguished road
Quote:
Originally Posted by norman1981 View Post
Dear all,

I got a crush running snappyHexMesh in parallel on 1.6-ext on one of my cases. I run snappyHexMesh in parallel on the motorBike tutorial to test the OF-1.6-ext snappyHexMesh version and it crushed too reporting these errors:
===
Truncating neighbour list at 12041 for backward compatibility

From function void polyMesh::initMesh()
in file meshes/polyMesh/polyMeshInitMesh.C at line 82
Truncating neighbour list at 12560 for backward compatibility

From function void polyMesh::initMesh()
in file meshes/polyMesh/polyMeshInitMesh.C at line 82
Truncating neighbour list at 12560 for backward compatibility

From function void polyMesh::initMesh()
in file meshes/polyMesh/polyMeshInitMesh.C at line 82
Truncating neighbour list at 12560 for backward compatibility
[0]
[0]
[0] --> FOAM FATAL ERROR:
[0] Problem. oldPointI:5728 newPointI:-1
[0]
[0] From function fvMeshDistribute::mergeSharedPoints()
[0] in file directTopoChange/fvMeshDistribute/fvMeshDistribute.C at line 612.
[0]
FOAM parallel run aborting
[0]
--------------------------------------------------------------------------
MPI_ABORT was invoked on rank 0 in communicator MPI_COMM_WORLD
with errorcode 1.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.
--------------------------------------------------------------------------
[1]
[1]
[1] --> FOAM FATAL ERROR:
[1] Problem. oldPointI:5432 newPointI:-1
[1]
[1] From function fvMeshDistribute::mergeSharedPoints()
[1] in file directTopoChange/fvMeshDistribute/fvMeshDistribute.C at line 612.
[1]
FOAM parallel run aborting
[1]
====

The same case run well in parallel in 1.5-dev.

Kind Regards

Norman
Dear Norman,

I am getting the same error. Have you got any fix/workaround for this? Or should I use another version of the OpenFOAM?

Thanks in advance.

Ali

Last edited by aliqasemi; November 25, 2011 at 12:01.
aliqasemi is offline   Reply With Quote

Old   November 29, 2011, 05:34
Default
  #5
New Member
 
Ola Widlund
Join Date: Jun 2011
Location: Sweden
Posts: 13
Rep Power: 6
Ola Widlund is on a distinguished road
Hi!

I think you would be better off having a fresh OF-2.0 installation as a complement to 1.6-ext. I don't think snappyHexMesh is worked on by anyone in the extend team, so now you are actually using the 1.6 version of snappyHexMesh. There are a lot of developments since then; see release notes on www.openfoam.com.

Of course, nothing prevents you from using your generated mesh with solvers built with the 1.6-ext release.

/Ola
Ola Widlund is offline   Reply With Quote

Old   December 7, 2011, 13:48
Default
  #6
New Member
 
Ali Q Raeini
Join Date: Feb 2010
Posts: 21
Rep Power: 7
aliqasemi is on a distinguished road
Quote:
Originally Posted by Ola Widlund View Post
Hi!

I think you would be better off having a fresh OF-2.0 installation as a complement to 1.6-ext. I don't think snappyHexMesh is worked on by anyone in the extend team, so now you are actually using the 1.6 version of snappyHexMesh. There are a lot of developments since then; see release notes on www.openfoam.com.

Of course, nothing prevents you from using your generated mesh with solvers built with the 1.6-ext release.

/Ola
Thank you Ola,

Unfortunately, at the moment OF-2.0.x does not produce good quality meshes for me. I need a coarse mesh with no feature-edge handelling, roughly speaking. So it seems that I have to use the sHM in OF-1.6-ext - in serial - for now.

Ali
aliqasemi is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
parallel run for fsi simulation??? smn CFX 2 July 19, 2009 04:04
Parallel run diverges, serial does not SammyB OpenFOAM Running, Solving & CFD 1 May 10, 2009 03:28
Cant run in parallel on two nodes using OpenMPI CHristofer Main CFD Forum 0 October 26, 2007 09:54
Minimum number of nodes to run CFX in parallel Rui CFX 3 April 11, 2005 20:46
How to run parallel in ICEM_CFD? Kiddo Main CFD Forum 2 January 24, 2005 09:53


All times are GMT -4. The time now is 18:52.