CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Bugs (
-   -   cannot find -liberty (

Aneirin December 10, 2010 19:53

cannot find -liberty

I'm installing OpenFOAM 1.7.1 from source pack (on a Fedora 11 system). It's all going reasonably well (although it seems to take quite a long time!), but during the install process I see, at the linking stage of some parts, such things as

/usr/bin/ld: cannot find -liberty
collect2: ld returned 1 exit status

.. and then it goes on to installing other bits. Has anyone encountered this before - and am I missing important parts of the install through this? I couldn't immediately find another mention of this problem elsewhere.

In any case, thanks for your help.

Aneirin December 10, 2010 20:37

Ok, I'm sorry for this post, guys. I dug a little deeper and found one lad with a similar issue somewhere. For the sake of completeness and in case anyone stumbles upon this thread with an identical problem:

For me the solution was to install the binutils-devel package (through yum in my case) - which contains the libiberty package.

All times are GMT -4. The time now is 17:45.