CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Bugs

paraFoam, Segmentation fault

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 3, 2011, 16:19
Default paraFoam, Segmentation fault
  #1
New Member
 
Nat
Join Date: Oct 2009
Posts: 10
Rep Power: 7
Fed11 is on a distinguished road
Hi all
I just installed openFoam on my Laptop with the Opensuse 11.4x64. I nstallation went fine until I ran paraFoam. It crashes at start with the following message:

/opt/openfoam171/bin/paraFoam: line 119: 22087 Segmentation fault paraview --data="$caseFile"

Any help would be much appreciated
Fed11 is offline   Reply With Quote

Old   July 3, 2011, 17:59
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Nat,

Try running this command before paraFoam:
Code:
export LC_ALL=C
Best regards,
Bruno
wyldckat is online now   Reply With Quote

Old   July 3, 2011, 21:24
Default
  #3
New Member
 
Nat
Join Date: Oct 2009
Posts: 10
Rep Power: 7
Fed11 is on a distinguished road
Thanks Bruno. Actually, I found that that it's a driver problem. I recently installed the fglrx driver and it didn't work out for me on my Thinkpad Duo. So by removing it and back to my previous xorg.conf resolved the issue.

I wanted to change the driver because of of the following message that i keep getting from openFoam below. Any hint?

Thanks a lot

p, li { white-space: pre-wrap; } X Error: GLXBadContextTag 173
Extension: 154 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x260026e
X Error: GLXBadContextTag 173
Extension: 154 (Uknown extension)
Minor opcode: 1 (Unknown request)
Resource id: 0x9a0005
X Error: GLXBadContextTag 173
Extension: 154 (Uknown extension)
Minor opcode: 117 (Unknown request)
Resource id: 0x9a0005
X Error: GLXBadContextTag 173

Fed11 is offline   Reply With Quote

Old   July 4, 2011, 19:04
Default
  #4
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Nat,

As far as I can remember, those kinds of issues usually require one or more of these solutions:
  • Better drivers for the graphics card. In the past, one version back or forward would do the trick.
  • Rebuilding ParaView, so it can hook-up to the correct OpenGL functions for your card.
  • I remember about a special environment variable that would override some functions in the ParaView<->OpenGL interaction... lets see if I can find it... Here you go: ParaFoam error could not find a decent visual - solution in post #4
You can find a few more references to this sort of issue on this blog post of mine: Related issues to ParaView with OpenFOAM - Fixes and solutions

Best regards,
Bruno
wyldckat is online now   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Segmentation fault when starting paraFoam gaffu OpenFOAM Installation 16 November 18, 2011 20:05
Segmentation fault when running dieselFoam or dieselEngineFoam in parallel francesco OpenFOAM Bugs 3 June 10, 2011 09:30
forrtl: severe (174): SIGSEGV, segmentation fault occurred therockyy FLOW-3D 7 January 19, 2011 23:52
ParaView segmentation fault only for multiphase gwierink OpenFOAM 9 March 25, 2010 08:23
Segmentation fault with paraFoam and paraview 3.6.1 on Fedora 11 32 and 64 bit nanes OpenFOAM Paraview & paraFoam 2 September 11, 2009 09:12


All times are GMT -4. The time now is 08:50.