CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation on Windows, Mac and other Unsupported Platforms

Patches to compile OpenFOAM 2.2 on Mac OS X

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree20Likes

Reply
 
LinkBack Thread Tools Display Modes
Old   August 20, 2013, 15:09
Default
  #61
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by dav.dap83 View Post
Yes, I have.

Perhaps it may be more helpful to upload the log file.
Only looked at the first log file. For some reason it doesn't find pointHit.H (which is quite essential). Remove $FOAM_SRC/OpenFOAM/lnInclude and recompile (the lnInclude will be rebuilt).

After writing the last paragraph it just occurred to me: pointHit.H is one of these files with a major case "brother": PointHit.H. Are you sure you're on a case-sensitive filesystem and if yes: maybe you unpacked the sources on a case-insensitve filesystem before moving them to the case-sensitve one.
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   August 20, 2013, 18:43
Default
  #62
Member
 
Davide D.
Join Date: Oct 2012
Location: Birmingham (UK)
Posts: 44
Rep Power: 4
dav.dap83 is on a distinguished road
Quote:
Originally Posted by gschaider View Post
if yes: maybe you unpacked the sources on a case-insensitve filesystem before moving them to the case-sensitve one.
That's exactly what happened. Now I've unpacked the sources into a case-sentitive filesystem and the compilation succeeded.
Thank you
dav.dap83 is offline   Reply With Quote

Old   August 20, 2013, 19:24
Default
  #63
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by dav.dap83 View Post
That's exactly what happened. Now I've unpacked the sources into a case-sentitive filesystem and the compilation succeeded.
Thank you
Which instructions did you use? If it is on the Wiki: could you add a warning about this problem to the part about unpacking? (I think misunderstandings are best cleared by those to whom it was unclear. "I wouldn't have had this problem if THIS had been there")
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   August 20, 2013, 19:57
Default
  #64
Member
 
Davide D.
Join Date: Oct 2012
Location: Birmingham (UK)
Posts: 44
Rep Power: 4
dav.dap83 is on a distinguished road
Quote:
Originally Posted by gschaider View Post
If it is on the Wiki: could you add a warning about this problem to the part about unpacking? (I think misunderstandings are best cleared by those to whom it was unclear. "I wouldn't have had this problem if THIS had been there")
You mean this wiki? http://openfoamwiki.net/index.php/Ho...enFOAM_v21_Mac

Quote:
Originally Posted by gschaider View Post
Which instructions did you use?
In tr first attempt (that didn't work) I just extracted the tar files by double-clicking in the Downloads folder, and them dragged and dropped the folders inside the case-sensitive disk image. In the second attempt (this worked) I downloaded the tar files directly inside the disk image, and then unpacked them via terminal.

Last edited by dav.dap83; August 21, 2013 at 06:12.
dav.dap83 is offline   Reply With Quote

Old   September 27, 2013, 11:24
Default
  #65
New Member
 
Oscar Mayr
Join Date: Sep 2013
Posts: 1
Rep Power: 0
oscarsailing is on a distinguished road
Hello Everybody,

I just manage to install OF-v2.2 and I was running the first tutorials...

I came across this issue with snappy which make me struggle a lot in the tutorial "wigleyHull"

Code:
Oscars-MacBook-Pro:wigleyHull JARVIS$ snappyHexMesh
dyld: Library not loaded: libptscotch.dylib
  Referenced from: /Users/JARVIS/OpenFOAM/OpenFOAM-2.2.0/platforms/darwinIntel64GccDPOpt/lib/openmpi-macport/libptscotchDecomp.dylib
  Reason: image not found
Trace/BPT trap: 5
how do I solve it? openmpi was installed correctly and

/Volumes/OpenFOAM-v2.2/OpenFOAM-2.2.0/platforms/darwinIntel64GccDPOpt/lib/openmpi-macport/libptscotchDecomp.dylib

seems to be correctly placed...

sorry the ignorance

I look forward to your reply on this issue.

Oscar
oscarsailing is offline   Reply With Quote

Old   September 27, 2013, 15:20
Default
  #66
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by oscarsailing View Post
Hello Everybody,

I just manage to install OF-v2.2 and I was running the first tutorials...

I came across this issue with snappy which make me struggle a lot in the tutorial "wigleyHull"

Code:
Oscars-MacBook-Pro:wigleyHull JARVIS$ snappyHexMesh
dyld: Library not loaded: libptscotch.dylib
  Referenced from: /Users/JARVIS/OpenFOAM/OpenFOAM-2.2.0/platforms/darwinIntel64GccDPOpt/lib/openmpi-macport/libptscotchDecomp.dylib
  Reason: image not found
Trace/BPT trap: 5
how do I solve it? openmpi was installed correctly and

/Volumes/OpenFOAM-v2.2/OpenFOAM-2.2.0/platforms/darwinIntel64GccDPOpt/lib/openmpi-macport/libptscotchDecomp.dylib

seems to be correctly placed...
Reread the error message: it looks for libptscotch.dylib (not libptscotchDecomp.dylib) which on my machine (path may slightly vary due to different compiler) lies in /Volumes/Foam/ThirdParty-2.2.x/platforms/darwinIntel64Gcc46DPOpt/lib/openmpi-macport/

That is part of the ThirdParty-compilation. Maybe there was a problem there.

Quote:
Originally Posted by oscarsailing View Post
sorry the ignorance

I look forward to your reply on this issue.

Oscar
"And the Oscar for the most polite question goes to .... ". Sorry. Could not resist. I guess you don't find that funny and of course you're right
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   October 3, 2013, 11:08
Default
  #67
Member
 
Cesar
Join Date: Nov 2012
Location: Guanajuato, México
Posts: 78
Rep Power: 6
cesarcg is on a distinguished road
Send a message via Skype™ to cesarcg
Quote:
Originally Posted by gschaider View Post
I think I made it compile with 4.2 with the attached patch. Wanted to report it to the upstream but I first wanted to verify whether this is a fix to a MacOnly-problem

Bernhard

Attachment 23326
Dear Bernhard,

Excuse my ignorance but where does the attached patch of yours, posted in #54, have to be applied?

Regards,
César

Last edited by cesarcg; October 3, 2013 at 15:54.
cesarcg is offline   Reply With Quote

Old   October 3, 2013, 12:49
Default
  #68
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by cesarcg View Post
Dear Bernhard,

Excuse my ignorance but where does the attached patch of yours, posted in #54, has to be applied?

Regards,
César
If there is a newer version of the general patch and you used that: no
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   October 5, 2013, 04:49
Default
  #69
New Member
 
Jonathan byrne
Join Date: Sep 2013
Posts: 17
Rep Power: 3
jonathanbyrn is on a distinguished road
Hi,
I am having problems compiling the third party libraries. It could not find the makefile and header file for scotch and ptsscotch.

../../etc/wmakeFiles/scotch/Makefile.inc.i686_mac_darwin.shlib-OpenFOAM
WARNING: required include file 'scotch.h' not found!

I went to the makefile folder and copied Makefile.inc.i686_pc_linux2.shlib-OpenFOAM-64 to the name it was looking for. This pushed the compilation a little further but i'm still getting complaint about -lrt and the header files.

ld: library not found for -lrt
WARNING: required include file 'ptscotch.h' not found!

I'm using the most recent 2.2.1 downloads. Is there another version of the third party source code I should be using?

Any help would be greatly appreciated!
jonathanbyrn is offline   Reply With Quote

Old   October 5, 2013, 05:56
Default
  #70
New Member
 
Jonathan byrne
Join Date: Sep 2013
Posts: 17
Rep Power: 3
jonathanbyrn is on a distinguished road
So I was using the first patch, not the updated one. Now it is creating the osx makefile. It still isn't compiling though:
openmpicc -O3 -DCOMMON_FILE_COMPRESS_GZ -DCOMMON_RANDOM_FIXED_SEED -DSCOTCH_RENAME -DSCOTCH_RENAME_PARSER -Drestrict=__restrict -DCOMMON_TIMING_OLD -DSCOTCH_PTSCOTCH -DSCOTCH_VERSION=6 -DSCOTCH_RELEASE=0 -DSCOTCH_PATCHLEVEL=0 dummysizes.c -o ptdummysizes -lz -lm
make[2]: openmpicc: Command not found
make[2]: *** [ptdummysizes] Error 127
make[1]: *** [ptscotch] Error 2
make: *** [ptscotch] Error 2

should the build have linked openmpi to /usr/local/bin or should I have installed openmpi through macports?
jonathanbyrn is offline   Reply With Quote

Old   October 6, 2013, 10:12
Default
  #71
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by jonathanbyrn View Post
So I was using the first patch, not the updated one. Now it is creating the osx makefile. It still isn't compiling though:
openmpicc -O3 -DCOMMON_FILE_COMPRESS_GZ -DCOMMON_RANDOM_FIXED_SEED -DSCOTCH_RENAME -DSCOTCH_RENAME_PARSER -Drestrict=__restrict -DCOMMON_TIMING_OLD -DSCOTCH_PTSCOTCH -DSCOTCH_VERSION=6 -DSCOTCH_RELEASE=0 -DSCOTCH_PATCHLEVEL=0 dummysizes.c -o ptdummysizes -lz -lm
make[2]: openmpicc: Command not found
make[2]: *** [ptdummysizes] Error 127
make[1]: *** [ptscotch] Error 2
make: *** [ptscotch] Error 2

should the build have linked openmpi to /usr/local/bin or should I have installed openmpi through macports?
I use openmpi from MacPorts.
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   October 7, 2013, 07:02
Default
  #72
New Member
 
Jonathan byrne
Join Date: Sep 2013
Posts: 17
Rep Power: 3
jonathanbyrn is on a distinguished road
Thanks for getting back to me Bernhard, I really appreciate the help. I had macports openmpi installed but the macports check in /etc/config/settings.sh wasn't working for me. The -s flag in "which -s port >/dev/null" was returning 1 even though it was there. I removed it and it started using the macports version.

Everything in the thirdparty folder is building now but when something calls mpi, it blows up:
-------------------------------------------------------------------------
A requested component was not found, or was unable to be opened. This
means that this component is either not installed or is unable to be
used on your system (e.g., sometimes this means that shared libraries
that the component requires are unable to be found/loaded). Note that
Open MPI stopped checking at the first component that it did not find.

Host: jonserver
Framework: ras
Component: proxy
--------------------------------------------------------------------------
[jonserver:03894] [[24804,0],0] ORTE_ERROR_LOG: Error in file /opt/local/var/macports/build/_opt_mports_dports_science_openmpi/openmpi/work/openmpi-1.7.2/orte/mca/ess/hnp/ess_hnp_module.c at line 360

This folder doesn't exist and I can't see it being specified in any of the environment variables. Should these files exist or are they created dynamically?

In desperation I tried installing openmpi from source and using the systemmpi flag. It recompiled the third party libraries correctly but now I get this error:

--> FOAM FATAL ERROR:
Trying to use the dummy Pstream library.
This dummy library cannot be used in parallel mode

From function UPstream::init(int& argc, char**& argv)
in file UPstream.C at line 37.

FOAM exiting

My apologies if these are trivial configuration errors but I have no experience using openmpi and i'm having a difficult time debugging them.
jonathanbyrn is offline   Reply With Quote

Old   October 7, 2013, 07:48
Default
  #73
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by jonathanbyrn View Post
Thanks for getting back to me Bernhard, I really appreciate the help. I had macports openmpi installed but the macports check in /etc/config/settings.sh wasn't working for me. The -s flag in "which -s port >/dev/null" was returning 1 even though it was there. I removed it and it started using the macports version.

Everything in the thirdparty folder is building now but when something calls mpi, it blows up:
-------------------------------------------------------------------------
A requested component was not found, or was unable to be opened. This
means that this component is either not installed or is unable to be
used on your system (e.g., sometimes this means that shared libraries
that the component requires are unable to be found/loaded). Note that
Open MPI stopped checking at the first component that it did not find.

Host: jonserver
Framework: ras
Component: proxy
--------------------------------------------------------------------------
[jonserver:03894] [[24804,0],0] ORTE_ERROR_LOG: Error in file /opt/local/var/macports/build/_opt_mports_dports_science_openmpi/openmpi/work/openmpi-1.7.2/orte/mca/ess/hnp/ess_hnp_module.c at line 360

This folder doesn't exist and I can't see it being specified in any of the environment variables. Should these files exist or are they created dynamically?

In desperation I tried installing openmpi from source and using the systemmpi flag. It recompiled the third party libraries correctly but now I get this error:

--> FOAM FATAL ERROR:
Trying to use the dummy Pstream library.
This dummy library cannot be used in parallel mode

From function UPstream::init(int& argc, char**& argv)
in file UPstream.C at line 37.

FOAM exiting

My apologies if these are trivial configuration errors but I have no experience using openmpi and i'm having a difficult time debugging them.
Usually the problem with that kind of error message is that you're using one OpenMPI-implementation but there are environment variables that point to another. Check environment variables with MPI and OPAL in the name. Especially OPAL (if that is set unset it with .... unset)
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   October 7, 2013, 08:14
Default
  #74
New Member
 
Jonathan byrne
Join Date: Sep 2013
Posts: 17
Rep Power: 3
jonathanbyrn is on a distinguished road
I grepped my environment and the mpi paths seem to be correct:
printenv | grep -i mpi

MPI_ARCH_PATH=/opt/local
LD_LIBRARY_PATH=/Users/jonathanbyrne/OpenFOAM/ThirdParty-2.2.1/platforms/darwinIntel64Gcc46/gperftools-svn/lib:/Users/jonathanbyrne/OpenFOAM/ThirdParty-2.2.1/platforms/darwinIntel64Gcc46/paraview-3.12.0/lib/paraview-3.12:/Users/jonathanbyrne/OpenFOAM/OpenFOAM-2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib/openmpi-macport:/Users/jonathanbyrne/OpenFOAM/ThirdParty-2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib/openmpi-macport:/opt/local/lib:/Users/jonathanbyrne/OpenFOAM/jonathan-2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib:/Users/jonathanbyrne/OpenFOAM/site/2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib:/Users/jonathanbyrne/OpenFOAM/OpenFOAM-2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib:/Users/jonathanbyrne/OpenFOAM/ThirdParty-2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib:/Users/jonathanbyrne/OpenFOAM/OpenFOAM-2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib/dummy
MPI_BUFFER_SIZE=20000000
WM_MPLIB=MACPORTOPENMPI
FOAM_MPI=openmpi-macport
DYLD_LIBRARY_PATH=/Users/jonathanbyrne/OpenFOAM/OpenFOAM-2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib/openmpi-macport:/Users/jonathanbyrne/OpenFOAM/ThirdParty-2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib/openmpi-macport:/Users/jonathanbyrne/OpenFOAM/jonathan-2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib:/Users/jonathanbyrne/OpenFOAM/site/2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib:/Users/jonathanbyrne/OpenFOAM/OpenFOAM-2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib:/Users/jonathanbyrne/OpenFOAM/ThirdParty-2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib:/Users/jonathanbyrne/OpenFOAM/OpenFOAM-2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib/dummy:

There are no references to OPAL in my environment. Is there anywhere else I should look?
jonathanbyrn is offline   Reply With Quote

Old   October 7, 2013, 14:54
Default
  #75
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by jonathanbyrn View Post
I grepped my environment and the mpi paths seem to be correct:
printenv | grep -i mpi

MPI_ARCH_PATH=/opt/local
LD_LIBRARY_PATH=/Users/jonathanbyrne/OpenFOAM/ThirdParty-2.2.1/platforms/darwinIntel64Gcc46/gperftools-svn/lib:/Users/jonathanbyrne/OpenFOAM/ThirdParty-2.2.1/platforms/darwinIntel64Gcc46/paraview-3.12.0/lib/paraview-3.12:/Users/jonathanbyrne/OpenFOAM/OpenFOAM-2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib/openmpi-macport:/Users/jonathanbyrne/OpenFOAM/ThirdParty-2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib/openmpi-macport:/opt/local/lib:/Users/jonathanbyrne/OpenFOAM/jonathan-2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib:/Users/jonathanbyrne/OpenFOAM/site/2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib:/Users/jonathanbyrne/OpenFOAM/OpenFOAM-2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib:/Users/jonathanbyrne/OpenFOAM/ThirdParty-2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib:/Users/jonathanbyrne/OpenFOAM/OpenFOAM-2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib/dummy
MPI_BUFFER_SIZE=20000000
WM_MPLIB=MACPORTOPENMPI
FOAM_MPI=openmpi-macport
DYLD_LIBRARY_PATH=/Users/jonathanbyrne/OpenFOAM/OpenFOAM-2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib/openmpi-macport:/Users/jonathanbyrne/OpenFOAM/ThirdParty-2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib/openmpi-macport:/Users/jonathanbyrne/OpenFOAM/jonathan-2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib:/Users/jonathanbyrne/OpenFOAM/site/2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib:/Users/jonathanbyrne/OpenFOAM/OpenFOAM-2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib:/Users/jonathanbyrne/OpenFOAM/ThirdParty-2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib:/Users/jonathanbyrne/OpenFOAM/OpenFOAM-2.2.1/platforms/darwinIntel64Gcc46DPOpt/lib/dummy:

There are no references to OPAL in my environment. Is there anywhere else I should look?
You did the same ("printenv | grep -i opal")? Then this isn't set (don't remember he exact name of the variable ... it is set somewhere)

Two more things to check:
- that none of the old mpi-libs is in the LD_LIBRARY_PATH and/or DYLD_LIBRARY_PATH
- if you run "openmpirun -h" without the etc/bashrc being sourced, does it give you the same error or the help messages? If it works OK then the problem is one of the variables the script sets
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   October 7, 2013, 16:11
Default
  #76
New Member
 
Jonathan byrne
Join Date: Sep 2013
Posts: 17
Rep Power: 3
jonathanbyrn is on a distinguished road
I tried your advice and openmpirun worked before and after sourcing bashrc. It turns out $WM_PROJECT_DIR/bin/tools/RunFunctions is hardcoded to call mpirun instead of openmpirun, which was broken on my system. I changed it and now it is working. Thanks for your advice!
jonathanbyrn is offline   Reply With Quote

Old   October 7, 2013, 17:54
Default
  #77
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by jonathanbyrn View Post
I tried your advice and openmpirun worked before and after sourcing bashrc. It turns out $WM_PROJECT_DIR/bin/tools/RunFunctions is hardcoded to call mpirun instead of openmpirun, which was broken on my system. I changed it and now it is working. Thanks for your advice!
Ah. I rarely use the RunFunctions. Maybe I should adapt them in the patch as well
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   October 26, 2013, 03:10
Default
  #78
New Member
 
Ruben Di Battista
Join Date: May 2013
Location: Milan
Posts: 29
Rep Power: 4
tidusuper91 is on a distinguished road
Hi Bernhard, I'm back. I think i succeeded in building everything. The only error I get is this:

Code:
make[2]: `libptscotchparmetis.dylib' is up to date.
cp parmetis.h ../../include
cp libptscotchparmetis.dylib ../../lib
+ make prefix=/Users/rubendibattista/OpenFOAM/ThirdParty-2.2.2/platforms/darwinIntel64Gcc46/scotch_6.0.0 libdir=/Users/rubendibattista/OpenFOAM/ThirdParty-2.2.2/platforms/darwinIntel64Gcc46DPOpt/lib/openmpi-macport includedir=/Users/rube$
mkdir /Users/rubendibattista/OpenFOAM/ThirdParty-2.2.2/platforms/darwinIntel64Gcc46/scotch_6.0.0/include/openmpi-macport
cp -f ../bin/[agm]* /Users/rubendibattista/OpenFOAM/ThirdParty-2.2.2/platforms/darwinIntel64Gcc46/scotch_6.0.0/bin
cp: ../bin/[agm]*: No such file or directory
make: [install] Error 1 (ignored)
cp -f ../bin/d[agm]* /Users/rubendibattista/OpenFOAM/ThirdParty-2.2.2/platforms/darwinIntel64Gcc46/scotch_6.0.0/bin
cp -f ../include/*scotch*.h /Users/rubendibattista/OpenFOAM/ThirdParty-2.2.2/platforms/darwinIntel64Gcc46/scotch_6.0.0/include/openmpi-macport
cp -f ../lib/*scotch*.dylib /Users/rubendibattista/OpenFOAM/ThirdParty-2.2.2/platforms/darwinIntel64Gcc46DPOpt/lib/openmpi-macport
cp -Rf ../man/* /Users/rubendibattista/OpenFOAM/ThirdParty-2.2.2/platforms/darwinIntel64Gcc46/scotch_6.0.0/share/man
+ make realclean
(cd libscotch ;      make realclean)
Is this a problem?
tidusuper91 is offline   Reply With Quote

Old   October 28, 2013, 18:40
Default
  #79
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by tidusuper91 View Post
Hi Bernhard, I'm back. I think i succeeded in building everything. The only error I get is this:

Code:
make[2]: `libptscotchparmetis.dylib' is up to date.
cp parmetis.h ../../include
cp libptscotchparmetis.dylib ../../lib
+ make prefix=/Users/rubendibattista/OpenFOAM/ThirdParty-2.2.2/platforms/darwinIntel64Gcc46/scotch_6.0.0 libdir=/Users/rubendibattista/OpenFOAM/ThirdParty-2.2.2/platforms/darwinIntel64Gcc46DPOpt/lib/openmpi-macport includedir=/Users/rube$
mkdir /Users/rubendibattista/OpenFOAM/ThirdParty-2.2.2/platforms/darwinIntel64Gcc46/scotch_6.0.0/include/openmpi-macport
cp -f ../bin/[agm]* /Users/rubendibattista/OpenFOAM/ThirdParty-2.2.2/platforms/darwinIntel64Gcc46/scotch_6.0.0/bin
cp: ../bin/[agm]*: No such file or directory
make: [install] Error 1 (ignored)
cp -f ../bin/d[agm]* /Users/rubendibattista/OpenFOAM/ThirdParty-2.2.2/platforms/darwinIntel64Gcc46/scotch_6.0.0/bin
cp -f ../include/*scotch*.h /Users/rubendibattista/OpenFOAM/ThirdParty-2.2.2/platforms/darwinIntel64Gcc46/scotch_6.0.0/include/openmpi-macport
cp -f ../lib/*scotch*.dylib /Users/rubendibattista/OpenFOAM/ThirdParty-2.2.2/platforms/darwinIntel64Gcc46DPOpt/lib/openmpi-macport
cp -Rf ../man/* /Users/rubendibattista/OpenFOAM/ThirdParty-2.2.2/platforms/darwinIntel64Gcc46/scotch_6.0.0/share/man
+ make realclean
(cd libscotch ;      make realclean)
Is this a problem?
No. If you see the scotch-libraries with "ls $FOAM_EXT_LIBBIN/$FOAM_MPI" all should be fine
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   November 9, 2013, 13:29
Default
  #80
Senior Member
 
Alhasan's Avatar
 
Hasan K.J.
Join Date: Dec 2011
Location: Bristol, United Kingdom
Posts: 181
Rep Power: 5
Alhasan is on a distinguished road
Hello ppl,

I followed http://www.optimulation.com/2013/03/...n-lion-10-8-3/
the video on the above link to install openFOAM on mac.

- surfaceaFeatureExtract (is not working - it is very important for me)
so any suggestion how to get this working
- ParaView is not working ( probably think i have install new version ?)

Kind Regards,
Hasan K.J
Alhasan is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Superlinear speedup in OpenFOAM 13 msrinath80 OpenFOAM Running, Solving & CFD 18 March 3, 2015 06:36
Problem when installing Openfoam 2.0.x with mac giovaniharyadi OpenFOAM Installation 0 March 24, 2012 19:45
Modified OpenFOAM Forum Structure and New Mailing-List pete Site News & Announcements 0 June 29, 2009 05:56
The OpenFOAM extensions project mbeaudoin OpenFOAM 16 October 9, 2007 09:33
OpenFOAM Debian packaging current status problems and TODOs oseen OpenFOAM Installation 9 August 26, 2007 13:50


All times are GMT -4. The time now is 14:59.