CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation on Windows, Mac and other Unsupported Platforms (http://www.cfd-online.com/Forums/openfoam-installation-windows-mac/)
-   -   Building solidMechanics in OpenFOAM 1.6-ext on Mac OS X (http://www.cfd-online.com/Forums/openfoam-installation-windows-mac/126362-building-solidmechanics-openfoam-1-6-ext-mac-os-x.html)

codder November 11, 2013 18:04

Building solidMechanics in OpenFOAM 1.6-ext on Mac OS X
 
Hi Philip -

Basically, I have OpenFOAM-1.6-ext complied on the computer. Following the thread thus far, to the best of my ability, I did the following:

Code:

git clone git://git.code.sf.net/p/openfoam-extend/OpenFOAM-1.6-ext nextRelease-1.6-ext
git checkout -b nextRelease origin/nextRelease

Then, I copied the nextRelease-1.6-ext\applications\solidMechanics into the corresponding OpenFOAM-1.6-ext directory. However, when I try to compile, I see the following output.

Code:

make: *** [Make/darwinIntel64GccDPOpt/elasticPlasticSolidFoam.o] Error 1
+ wmake elasticPlasticNonLinTLSolidFoam
Making dependency list for source file elasticPlasticNonLinTLSolidFoam.C
could not open file labelIOList.H for source file elasticPlasticNonLinTLSolidFoam.C
could not open file polyBoundaryMesh.H for source file elasticPlasticNonLinTLSolidFoam.C
could not open file boundBox.H for source file elasticPlasticNonLinTLSolidFoam.C
could not open file pointZoneMesh.H for source file elasticPlasticNonLinTLSolidFoam.C
could not open file faceZoneMesh.H for source file elasticPlasticNonLinTLSolidFoam.C
could not open file cellZoneMesh.H for source file elasticPlasticNonLinTLSolidFoam.C

I believe that the "missing elements" here are files being stored in nextRelease-1.6-ext/src/solidModels. Is this true (and if so), what steps should I take to compile solidMechanics on the current stable release?

Thank you, Eric

codder November 13, 2013 14:23

What I have tried so far is:

Code:

git clone git://git.code.sf.net/p/openfoam-extend/OpenFOAM-1.6-ext ~/OpenFOAM/newRelease
cd ~/OpenFOAM/newRelease
git checkout -b nextRelease origin/nextRelease

cp -R ~/OpenFOAM/newRelease/applications/solvers/solidMechanics/ ~/OpenFOAM/OpenFOAM-1.6-ext/applications/solvers/solidMechanics/
cp -R ~/OpenFOAM/newRelease/tutorials/solidMechanics/ ~/OpenFOAM/OpenFOAM-1.6-ext/tutorials/solidMechanics/

rm -R ~/OpenFOAM/OpenFOAM-1.6-ext/src
cp -R ~/OpenFOAM/newRelease/src/ ~/OpenFOAM/OpenFOAM-1.6-ext/src/
find ~/OpenFOAM/OpenFOAM-1.6-ext/src -name "*.H" | while read i; do ln -s "$i" ~/OpenFOAM/OpenFOAM-1.6-ext/src/OpenFOAM/lnInclude/$(basename "$i") ; done

... but only with success:

Code:

hcp-128-83-76-122:solidMechanics eric$ ./Allwmake
+ wmake elasticAcpSolidFoam
./Allwmake: line 6: wmake: command not found
+ wmake elasticIncrAcpSolidFoam
./Allwmake: line 7: wmake: command not found
+ wmake elasticIncrSolidFoam
./Allwmake: line 8: wmake: command not found
+ wmake elasticNonLinIncrTLSolidFoam
./Allwmake: line 9: wmake: command not found
+ wmake elasticNonLinTLSolidFoam
./Allwmake: line 10: wmake: command not found
+ wmake elasticNonLinULSolidFoam
./Allwmake: line 11: wmake: command not found
+ wmake elasticOrthoAcpSolidFoam
./Allwmake: line 12: wmake: command not found
+ wmake elasticOrthoNonLinULSolidFoam
./Allwmake: line 13: wmake: command not found
+ wmake elasticOrthoSolidFoam
./Allwmake: line 14: wmake: command not found
+ wmake elasticPlasticSolidFoam
./Allwmake: line 15: wmake: command not found
+ wmake elasticPlasticNonLinTLSolidFoam
./Allwmake: line 16: wmake: command not found
+ wmake elasticPlasticNonLinULSolidFoam
./Allwmake: line 17: wmake: command not found
+ wmake elasticSolidFoam
./Allwmake: line 18: wmake: command not found
+ wmake elasticThermalSolidFoam
./Allwmake: line 19: wmake: command not found
+ wmake icoFsiElasticNonLinULSolidFoam
./Allwmake: line 20: wmake: command not found
+ wmake viscoElasticSolidFoam
./Allwmake: line 21: wmake: command not found
+ cd utilities
+ wmake all
./Allwmake: line 23: wmake: command not found
dhcp-128-83-76-122:solidMechanics eric$ . ~/OpenFOAM/OpenFOAM-1.6-ext/etc/bashrc
dhcp-128-83-76-122:solidMechanics eric$ ./Allwmake + wmake elasticAcpSolidFoam
make: *** No rule to make target `/Users/eric/OpenFOAM/OpenFOAM-1.6-ext/src/finiteVolume/lnInclude/fvCFD.H', needed by `elasticAcpSolidFoam.dep'.  Stop.
+ wmake elasticIncrAcpSolidFoam


wyldckat November 15, 2013 03:23

Greetings Eric,

I've moved your two posts from the thread http://www.cfd-online.com/Forums/ope...am-extend.html because this seems to be more of an installation problem of OpenFOAM 1.6-ext on Mac OS X.

The problem you are having with this:
Quote:

Code:

./Allwmake: line 8: wmake: command not found

which means that something went wrong with the original installation of OpenFOAM 1.6-ext.
One simple test that you can make is to run this command:
Code:

export | grep FOAM
If it this command showed nothing to you, then this means that the OpenFOAM shell environment is not operational. If this is the case, it seems that you did not follow properly these two sections:
Best regards,
Bruno

codder November 26, 2013 18:32

solved issue
 
Hi Bruno -

Thanks for pointing out one source of the problems I was seeing. At some point, however, I gave up attempting to install the solidMechanics source into the 1.6 extend stable, and instead compiled the newRelease branch entire.

The later ultimately proved successful, following the advice of a co-worker and:

http://openfoamwiki.net/index.php/In...1.6-ext/Ubuntu

... running Ubuntu 12.04 on VMWare Fusion.

codder January 11, 2014 18:34

updated solution
 
Edit:
Presently I install solidMechanics solvers via foam-extend-3.0, per my thread, and with other wiki installation instructions also available.


All times are GMT -4. The time now is 07:03.