CFD Online URL
[Sponsors]
Home > Forums > OpenFOAM Installation on Windows, Mac and other Unsupported Platforms

Questions regarding to install OpenFOAMv2.3.0 in Mac Mavericks

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   June 1, 2014, 06:15
Question Questions regarding to install OpenFOAMv2.3.0 in Mac Mavericks
  #1
New Member
 
谭健
Join Date: May 2014
Location: Gothenburg,Sweden
Posts: 2
Rep Power: 0
JianT88 is on a distinguished road
Hi everybody!

I'm a beginner of OpenFOAM and trying to install OpenFOAM on a Mac Mavericks system.

I basically follow the OpenFOAMwiki tutorial: http://openfoamwiki.net/index.php/In...OpenFOAM_2.2.2

At step 4.3.9, while trying to source the bashrc file, after I typed . etc/bashrc in the terminal, it told me: -bash: mpicc: command not found

I also tried to do step 4.3.10 and ignore 4.3.9 but it seems there are some errors.

I attach the log file. I deleted part of the log info due to file size restrictions. Also I want to point out something: at the beginning of the log file it says 'scotch.c' cannot found; later it also states the problem with mpicc I mentioned above; and at the end it tells me there are some errors or something.

Also, I didn't patch the third patch file SurfaCGALFix.patch since it seems unnecessary? I tried to patch it afterwards only to see if it works (and it doesn't: Hunk #1 FAILED at 48. 1 out of 1 hunk FAILED -- saving rejects to file applications/utilities/surface/surfaceFeatureExtract/surfaceFeatureExtract.C.rej).

I'm using the latest version 2.3.0 but the version of the patches are still older (I download them from the link of the post: Patches to compile OpenFOAM 2.2 on Mac OS X).

I wonder where exactly the problem is/are? I'm not really familiar with bash command lines or terminals so I cannot really understand the error report. Thank you all very much in advance!

Best regards,
Jian
Attached Files
File Type: gz log_20140601.log.gz (28.5 KB, 1 views)
JianT88 is offline   Reply With Quote

Old   June 8, 2014, 06:25
Default
  #2
New Member
 
谭健
Join Date: May 2014
Location: Gothenburg,Sweden
Posts: 2
Rep Power: 0
JianT88 is on a distinguished road
Hi everybody, again....

I solved the problem by adding the OpenMPI package and use OpenFOAM 2.2.2 instead of 2.3.0. Everything works just fine now so I would like to think that there are some inconsistencies between the latest OF2.3.0 and the old patch for OF2.2.2.

Just an update for those who might get stuck for the same problem.
JianT88 is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Any Parallel install procedure on Mac OS JinZhiyi SU2 Installation 2 March 11, 2014 03:12
Please please Help!environment variables are inconsi openFOAM-2.2.0 on mac mavericks esujby OpenFOAM Installation on Windows, Mac and other Unsupported Platforms 0 March 3, 2014 18:42
Installing OpenFoam2.2.2 on Mac OS X Mavericks ajl42 OpenFOAM Installation on Windows, Mac and other Unsupported Platforms 14 January 10, 2014 12:35
Can't find files when install OF2.1.1 on Mac hewei OpenFOAM Installation on Windows, Mac and other Unsupported Platforms 9 July 11, 2012 11:19
Mac Simple Install Request or Processing Assistance Help sjohnson OpenFOAM Installation 4 December 12, 2008 08:46


All times are GMT -4. The time now is 10:33.