CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Problems after having installed 1.7.0-Version on SUSE (http://www.cfd-online.com/Forums/openfoam-installation/100099-problems-after-having-installed-1-7-0-version-suse.html)

Isabell April 20, 2012 07:23

Problems after having installed 1.7.0-Version on SUSE
 
Hello everyone!

I'm a complete 'freshman' using OpenFOAM and as it seems even failed installing it. I'm supposed so use the 1.7.0-version for my bachelor thesis. After having installed and uninstalled OpenFOAM probably a thousand times I was completely sure that I did everything correctly this time, but the installation test found an error:

Checking basic setup...
-------------------------------------------------------------------------------
Shell: bash
Host: linux-lwyo.site
OS: Linux version 3.1.0-1.2-desktop
-------------------------------------------------------------------------------


Checking main OpenFOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/Isabell/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /home/Isabell/OpenFOAM/Isabell-1.7.0 yes no
$WM_THIRD_PARTY_DIR /home/Isabell/OpenFOAM/ThirdParty-1.7.0 yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /home/Isabell/OpenFOAM/OpenFOAM-1.7.0 yes yes yes

$FOAM_APPBIN ...7.0/applications/bin/linux64GccDPOpt no yes
$FOAM_SITE_APPBIN ...nFOAM/site/1.7.0/bin/linux64GccDPOpt no no
$FOAM_USER_APPBIN ...7.0/applications/bin/linux64GccDPOpt no no
$WM_DIR ...sabell/OpenFOAM/OpenFOAM-1.7.0/wmake yes yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...M/OpenFOAM-1.7.0/lib/linux64GccDPOpt no yes
$FOAM_SITE_LIBBIN ...nFOAM/site/1.7.0/lib/linux64GccDPOpt no no
$FOAM_USER_LIBBIN ...AM/Isabell-1.7.0/lib/linux64GccDPOpt no no
$MPI_ARCH_PATH ...0/platforms/linux64Gcc/openmpi-1.4.1 no yes
-------------------------------------------------------------------------------


Third party software
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
gcc 4.6.2 /usr/bin/gcc
gzip 1.4 /usr/bin/gzip
tar 1.26 /bin/tar
icoFoam
WARNING: Conflicting installations:
OpenFOAM settings : /home/Isabell/OpenFOAM/OpenFOAM-1.7.0/applications/bin/linux64GccDPOpt/icoFoam
current path :
CRITICAL ERROR

-------------------------------------------------------------------------------


Summary
-------------------------------------------------------------------------------
Base configuration ok.

*** The foam installation contains 1 critical error(s)
*** Review the output for warning messages and consult
*** the installation guide for trouble shooting.

done.

Unfortunately I have no idea what this is supposed to tell me ^^

May anyone help me? That would be great!
Isabell

wyldckat April 20, 2012 11:13

Greetings Isabell and welcome to the forum!

The maximum Gcc version compatible with OpenFOAM 1.7.0 is the Gcc 4.4.x series; minimum is 4.3.3. For OpenFOAM 1.7.1 you can use Gcc 4.5.x.

Gcc 4.6.1 that comes with openSUSE 12.1 isn't supported by those older OpenFOAM versions. I think you can still get on openSUSE 12.1 the older Gcc 4.3.4, directly from YaST/zypper. You'll need at least the packages gcc43 and gcc43-c++.

For using this version gcc43 version, you can see the instructions on this post: http://www.cfd-online.com/Forums/ope...tml#post278809 post #2

If you want to build a custom version of Gcc 4.4: Automated scripts for building gcc 4.4.x and 4.5.x for using with OpenFOAM 1.7 series

Good luck!
Bruno

Isabell April 25, 2012 11:12

Hey!

Thank you very much for your soon response!

But in the meantime some things were changing and it came um that I will use the 2.0 Version now. I hope there will be no problems..Otherwhise I know where to aks now :)

Thank you again, it's a great forum!
Isabell


All times are GMT -4. The time now is 08:08.