CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Error compiling paraView-3.12.0 on fc13 (http://www.cfd-online.com/Forums/openfoam-installation/100280-error-compiling-paraview-3-12-0-fc13.html)

jsf April 23, 2012 04:39

Error compiling paraView-3.12.0 on fc13
 
1 Attachment(s)
I am trying to compile paraView-3.12.0 on fc13.

I have compiled OpenFOAM-2.1.x successfully.
I got it using GIT
$ git clone http://github.com/OpenFOAM/OpenFOAM-2.1.x.git

I downloaded from http://www.openfoam.org/download/source.php
ThirdParty-2.1.0.tgz

fc13, it has cmake.x86_64 0:2.8.0-3.fc13 and qt.x86_64 1:4.6.3-10.fc13

I have tried with and without MPI and Python

I keep getting "File truncated" errors like this:

[ 42%] Building CXX object VTK/Graphics/CMakeFiles/vtkGraphicsPythonD.dir/vtkGraphicsPythonInit.cxx.o
Linking CXX shared library ../../bin/libvtkGraphicsPythonD.so
CMakeFiles/vtkGraphicsPythonD.dir/vtkAnnotationLinkPython.cxx.o: file not recognized: File truncated
collect2: ld returned 1 exit status
make[2]: *** [bin/libvtkGraphicsPythonD.so.pv3.12] Error 1
make[1]: *** [VTK/Graphics/CMakeFiles/vtkGraphicsPythonD.dir/all] Error 2
make: *** [all] Error 2

I have tried deleting everything and starting again a few times.

Any help would be appreciated. Thanks in advance!

wyldckat April 23, 2012 06:08

Greetings John and welcome to the forum!

Assuming you have enough disk space, then the problem might be related to the outdated CMake. I think the minimum CMake is 2.8.3 for ParaView 3.12.0, although the installer doesn't complain about it.

The following post was tested on Ubuntu 10.04, but it should work on Fedora 13 as well: paraview compilation error paraview-3.12.0 - post #9

Best regards,
Bruno

jsf April 24, 2012 01:26

Hi Bruno,

Thanks very much for your suggestion. I followed those instructions and upgraded cmake but I got exactly the same error.

Is the a "clean" command I should have used before trying to compile again?

It now seems that my RAID array is failing and may need to be rebuilt so that may be causing the problem. I will probably try to install to Fedora-16 after rebuilding the RAID array. Then I will install OpenFOAM on that.

Thanks again for your help.

Cheers,
John


All times are GMT -4. The time now is 07:39.