CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Contrib/swak4Foam

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree3Likes

Reply
 
LinkBack Thread Tools Display Modes
Old   July 23, 2013, 14:29
Default
  #41
psk
Member
 
david
Join Date: Jun 2013
Location: Montreal, Canada
Posts: 62
Rep Power: 3
psk is an unknown quantity at this point
Thanks for your reply

Sorry gschaider, I cant understand ( Install them via the package manager of your distro) please be little brief. I am newbie
__________________
Million Thanks,
David

"Small Dream is a Crime"
psk is offline   Reply With Quote

Old   July 23, 2013, 14:56
Default
  #42
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,920
Rep Power: 41
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by psk View Post
Thanks for your reply

Sorry gschaider, I cant understand ( Install them via the package manager of your distro) please be little brief. I am newbie
That is called differently in every distribution. The software you install software with (and probably also look for software with). yum, apt-get whatever (and I don't know the name of the GUIs for these. Especially not for Ubuntu)
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   July 24, 2013, 12:07
Default
  #43
psk
Member
 
david
Join Date: Jun 2013
Location: Montreal, Canada
Posts: 62
Rep Power: 3
psk is an unknown quantity at this point
Good Day gschaider,

I install openFoam 2.1 in ubuntu 11.01 in that i try to install swak4Foam, i got error like this, I follow these steps

Step 1: [ svn checkout svn://svn.code.sf.net/p/openfoam-extend/svn/trunk/Breeder_2.0/libraries/swak4Foam/ ], copy & paste in terminal window

step 2: [ hg clone http://hg.code.sf.net/p/openfoam-extend/swak4Foam ] copy & paste in terminal window

upto this step it works

step 3: [ hg update port_2.0.x ] copy & paste in terminal, I got error like this,

toshiba@ubuntu:~/OpenFOAM/toshiba-2.1.0/swak4Foam$ hg update port_2.0.x
abort: no repository found in '/home/toshiba/OpenFOAM/toshiba-2.1.0/swak4Foam' (.hg not found)!

kindly let me know the step 3 is necessary? just I tried.

step4: ./Allwmake --->copy & paste in terminal window, I got error like,

toshiba@ubuntu:~/OpenFOAM/toshiba-2.1.0/swak4Foam$ ./Allwmake
No 'swakConfiguration'. Python etc won't work
Checking swak4Foam-version and generating file
abort: no repository found in '/home/toshiba/OpenFOAM/toshiba-2.1.0/swak4Foam' (.hg not found)!
Swak version is 0.2.4
No 'bison' found. This is absolutely essential for swak4Foam. Can't go on
Requirements for Library not satisfied. I see no sense in going on
toshiba@ubuntu:~/OpenFOAM/toshiba-2.1.0/swak4Foam$

Kindly help me, then next step what i have to do?
__________________
Million Thanks,
David

"Small Dream is a Crime"
psk is offline   Reply With Quote

Old   July 24, 2013, 13:13
Default
  #44
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,920
Rep Power: 41
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by psk View Post
Good Day gschaider,

I install openFoam 2.1 in ubuntu 11.01 in that i try to install swak4Foam, i got error like this, I follow these steps

Step 1: [ svn checkout svn://svn.code.sf.net/p/openfoam-extend/svn/trunk/Breeder_2.0/libraries/swak4Foam/ ], copy & paste in terminal window

step 2: [ hg clone http://hg.code.sf.net/p/openfoam-extend/swak4Foam ] copy & paste in terminal window

upto this step it works

step 3: [ hg update port_2.0.x ] copy & paste in terminal, I got error like this,

toshiba@ubuntu:~/OpenFOAM/toshiba-2.1.0/swak4Foam$ hg update port_2.0.x
abort: no repository found in '/home/toshiba/OpenFOAM/toshiba-2.1.0/swak4Foam' (.hg not found)!

kindly let me know the step 3 is necessary? just I tried.

step4: ./Allwmake --->copy & paste in terminal window, I got error like,

toshiba@ubuntu:~/OpenFOAM/toshiba-2.1.0/swak4Foam$ ./Allwmake
No 'swakConfiguration'. Python etc won't work
Checking swak4Foam-version and generating file
abort: no repository found in '/home/toshiba/OpenFOAM/toshiba-2.1.0/swak4Foam' (.hg not found)!
Swak version is 0.2.4
No 'bison' found. This is absolutely essential for swak4Foam. Can't go on
Requirements for Library not satisfied. I see no sense in going on
toshiba@ubuntu:~/OpenFOAM/toshiba-2.1.0/swak4Foam$

Kindly help me, then next step what i have to do?
INSTALL bison! And make sure flex is also there.

Something like
Code:
sudo apt-get install bison
but I'm not 100% sure as I don't have Ubuntu. Maybe a fellow Ubuntist can help you
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   July 24, 2013, 15:20
Default
  #45
psk
Member
 
david
Join Date: Jun 2013
Location: Montreal, Canada
Posts: 62
Rep Power: 3
psk is an unknown quantity at this point
Thanks for your response gschaider

I install bison, but it won't work, anyhow I try my best
__________________
Million Thanks,
David

"Small Dream is a Crime"
psk is offline   Reply With Quote

Old   July 24, 2013, 17:09
Default
  #46
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,920
Rep Power: 41
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by psk View Post
Thanks for your response gschaider

I install bison, but it won't work, anyhow I try my best
Then you should get a different error. Or what do you mean with "it won't work". The README describes how to check for bison and flex
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   July 25, 2013, 01:14
Default
  #47
psk
Member
 
david
Join Date: Jun 2013
Location: Montreal, Canada
Posts: 62
Rep Power: 3
psk is an unknown quantity at this point
Good Day gschaider,

swak4Foam, right now it works( ubuntu 11.01 with OF 2.1) I follow these commands

(A) Install flex from terminal: sudo apt-get install flex
(B) Install bison from terminal: sudo apt-get install bison
(C) If you dont have gcc installed, you can get it using sudo apt-get install gcc
zandi likes this.
__________________
Million Thanks,
David

"Small Dream is a Crime"
psk is offline   Reply With Quote

Old   March 21, 2014, 18:16
Default
  #48
Member
 
Yijiu Jiang
Join Date: Jan 2013
Location: Texas, US
Posts: 30
Rep Power: 5
y_jiang is on a distinguished road
Hi Bruno,

I am also trying to install funkySetFields on my server. I found your post but stuck on the 1st step. Specifically, it showed 'svn: command not found' when I input
svn checkout https://openfoam-extend.svn.sourcefo...ies/swak4Foam/

Since I am not superuser of the server, 'yum install svn' doesn't work for my case. Do you have any idea on solving this problem?

Thank you!

Yijiu


Quote:
Originally Posted by wyldckat View Post
Greetings to all!

@Julien: I've just now finished testing on openSUSE 11.4 x86_64 with the RPM packages of OpenFOAM 2.1.0 and had no problems at all!
My guess is that the problem you're having is due to placing swak4Foam's code in the folder "/opt/OpenFOAM-2.1.0/Telechargements/swak4Foam" .

After the OpenFOAM environment was ready to be used, I did:
Code:
mkdir -p $FOAM_RUN
run
svn checkout https://openfoam-extend.svn.sourceforge.net/svnroot/openfoam-extend/trunk/Breeder_2.0/libraries/swak4Foam/
cd swak4Foam
export WM_NCOMPPROCS=4
./Allwmake
./Allwmake
The "WM_NCOMPPROCS" is for using 4 cores for faster building. Ran a second time the Allwmake command just to know if all was built successfully and it was all OK! I didn't need to change anything in swak4Foam's code!

Best regards,
Bruno
y_jiang is offline   Reply With Quote

Old   March 21, 2014, 18:23
Default
  #49
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 9,523
Blog Entries: 36
Rep Power: 97
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Quote:
Originally Posted by y_jiang View Post
Since I am not superuser of the server, 'yum install svn' doesn't work for my case. Do you have any idea on solving this problem?
Quick answer:
wyldckat is offline   Reply With Quote

Old   March 21, 2014, 19:06
Default
  #50
Member
 
Yijiu Jiang
Join Date: Jan 2013
Location: Texas, US
Posts: 30
Rep Power: 5
y_jiang is on a distinguished road
Thank you Bruno! I have already downloaded the pack. I think it should be installed into FOAM_USER_LIBBIN.

What I did is:
echo $FOAM_USER_LIBBIN
it gave me:
/home/myname/OpenFOAM/myname-2.2.0/platforms/linux64Gcc45DPOpt/lib
but, there was no such directory before. Then, I created it.
My question is that, is this the right path? or I have to put it into
/home/myname/OpenFOAM/OpenFOAM-2.2.0/platforms/linux64Gcc45DPOpt/lib ?
What's the difference? It makes me a little bit confused...

Yijiu
y_jiang is offline   Reply With Quote

Old   March 22, 2014, 11:03
Default
  #51
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 9,523
Blog Entries: 36
Rep Power: 97
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Yijiu,

Looks like you've never built source code in OpenFOAM. My advice is that you follow this tutorial to get to know how to build custom source code for OpenFOAM: http://openfoamwiki.net/index.php/Ho...ure_to_icoFoam

Regarding swak4Foam, run these commands:
Code:
mkdir -p $FOAM_RUN
cd "$HOME/OpenFOAM/$USER-$WM_PROJECT_VERSION
pwd
Then unpack the file you've downloaded into the folder given by the last command.
And then rename the folder that was created when you unpacked the swak4Foam package, to the simpler folder name "swak4Foam".

And finally, follow the instructions given here: http://openfoamwiki.net/index.php/Co...4Foam#Building

Best regards,
Bruno
__________________
___
I'll be at OFW11 in Portugal
wyldckat is offline   Reply With Quote

Old   March 22, 2014, 21:20
Default
  #52
Member
 
Yijiu Jiang
Join Date: Jan 2013
Location: Texas, US
Posts: 30
Rep Power: 5
y_jiang is on a distinguished road
I made it as your advice. Thank you Bruno!
y_jiang is offline   Reply With Quote

Old   July 6, 2014, 09:20
Default
  #53
New Member
 
Anastasios Stampoultzoglou
Join Date: May 2014
Posts: 18
Rep Power: 4
Tasos is on a distinguished road
Hello to everyone,
I would like to ask you a question about the installation of swak4foam. First of all,
i wrote this command to the terminal : "sudo apt-get install build-essential bison flex subversion git mercurial wget", then i download the files of swak4foam and i put them into the home directory. After that, i was into the file swak4foam with :"cd swak4foam" and then i wrote the above commands: "./Allwmake > make.log 2>&1".Finally i wrote again "./Allwmake" to see if everythink is ok and i had this message;what do you think?what is the problem?
Thank you

Code:
Previously compiled for OpenFOAM 2.2.2
No file 'swakConfiguration'. Python etc won't work. See README for details
Checking swak4Foam-version and generating file
abort: no repository found in '/home/tasos/OpenFOAM/tasos-2.2.2/swak4Foam' (.hg not found)!
Swak version is 0.3.0
Bison is version 2.5
Flex is version 2.5.35 (Minor version: 35)
OpenFOAM-version: Major 2 Minor 2 Patch 2 (-1 == x)
No change to swak4FoamParsers/foamVersion4swak.H
'/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/lib/libswak4FoamParsers.so' is up to date.
'/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/lib/libswakLagrangianParser.so' is up to date.
'/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/lib/libgroovyBC.so' is up to date.
'/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/lib/libswakFunctionObjects.so' is up to date.
'/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/lib/libsimpleFunctionObjects.so' is up to date.
'/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/lib/libsimpleLagrangianFunctionObjects.so' is up to date.
'/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/lib/libsimpleSearchableSurfaces.so' is up to date.
'/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/lib/libsimpleSwakFunctionObjects.so' is up to date.
'/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/lib/libswakTopoSources.so' is up to date.
'/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/lib/libswakSourceFields.so' is up to date.
'/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/lib/libgroovyStandardBCs.so' is up to date.

SWAK_PYTHON_INCLUDE not defined .... no Python-Integration. Most people are fine without it

'/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/lib/libswakMeshQualityFunctionPlugin.so' is up to date.
'/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/lib/libswakLocalCalculationsFunctionPlugin.so' is up to date.
'/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/lib/libswakRandomFunctionPlugin.so' is up to date.
'/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/lib/libswakFvcSchemesFunctionPlugin.so' is up to date.
'/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/lib/libswakThermoTurbFunctionPlugin.so' is up to date.
'/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/lib/libswakTransportTurbFunctionPlugin.so' is up to date.
'/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/lib/libswakSurfacesAndSetsFunctionPlugin.so' is up to date.
'/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/lib/libswakLagrangianCloudSourcesFunctionPlugin.so' is up to date.
'/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/lib/libswakVelocityFunctionPlugin.so' is up to date.
'/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/lib/libswakChemistryModelFunctionPlugin.so' is up to date.
'/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/lib/libswakRadiationModelFunctionPlugin.so' is up to date.
'/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/lib/libswakCoalCloudAdaptor.so' is up to date.

If you have your own function-plugins you can specify them using the SWAK_USER_PLUGINS environment variable and they would be compiled now. If you don't know what this means: don't bother. You propably don't need it

make[1]: Entering directory `/home/tasos/OpenFOAM/tasos-2.2.2/swak4Foam/Utilities/calcNonUniformOffsetsForMapped'
make[1]: `/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/bin/calcNonUniformOffsetsForMapped' is up to date.
make[1]: Leaving directory `/home/tasos/OpenFOAM/tasos-2.2.2/swak4Foam/Utilities/calcNonUniformOffsetsForMapped'
make[1]: Entering directory `/home/tasos/OpenFOAM/tasos-2.2.2/swak4Foam/Utilities/fieldReport'
make[1]: `/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/bin/fieldReport' is up to date.
make[1]: Leaving directory `/home/tasos/OpenFOAM/tasos-2.2.2/swak4Foam/Utilities/fieldReport'
make[1]: Entering directory `/home/tasos/OpenFOAM/tasos-2.2.2/swak4Foam/Utilities/funkyDoCalc'
make[1]: `/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/bin/funkyDoCalc' is up to date.
make[1]: Leaving directory `/home/tasos/OpenFOAM/tasos-2.2.2/swak4Foam/Utilities/funkyDoCalc'

SWAK_PYTHON_INCLUDE not defined .... no Python-Integration. Utility funkyPythonPostproc not compiled

make[1]: Entering directory `/home/tasos/OpenFOAM/tasos-2.2.2/swak4Foam/Utilities/funkySetBoundaryField'
make[1]: `/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/bin/funkySetBoundaryField' is up to date.
make[1]: Leaving directory `/home/tasos/OpenFOAM/tasos-2.2.2/swak4Foam/Utilities/funkySetBoundaryField'
make[1]: Entering directory `/home/tasos/OpenFOAM/tasos-2.2.2/swak4Foam/Utilities/funkySetFields'
make[1]: `/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/bin/funkySetFields' is up to date.
make[1]: Leaving directory `/home/tasos/OpenFOAM/tasos-2.2.2/swak4Foam/Utilities/funkySetFields'
make[1]: Entering directory `/home/tasos/OpenFOAM/tasos-2.2.2/swak4Foam/Utilities/funkySetLagrangianField'
make[1]: `/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/bin/funkySetLagrangianField' is up to date.
make[1]: Leaving directory `/home/tasos/OpenFOAM/tasos-2.2.2/swak4Foam/Utilities/funkySetLagrangianField'
make[1]: Entering directory `/home/tasos/OpenFOAM/tasos-2.2.2/swak4Foam/Utilities/replayTransientBC'
make[1]: `/home/tasos/OpenFOAM/tasos-2.2.2/platforms/linux64GccDPOpt/bin/replayTransientBC' is up to date.
make[1]: Leaving directory `/home/tasos/OpenFOAM/tasos-2.2.2/swak4Foam/Utilities/replayTransientBC'


If you want to use swakCoded-function object or compile software based on swak set the environment variable SWAK4FOAM_SRC to /home/tasos/OpenFOAM/tasos-2.2.2/swak4Foam/Libraries (most people will be fine without setting that variable)

Last edited by wyldckat; July 6, 2014 at 12:49. Reason: Added [CODE][/CODE]
Tasos is offline   Reply With Quote

Old   July 6, 2014, 12:52
Default
  #54
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 9,523
Blog Entries: 36
Rep Power: 97
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Tasos,

Quick answer, please read this page: http://openfoamwiki.net/index.php/In...Error_Messages

If after reading that page you are still unable to figure out if the output you got is OK or not, please state what specific lines you are concerned about.

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   July 7, 2014, 08:30
Default
  #55
New Member
 
Anastasios Stampoultzoglou
Join Date: May 2014
Posts: 18
Rep Power: 4
Tasos is on a distinguished road
Mr Bruno ,
First of i would like to thank you for your quick response.I read the page you told and helped me a lot, but as a very new user i am not sure about some lines.

"SWAK_PYTHON_INCLUDE not defined .... no Python-Integration. Most people are fine without it"
"If you have your own function-plugins you can specify them using the SWAK_USER_PLUGINS environment variable and they would be compiled now. If you don't know what this means: don't bother. You propably don't need it"
"SWAK_PYTHON_INCLUDE not defined .... no Python-Integration. Utility funkyPythonPostproc not compiled"
"If you want to use swakCoded-function object or compile software based on swak set the environment variable SWAK4FOAM_SRC to /home/tasos/OpenFOAM/tasos-2.2.2/swak4Foam/Libraries (most people will be fine without setting that variable)"

You may find some of them silly but all of these stuff are very new for me.
Thanks a lot
Tasos is offline   Reply With Quote

Old   July 7, 2014, 14:54
Default
  #56
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 9,523
Blog Entries: 36
Rep Power: 97
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Quote:
Originally Posted by Tasos View Post
You may find some of them silly but all of these stuff are very new for me.
No problem. And thanks for being more specific regarding which lines you were concerned about.
I didn't add more information about these lines in the wiki because:
  1. Didn't feel necessary to explain, at least not yet, since the whole line has essentially the full explanation (i.e., I was lazy ).
  2. The instructions have a few months now... so I haven't updated yet (not as much as lazy, but more as limited time on my hands).
  3. It's a wiki, anyone can edit it

So, to detail each line:
  1. Code:
    SWAK_PYTHON_INCLUDE not defined .... no Python-Integration. Most people are fine without it
    No problem here, unless you want to use "Python-Integration"; in other words, if you want to be able to execute Python scripts directly from a running OpenFOAM solver or utility.
  2. Code:
    If you have your own function-plugins you can specify them using the SWAK_USER_PLUGINS environment variable and they would be compiled now. If you don't know what this means: don't bother. You propably don't need it
    I've never used this myself, but there is no problem here. It's just a friendly reminder that your own plug-ins could be built, if you already have them. But since it's the first time you're using it, it's unlikely that you'll need this feature right now.
  3. Code:
    SWAK_PYTHON_INCLUDE not defined .... no Python-Integration. Utility funkyPythonPostproc not compiled
    Same as #1, only important if you want the feature "Python-Integration".
  4. Code:
    If you want to use swakCoded-function object or compile software based on swak set the environment variable SWAK4FOAM_SRC to /home/tasos/OpenFOAM/tasos-2.2.2/swak4Foam/Libraries (most people will be fine without setting that variable)
    This is only necessary if you want to be able to use the swak4Foam's own "#codeStream" capabilities.
There is a "README" file in the main folder of swak4Foam, which tells you a bit more about each one of these features .
wyldckat is offline   Reply With Quote

Old   July 10, 2014, 13:28
Default
  #57
New Member
 
Anastasios Stampoultzoglou
Join Date: May 2014
Posts: 18
Rep Power: 4
Tasos is on a distinguished road
Mr Bruno thank you very much, you were very helpful
wyldckat likes this.
Tasos is offline   Reply With Quote

Old   October 1, 2014, 05:34
Default Illegal instruction
  #58
Member
 
Albert Tong
Join Date: Dec 2010
Location: Perth, WA, Australia
Posts: 76
Blog Entries: 1
Rep Power: 7
tfuwa is on a distinguished road
Dear Bruno and All,

I got an
Code:
Illegal instruction
message when using groovyBC. Can you please give a hand on this? Thank you.

It seems to me the compiling process is okay. as see bellow for the second ./Allwmake;

Code:
./Allwmake 
Previously compiled for OpenFOAM 2.2.2
No file 'swakConfiguration'. Python etc won't work. See README for details
Checking swak4Foam-version and generating file
Swak version is 0.3.1
Bison is version 2.7
Flex is version 2.5.35 (Minor version: 35)
OpenFOAM-version: Major 2 Minor 2 Patch 2 (-1 == x / 2)
No change to swak4FoamParsers/foamVersion4swak.H
'/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/lib/libswak4FoamParsers.so' is up to date.
'/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/lib/libswakLagrangianParser.so' is up to date.
'/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/lib/libgroovyBC.so' is up to date.
'/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/lib/libswakFunctionObjects.so' is up to date.
'/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/lib/libsimpleFunctionObjects.so' is up to date.
'/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/lib/libsimpleLagrangianFunctionObjects.so' is up to date.
'/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/lib/libsimpleSearchableSurfaces.so' is up to date.
'/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/lib/libsimpleSwakFunctionObjects.so' is up to date.
'/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/lib/libswakTopoSources.so' is up to date.
'/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/lib/libswakSourceFields.so' is up to date.
Compiling swakFvOptions
'/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/lib/libswakFvOptions.so' is up to date.
'/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/lib/libgroovyStandardBCs.so' is up to date.

SWAK_PYTHON_INCLUDE not defined .... no Python-Integration. Most people are fine without it

'/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/lib/libswakMeshQualityFunctionPlugin.so' is up to date.
'/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/lib/libswakLocalCalculationsFunctionPlugin.so' is up to date.
'/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/lib/libswakRandomFunctionPlugin.so' is up to date.
'/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/lib/libswakFvcSchemesFunctionPlugin.so' is up to date.
'/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/lib/libswakThermoTurbFunctionPlugin.so' is up to date.
'/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/lib/libswakTransportTurbFunctionPlugin.so' is up to date.
'/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/lib/libswakSurfacesAndSetsFunctionPlugin.so' is up to date.
'/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/lib/libswakLagrangianCloudSourcesFunctionPlugin.so' is up to date.
'/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/lib/libswakVelocityFunctionPlugin.so' is up to date.
'/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/lib/libswakChemistryModelFunctionPlugin.so' is up to date.
'/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/lib/libswakRadiationModelFunctionPlugin.so' is up to date.
'/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/lib/libswakCoalCloudAdaptor.so' is up to date.

If you have your own function-plugins you can specify them using the SWAK_USER_PLUGINS environment variable and they would be compiled now. If you don't know what this means: don't bother. You propably don't need it

make[1]: Entering directory `/home/albert/OpenFOAM/albert-2.2.2/applications/swak4Foam_2.x/Utilities/calcNonUniformOffsetsForMapped'
make[1]: `/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/bin/calcNonUniformOffsetsForMapped' is up to date.
make[1]: Leaving directory `/home/albert/OpenFOAM/albert-2.2.2/applications/swak4Foam_2.x/Utilities/calcNonUniformOffsetsForMapped'
make[1]: Entering directory `/home/albert/OpenFOAM/albert-2.2.2/applications/swak4Foam_2.x/Utilities/fieldReport'
make[1]: `/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/bin/fieldReport' is up to date.
make[1]: Leaving directory `/home/albert/OpenFOAM/albert-2.2.2/applications/swak4Foam_2.x/Utilities/fieldReport'
make[1]: Entering directory `/home/albert/OpenFOAM/albert-2.2.2/applications/swak4Foam_2.x/Utilities/funkyDoCalc'
make[1]: `/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/bin/funkyDoCalc' is up to date.
make[1]: Leaving directory `/home/albert/OpenFOAM/albert-2.2.2/applications/swak4Foam_2.x/Utilities/funkyDoCalc'

SWAK_PYTHON_INCLUDE not defined .... no Python-Integration. Utility funkyPythonPostproc not compiled

make[1]: Entering directory `/home/albert/OpenFOAM/albert-2.2.2/applications/swak4Foam_2.x/Utilities/funkySetBoundaryField'
make[1]: `/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/bin/funkySetBoundaryField' is up to date.
make[1]: Leaving directory `/home/albert/OpenFOAM/albert-2.2.2/applications/swak4Foam_2.x/Utilities/funkySetBoundaryField'
make[1]: Entering directory `/home/albert/OpenFOAM/albert-2.2.2/applications/swak4Foam_2.x/Utilities/funkySetFields'
make[1]: `/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/bin/funkySetFields' is up to date.
make[1]: Leaving directory `/home/albert/OpenFOAM/albert-2.2.2/applications/swak4Foam_2.x/Utilities/funkySetFields'
make[1]: Entering directory `/home/albert/OpenFOAM/albert-2.2.2/applications/swak4Foam_2.x/Utilities/funkySetLagrangianField'
make[1]: `/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/bin/funkySetLagrangianField' is up to date.
make[1]: Leaving directory `/home/albert/OpenFOAM/albert-2.2.2/applications/swak4Foam_2.x/Utilities/funkySetLagrangianField'
make[1]: Entering directory `/home/albert/OpenFOAM/albert-2.2.2/applications/swak4Foam_2.x/Utilities/funkyWarpMesh'
make[1]: `/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/bin/funkyWarpMesh' is up to date.
make[1]: Leaving directory `/home/albert/OpenFOAM/albert-2.2.2/applications/swak4Foam_2.x/Utilities/funkyWarpMesh'
make[1]: Entering directory `/home/albert/OpenFOAM/albert-2.2.2/applications/swak4Foam_2.x/Utilities/replayTransientBC'
make[1]: `/home/albert/OpenFOAM/albert-2.2.2/platforms/crayxcGccDPOpt/bin/replayTransientBC' is up to date.
make[1]: Leaving directory `/home/albert/OpenFOAM/albert-2.2.2/applications/swak4Foam_2.x/Utilities/replayTransientBC'
Then funkySetFields gives the following message, also seems good.

Code:
/*---------------------------------------------------------------------------*\
| =========                 |                                                 |
| \\      /  F ield         | OpenFOAM: The Open Source CFD Toolbox           |
|  \\    /   O peration     | Version:  2.2.2                                 |
|   \\  /    A nd           | Web:      www.OpenFOAM.org                      |
|    \\/     M anipulation  |                                                 |
\*---------------------------------------------------------------------------*/
Build  : 2.2.2-9739c53ec43f
Exec   : funkySetFields
Date   : Oct 01 2014
Time   : 17:17:54
Host   : "huge"
PID    : 64766
Case   : /scratch/partner/albert/KC5
nProcs : 1
sigFpe : Enabling floating point exception trapping (FOAM_SIGFPE).
fileModificationChecking : Monitoring run-time modified files using timeStampMaster
allowSystemOperations : Disallowing user-supplied system call operations

// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
swakVersion: 0.3.1 (Release date: 2014-07-11)
// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //


--> FOAM FATAL ERROR: 
funkySetFields: time/latestTime option is required


    From function main()
    in file funkySetFields.C at line 643.

FOAM exiting
But when I use groovyBC, it displays as

Code:
icoFoam
/*---------------------------------------------------------------------------*\
| =========                 |                                                 |
| \\      /  F ield         | OpenFOAM: The Open Source CFD Toolbox           |
|  \\    /   O peration     | Version:  2.2.2                                 |
|   \\  /    A nd           | Web:      www.OpenFOAM.org                      |
|    \\/     M anipulation  |                                                 |
\*---------------------------------------------------------------------------*/
Build  : 2.2.2-9739c53ec43f
Exec   : icoFoam
Date   : Oct 01 2014
Time   : 17:23:16
Host   : "huge"
PID    : 3430
Case   : /scratch/partner/albert/KC5
nProcs : 1
sigFpe : Enabling floating point exception trapping (FOAM_SIGFPE).
fileModificationChecking : Monitoring run-time modified files using timeStampMaster
allowSystemOperations : Disallowing user-supplied system call operations

// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
Create time

Create mesh for time = 0

Reading transportProperties

Reading field p

Illegal instruction
I have already added the following to system/controlDict

Code:
libs (
      "libOpenFOAM.so"
      "libsimpleSwakFunctionObjects.so"
      "libswakFunctionObjects.so"
      "libgroovyBC.so"
     );
__________________
Kind regards,

Albert
tfuwa is offline   Reply With Quote

Old   October 1, 2014, 18:52
Default
  #59
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,920
Rep Power: 41
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by tfuwa View Post
Dear Bruno and All,

I got an
Code:
Illegal instruction
message when using groovyBC. Can you please give a hand on this? Thank you.

It seems to me the compiling process is okay. as see bellow for the second ./Allwmake;

Code:
./Allwmake 
Previously compiled for OpenFOAM 2.2.2
No file 'swakConfiguration'. Python etc won't work. See README for details
Checking swak4Foam-version and generating file
Swak version is 0.3.1
Bison is version 2.7
Flex is version 2.5.35 (Minor version: 35)
OpenFOAM-version: Major 2 Minor 2 Patch 2 (-1 == x / 2)
No change to swak4FoamParsers/foamVersion4swak.H
But when I use groovyBC, it displays as

Code:
icoFoam
/*---------------------------------------------------------------------------*\
| =========                 |                                                 |
| \\      /  F ield         | OpenFOAM: The Open Source CFD Toolbox           |
|  \\    /   O peration     | Version:  2.2.2                                 |
|   \\  /    A nd           | Web:      www.OpenFOAM.org                      |
|    \\/     M anipulation  |                                                 |
\*---------------------------------------------------------------------------*/
Build  : 2.2.2-9739c53ec43f
Exec   : icoFoam
Date   : Oct 01 2014
Time   : 17:23:16
Host   : "huge"
PID    : 3430
Case   : /scratch/partner/albert/KC5
nProcs : 1
sigFpe : Enabling floating point exception trapping (FOAM_SIGFPE).
fileModificationChecking : Monitoring run-time modified files using timeStampMaster
allowSystemOperations : Disallowing user-supplied system call operations

// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
Create time

Create mesh for time = 0

Reading transportProperties

Reading field p

Illegal instruction
I have already added the following to system/controlDict

Code:
libs (
      "libOpenFOAM.so"
      "libsimpleSwakFunctionObjects.so"
      "libswakFunctionObjects.so"
      "libgroovyBC.so"
     );
No idea. That happens before groovyBC had the chance to do anything and seems to happen during the loading of the libraries. Try
a) removing "libOpenFOAM.so" (this is only needed for paraFoam)
b) ./Allclean and ./Allwmake in swak4Foam

The OF 2.2.2-installation: is that a precompiled binary or did you compile it yourself?
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   October 4, 2014, 21:50
Default
  #60
Member
 
Albert Tong
Join Date: Dec 2010
Location: Perth, WA, Australia
Posts: 76
Blog Entries: 1
Rep Power: 7
tfuwa is on a distinguished road
Quote:
Originally Posted by gschaider View Post
No idea. That happens before groovyBC had the chance to do anything and seems to happen during the loading of the libraries. Try
a) removing "libOpenFOAM.so" (this is only needed for paraFoam)
b) ./Allclean and ./Allwmake in swak4Foam

The OF 2.2.2-installation: is that a precompiled binary or did you compile it yourself?
Hi Bernhard,

Thanks for your kind help. With steps a) and b), the problem persists.

The OF2.2.2 was compiled by myself. There were some errors popped-out during installation, which never influences my daily use, but may cause the error to swak4Foam. I will try to re-install OF. Thank you.
__________________
Kind regards,

Albert
tfuwa is offline   Reply With Quote

Reply

Tags
swak4foam

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 18:01.