CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Paraview installation on scientific linux?? (

EllieM July 17, 2012 06:03

Paraview installation on scientific linux??

I'm not a newbie, but still not too technical! I have never had a problem installing in fedora, but when my laptop died I decided that I could stomach gnome3 nor more, hence SL.

I have a fresh installation of SL6.2, 64 bit fully updated.

Openfoam appears to have installed without a hitch, I pulled the latest release from the git repository yesterday.

When I get to the ./makeParaview command, I get

*** Error: cannot find qmake either at $QMAKE_PATH or in current $PATH

Can't pretend to know what this means! So I tried running ./makeQt and got

Starting build: Qt-4.7.3
./makeQt: line 107: cd: /home/ellie/OpenFOAM/ThirdParty-2.1.x/qt-everywhere-opensource-src-4.7.3: No such file or directory

I apologise if this is a duplicate post, I spent all afternoon yesterday (& this morning) trawling forums, google searches not much use, especially when I am not entirely sure what I am looking for!

Thanks in advance

linnemann July 17, 2012 06:29

Hi you need to install qt4

yum install qt4-devel

wyldckat July 17, 2012 06:32

Greetings EllieM and welcome to the forum!

This is a bit outdated, but the principle is the same: Building ParaView 3.10.1 with custom Qt 4.6.4
Adapt 4.6.4 to 4.7.3 and 3.10.1 to 3.12.0 and you should be good to go.

Additionally, you might already have a valid Qt installation. Try:

qmake-qt4 --version
Or type qmake and hit the tab key a couple of time, to see if it auto-completes. If it does, from that blog post you can follow the instructions from the line where makeParaView is called instead!

edit: Linnemann, you got 3 minutes ahead of me :D

Best regards,

EllieM July 17, 2012 06:41

Hi, thank you both for getting back to me..

linnemann, when I run 'sudo yum install qt4-devel' I get

Package 1:qt-devel-4.6.2-24.el6.x86_64 already installed and latest version
Nothing to do

wyldeckat, 'qmake-qt4 --version' gives

QMake version 2.01a
Using Qt version 4.6.2 in /usr/lib64

I am a bit lost in the link for the post you sent, sorry - where should I be looking?

Thanks again

linnemann July 17, 2012 06:57

In the makeParaview script you need to change the following lines


# Set the path to the Qt-4.5 (or later) qmake if the system Qt is older

# Set the path to cmake

So for qmake you insert the return you get from running


which qmake-qt4
and similar for cmake


which cmake
If you dont have cmake you need to install it.

yum install cmake

I think this should work

wyldckat July 17, 2012 06:57

Instead of simply running makeParaView, run it like this:

./makeParaView -qmake `which qmake-qt4` > makePV.log 2>&1
This will make sure it uses the qmake-qt4 binary instead of the default qmake one, as well as keeping a full build log in the file "makePV.log".

The rest is the same as explained in the official OpenFOAM instructions.

EllieM July 17, 2012 07:37

Thank you again for both getting back to me.

I followed both your sets of instructions

makeParaview has been changed to

# Set the path to the Qt-4.5 (or later) qmake if the system Qt is older

# Set the path to cmake

When I run

./makeParaView -qmake `which qmake-qt4` > makePV.log 2>&1

my makePV.log tells me that

CMake Error at VTK/Utilities/vtkhdf5/CMakeLists.txt:1 (cmake_minimum_required):
CMake 2.8 or higher is required. You are running version 2.6.4

There are also a couple of other errors, but they appear to be connected.

I have the most up to date version available on SL, so I enabled the atrpms repo (as suggested here and I still cannot get cmake 2.8....

I am now going to walk away from the machine before it ends up in a million pieces!

linnemann July 17, 2012 07:49

Download the latest release of cmake

yum install ncurces-devel

unpack cmake

go to cmake dir

./configure --prefix=/usr/local

make && make install

run which cmake

should be in /usr/local/bin and not /usr/bin

wyldckat July 17, 2012 07:57

Or as an alternative to Linnemann's instructions - from within the ThirdParty folder run these commands:

wget "" -O getCmake
wget ""
chmod +x get* make*
./makeCmake > mkcmake.log 2>&1

Source for most of the commands: :)

EllieM July 17, 2012 08:15

Thank you both for your help, but I give up!

wyldckat, your method gives me an error with Linking CXX static library libCMakeLib.a

linnemann, your method gives me an error of

The bug is not reproducible, so it is likely a hardware or OS problem.
gmake: *** [cmBootstrapCommands.o] Error 1
Error when bootstrapping CMake:
Problem while running gmake

Again, thank you both so much, I really do appreciate it, but I simply do not have the time at the moment to fix this! :-(

kiddosuper May 12, 2013 21:32

encountered same problem as #7 , cmake version is not matching requried version 2.8

follow the instruction from linnemann

So I download cmake 2.8 , and compile with
# ./configure --prefix=/usr/local
# ./bootstrap; make; make install

after that, still need to modify the link for cmake
# cd /usr/bin
# mv cmake xxxcmake
# ln -s /usr/local/bin/cmake ./

and then , problem solved

All times are GMT -4. The time now is 22:48.