CFD Online URL
[Sponsors]
Home > Forums > OpenFOAM Installation

Paraview installation on scientific linux??

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree7Likes
  • 1 Post By linnemann
  • 2 Post By linnemann
  • 2 Post By wyldckat
  • 1 Post By linnemann
  • 1 Post By wyldckat

Reply
 
LinkBack Thread Tools Display Modes
Old   July 17, 2012, 07:03
Default Paraview installation on scientific linux??
  #1
New Member
 
EllieM
Join Date: Jul 2012
Posts: 4
Rep Power: 4
EllieM is on a distinguished road
Hi,

I'm not a newbie, but still not too technical! I have never had a problem installing in fedora, but when my laptop died I decided that I could stomach gnome3 nor more, hence SL.

I have a fresh installation of SL6.2, 64 bit fully updated.

Openfoam appears to have installed without a hitch, I pulled the latest release from the git repository yesterday.

When I get to the ./makeParaview command, I get

*** Error: cannot find qmake either at $QMAKE_PATH or in current $PATH

Can't pretend to know what this means! So I tried running ./makeQt and got

---------------
Starting build: Qt-4.7.3
./makeQt: line 107: cd: /home/ellie/OpenFOAM/ThirdParty-2.1.x/qt-everywhere-opensource-src-4.7.3: No such file or directory

I apologise if this is a duplicate post, I spent all afternoon yesterday (& this morning) trawling forums, google searches not much use, especially when I am not entirely sure what I am looking for!

Thanks in advance
EllieM is offline   Reply With Quote

Old   July 17, 2012, 07:29
Default
  #2
Senior Member
 
linnemann's Avatar
 
Niels Nielsen
Join Date: Mar 2009
Location: NJ - Denmark
Posts: 441
Rep Power: 13
linnemann will become famous soon enough
Hi you need to install qt4

yum install qt4-devel
wyldckat likes this.
__________________
Linnemann

PS. I do not do personal support, so please post in the forums.
linnemann is offline   Reply With Quote

Old   July 17, 2012, 07:32
Default
  #3
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,514
Blog Entries: 33
Rep Power: 74
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
Greetings EllieM and welcome to the forum!

This is a bit outdated, but the principle is the same: Building ParaView 3.10.1 with custom Qt 4.6.4
Adapt 4.6.4 to 4.7.3 and 3.10.1 to 3.12.0 and you should be good to go.

Additionally, you might already have a valid Qt installation. Try:
Code:
qmake-qt4 --version
Or type qmake and hit the tab key a couple of time, to see if it auto-completes. If it does, from that blog post you can follow the instructions from the line where makeParaView is called instead!

edit: Linnemann, you got 3 minutes ahead of me

Best regards,
Bruno

Last edited by wyldckat; July 17, 2012 at 07:33. Reason: see "edit:"
wyldckat is offline   Reply With Quote

Old   July 17, 2012, 07:41
Default
  #4
New Member
 
EllieM
Join Date: Jul 2012
Posts: 4
Rep Power: 4
EllieM is on a distinguished road
Hi, thank you both for getting back to me..

linnemann, when I run 'sudo yum install qt4-devel' I get

Package 1:qt-devel-4.6.2-24.el6.x86_64 already installed and latest version
Nothing to do

wyldeckat, 'qmake-qt4 --version' gives

QMake version 2.01a
Using Qt version 4.6.2 in /usr/lib64

I am a bit lost in the link for the post you sent, sorry - where should I be looking?

Thanks again
EllieM is offline   Reply With Quote

Old   July 17, 2012, 07:57
Default
  #5
Senior Member
 
linnemann's Avatar
 
Niels Nielsen
Join Date: Mar 2009
Location: NJ - Denmark
Posts: 441
Rep Power: 13
linnemann will become famous soon enough
In the makeParaview script you need to change the following lines

Code:
# Set the path to the Qt-4.5 (or later) qmake if the system Qt is older
QMAKE_PATH=""

# Set the path to cmake
CMAKE_PATH=""
So for qmake you insert the return you get from running

Code:
which qmake-qt4
and similar for cmake

Code:
which cmake
If you dont have cmake you need to install it.

yum install cmake

I think this should work
wyldckat and EllieM like this.
__________________
Linnemann

PS. I do not do personal support, so please post in the forums.
linnemann is offline   Reply With Quote

Old   July 17, 2012, 07:57
Default
  #6
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,514
Blog Entries: 33
Rep Power: 74
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
Instead of simply running makeParaView, run it like this:
Code:
./makeParaView -qmake `which qmake-qt4` > makePV.log 2>&1
This will make sure it uses the qmake-qt4 binary instead of the default qmake one, as well as keeping a full build log in the file "makePV.log".

The rest is the same as explained in the official OpenFOAM instructions.
linnemann and EllieM like this.
wyldckat is offline   Reply With Quote

Old   July 17, 2012, 08:37
Default
  #7
New Member
 
EllieM
Join Date: Jul 2012
Posts: 4
Rep Power: 4
EllieM is on a distinguished road
Thank you again for both getting back to me.

I followed both your sets of instructions

makeParaview has been changed to

# Set the path to the Qt-4.5 (or later) qmake if the system Qt is older
QMAKE_PATH="/usr/bin/qmake-qt4"

# Set the path to cmake
CMAKE_PATH="/usr/bin/cmake"

When I run

./makeParaView -qmake `which qmake-qt4` > makePV.log 2>&1

my makePV.log tells me that

CMake Error at VTK/Utilities/vtkhdf5/CMakeLists.txt:1 (cmake_minimum_required):
CMake 2.8 or higher is required. You are running version 2.6.4

There are also a couple of other errors, but they appear to be connected.

I have the most up to date version available on SL, so I enabled the atrpms repo (as suggested here http://www.linuxforums.org/forum/red...linux-6-a.html) and I still cannot get cmake 2.8....

I am now going to walk away from the machine before it ends up in a million pieces!
EllieM is offline   Reply With Quote

Old   July 17, 2012, 08:49
Default
  #8
Senior Member
 
linnemann's Avatar
 
Niels Nielsen
Join Date: Mar 2009
Location: NJ - Denmark
Posts: 441
Rep Power: 13
linnemann will become famous soon enough
Download the latest release of cmake

yum install ncurces-devel

unpack cmake

go to cmake dir

./configure --prefix=/usr/local

make && make install

run which cmake

should be in /usr/local/bin and not /usr/bin
EllieM likes this.
__________________
Linnemann

PS. I do not do personal support, so please post in the forums.
linnemann is offline   Reply With Quote

Old   July 17, 2012, 08:57
Default
  #9
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,514
Blog Entries: 33
Rep Power: 74
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
Or as an alternative to Linnemann's instructions - from within the ThirdParty folder run these commands:
Code:
wget "http://www.openfoam.org/mantisbt/file_download.php?file_id=143&type=bug" -O getCmake
wget "https://raw.github.com/OpenFOAM/ThirdParty-2.0.x/master/makeCmake"
chmod +x get* make*
./getCmake
./makeCmake > mkcmake.log 2>&1
wmSET
Source for most of the commands: http://www.cfd-online.com/Forums/blo...untu-8-04.html
EllieM likes this.
wyldckat is offline   Reply With Quote

Old   July 17, 2012, 09:15
Default
  #10
New Member
 
EllieM
Join Date: Jul 2012
Posts: 4
Rep Power: 4
EllieM is on a distinguished road
Thank you both for your help, but I give up!

wyldckat, your method gives me an error with Linking CXX static library libCMakeLib.a

linnemann, your method gives me an error of


The bug is not reproducible, so it is likely a hardware or OS problem.
gmake: *** [cmBootstrapCommands.o] Error 1
---------------------------------------------
Error when bootstrapping CMake:
Problem while running gmake


Again, thank you both so much, I really do appreciate it, but I simply do not have the time at the moment to fix this! :-(
EllieM is offline   Reply With Quote

Old   May 12, 2013, 22:32
Default
  #11
New Member
 
Kiddosuper
Join Date: Apr 2009
Posts: 2
Rep Power: 0
kiddosuper is on a distinguished road
encountered same problem as #7 , cmake version is not matching requried version 2.8

follow the instruction from linnemann

So I download cmake 2.8 , and compile with
# ./configure --prefix=/usr/local
# ./bootstrap; make; make install

after that, still need to modify the link for cmake
# cd /usr/bin
# mv cmake xxxcmake
# ln -s /usr/local/bin/cmake ./

and then , problem solved
kiddosuper is offline   Reply With Quote

Reply

Tags
installation, openfoam, paraview 3.12, scientific linux

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual Boot Windows and Linux and Go Open Source andyj Main CFD Forum 2 October 21, 2010 17:49
Installation problem with ParaView 3.8.0 on openSUSE 11.2 aero_ OpenFOAM Paraview & paraFoam 14 August 2, 2010 19:13
paraFoam reader for OpenFOAM 1.6 smart OpenFOAM Installation 13 November 16, 2009 22:41
64bitrhel5 OF installation instructions mirko OpenFOAM Installation 2 August 12, 2008 19:07
Paraview installation troubles jjhall OpenFOAM Installation 3 April 17, 2008 13:59


All times are GMT -4. The time now is 02:46.