CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   segmentation fault when installing OF-2.1.1 on a cluster (

Rebecca513 July 20, 2012 10:26

segmentation fault when installing OF-2.1.1 on a cluster
Dear all,

I am trying to install OF-2.1.1 on a cluster. I have followed the instructions on the website:
but whenever I try to

source $HOME/OpenFOAM/OpenFOAM-2.1.1/etc/cshrc

It gives me error messages as follows.

Segmentation fault
Segmentation fault
Segmentation fault

Your '' operating system is not supported by this release
of OpenFOAM. For further assistance, please contact

Segmentation fault
Segmentation fault
Segmentation fault
Segmentation fault

I have no root access, so it is under my own directory. and the system info is:
Linux version 2.6.18-308.11.1.el5
(gcc version 4.1.2 20080704 (Red Hat 4.1.2-52))

I don't know what I should do with this. Any help and suggestion are truly appreciated!

Thank you.



wyldckat July 20, 2012 21:26

Greetings Hang,

That's a really old system... anyway, for RHEL you should use the dedicated project CentFOAM:

Best regards,

linnemann July 21, 2012 03:07

Its still el5 and its supported into 2014 so it will still be working nicely, we use Rocks 5 for some of our clusters.

But as Bruno says, my centFoam project will have you up and running pretty quickly.

If you want to compile your own OF you need to compile a newer GCC there are make scripts for that in the ThirdParty folder.

Otherwise you need to have gcc44 installed by yum, and then change gcc to gcc44 in the OF settings files.

wyldckat July 21, 2012 06:34

I apologize for this comment:

Originally Posted by wyldckat (Post 372720)
That's a really old system...

I got caught up in the fast paced releases of GCC and other technologies, that to me 2007 is already a long time ago ;): GCC 4.1.2 - February 13, 2007

Rebecca513 July 21, 2012 15:40

Dear Bruno and Niels,

Thank you for your replies.

I will try to contact the cluster manager see if he could help me run 'python --yum' as roots.

Niels, if I understand you correctly, after yum has been run, gcc will be updated to gcc44, and I will have to change OF settings before I run 'python --OF21'. If by any chance I don't get access to root, I will not be able to use the python script for centFOAM to install OF. Instead, I need to compile a newer gcc using the makeGcc file in the Thirdparty directory, and then compile OpenFOAM manually.

Thank you again for your help.



linnemann July 22, 2012 06:31


No its the other way around.

CentFOAM assumes you dont have gcc44 intalled and comes with its own gcc in the Thridparty folder.

What I meant was that if you want to compile yourself using only system gcc you need gcc44 installed by yum.

You can always compile your own newer gcc in the Thirdparty folder and there are numerous howtos on this forum on how to do that.

Rebecca513 July 22, 2012 20:43

Hi Niels,

Thank you for the clarification.

I will try the script first see if it works. If not, I will try to compile myself.

Thank you~



Rebecca513 July 25, 2012 13:59

Dear Niels,

I have successfully installed centFOAM on the cluster, seems that the cshrc is broken, but once I switched to bshrc, I could get it to work.

But when I try to use parallel computing, it gives me the error saying that unable to open '.../Thirdparty-2.1.1/platforms/linux64Gcc/openmpi-1.5.3/lib/....', I was wondering if I need to install and compile openmpi separately. Or it is already in centFOAM package, I just need to use different commands than 'mpirun -np 4 simpleFoam -parallel > log'.

Thank you~



linnemann July 25, 2012 14:05


No that is not necessary, openmpi is part of centFOAM.

Could you try to cd/browse to that folder manually and see if it exists?

If the files are present the folder permissions could be wrong.

Rebecca513 July 31, 2012 15:06

Thank you~

Turned out that openmpi in the package is not consistent with the set-up of the cluster system, with help of the support group, I got it work now.



All times are GMT -4. The time now is 12:29.