CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

How to upgrade centFOAM

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   January 24, 2013, 09:42
Default
  #21
Super Moderator
 
praveen's Avatar
 
Praveen. C
Join Date: Mar 2009
Location: Bangalore
Posts: 251
Blog Entries: 6
Rep Power: 10
praveen is on a distinguished road
I am getting the same problem with 2.1.1. Is there a known fix for this ?
__________________
http://twitter.com/cfdlab
praveen is offline   Reply With Quote

Old   January 24, 2013, 16:56
Default
  #22
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 9,531
Blog Entries: 36
Rep Power: 97
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Praveen,

I had to re-read the whole thread in order to understand you question ... so my question back to you is: did you try the instructions given along the thread? If so, what was the outcome?

You can also try building OpenFOAM 2.1.1 from the source code: http://openfoamwiki.net/index.php/In...CentOS_SL_RHEL

Best regards,
Bruno
__________________
___
I'll be at OFW11 in Portugal
wyldckat is offline   Reply With Quote

Old   January 25, 2013, 01:44
Default
  #23
Super Moderator
 
praveen's Avatar
 
Praveen. C
Join Date: Mar 2009
Location: Bangalore
Posts: 251
Blog Entries: 6
Rep Power: 10
praveen is on a distinguished road
I am having trouble even running ldd

Code:
[praveen@turing obliqueShock]$ ldd $(which blockMesh)
/home/praveen/OpenFOAM/OpenFOAM-2.1.1/platforms/linux64GccDPOpt/bin/blockMesh: error while loading shared libraries: /home/praveen/OpenFOAM/ThirdParty-2.1.1/platforms/linux64Gcc/openmpi-1.5.3/lib/libmpi.so.1: ELF file OS ABI invalid
I am on x86_64.
__________________
http://twitter.com/cfdlab
praveen is offline   Reply With Quote

Old   January 26, 2013, 15:55
Default
  #24
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 9,531
Blog Entries: 36
Rep Power: 97
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Praveen,

Sorry, but I don't have time this weekend to try and replicate this error. As I wrote before, it's best that you re-build OpenFOAM from the source code. The link in the previous post provides instructions for both major versions of CentOS et al.

Best regards,
Bruno
__________________
___
I'll be at OFW11 in Portugal
wyldckat is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
CentFOAM Python Script Installation: Error socon009 OpenFOAM Installation 2 May 26, 2012 09:36
Upgrade CPU or GPU which one is better RTAF Hardware 1 January 27, 2012 10:06
check wmake in CentFOAM pit OpenFOAM 12 November 24, 2010 17:59
CentFOAM updated/cleaned linnemann OpenFOAM Installation 0 June 1, 2010 15:40
Upgrade P4 1.5 to P4 2.6 JJJ FLUENT 3 May 29, 2004 10:30


All times are GMT -4. The time now is 22:32.