CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   error while loading shared libraries (http://www.cfd-online.com/Forums/openfoam-installation/106338-error-while-loading-shared-libraries.html)

Rogue August 26, 2012 00:54

error while loading shared libraries
 
Hi all,
I was using OpenFoam 2.1 it was working very well until when I decide to install OpenFoam 1.6-ext for a project.
I follow the readme file instructions for the installation, all seem working good.
But when i typed blockMesh to execute the cavity case, i got this error message :

esni@ubuntu:~/iOpenFoam/incompressible/applis/icoFoam/cavity$ blockMesh
blockMesh: error while loading shared libraries: libparMetisDecomp.so: cannot open shared object file: No such file or directory

I got the message with OpenFoam 2.1 and 1.6.
I am using ubuntu 12.04.
Any help is welcome

Best regards
Rogue

wyldckat August 26, 2012 07:41

Greetings Rogue and welcome to the forum!

Here you go:
  1. Edit the file "~/.bashrc".
  2. Modify the lines you have, possibly that look something like this:
    Code:

    . $HOME/OpenFOAM/OpenFOAM-2.1.1/etc/bashrc
    . $HOME/OpenFOAM/OpenFOAM-1.6-ext/etc/bashrc

  3. Change those two to this instead:
    Code:

    alias of211='. $HOME/OpenFOAM/OpenFOAM-2.1.1/etc/bashrc'
    alias of16ext='. $HOME/OpenFOAM/OpenFOAM-1.6-ext/etc/bashrc'

  4. Save and close the text editor.
  5. Now, whenever you start a new terminal, run of211 or of16ext depending on the version you want to use.
I advise you to build 1.6-ext once again, because the shell environment was contaminated with the 2.1 version :(

For more information on this subject: Advanced tips for working with the OpenFOAM shell environment

Best regards,
Bruno

PS: I've moved your post to a new thread, from that old thread... because it was really old already.

Rogue August 29, 2012 00:25

Hi wyldckat,

Thanks, it's now working with of 2.1.1 but I get some errors trying to reinstall of 1.6 ext.
I am trying to fix it.

Thanks again.

RygeltheXVI September 18, 2012 09:31

Progress
 
Hail,
I am currently encountering the same issue.
Did you end up resolving the problem and if so how?

Thanks

wyldckat September 18, 2012 14:40

Greetings Rygel,

He possibly solved it by following the instructions on post #2 :rolleyes: ;)

Best regards,
Bruno

Rogue September 19, 2012 16:00

Hi RygeltheXVI,
I just follow what is said in post #2 as told by wyldckat to fix it.
hope it'll do so with you!


All times are GMT -4. The time now is 03:35.