CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Compilation error for OpenFOAM-ext on Ubantu 10.04 32 bit (http://www.cfd-online.com/Forums/openfoam-installation/107102-compilation-error-openfoam-ext-ubantu-10-04-32-bit.html)

Sargam05 September 17, 2012 15:08

Compilation error for OpenFOAM-ext on Ubantu 10.04 32 bit
 
Hello everybody,

I have installed OpenFOAM-1.6-ext and also changed environmental variables in my ubantu 10.04 32 bit machine. During compilation, it seems src files are compiling successfully but some errors messages are coming for solvers compilation.

Since it is a big file of compilation therefore I cannot copy all compilation error messages. There is an example error message for pisoFoam and porousSimpleFoam solvers:

/bin/sh: /home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/wmake/bin/linuxGcc/wmkdep: not found
/bin/sh: /home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/wmake/bin/linuxGcc/wmkdep: not found
/bin/sh: /home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/wmake/bin/linuxGcc/wmkdep: not found
/bin/sh: /home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/wmake/bin/linuxGcc/wmkdep: not found
/bin/sh: /home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/wmake/bin/linuxGcc/wmkdep: not found
/bin/sh: /home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/wmake/bin/linuxGcc/wmkdep: not found
SOURCE=regionProperties/regionProperties.C ; g++ -m32 -Dlinux -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -O3 -DNoRepository -ftemplate-depth-40 -Ifluid -Isolid -IregionProperties -Iinclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/meshTools/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/finiteVolume/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/thermophysicalModels/basic/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/turbulenceModels/compressible/turbulenceModel -IlnInclude -I. -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/OpenFOAM/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linuxGccDPOpt/regionProperties.o
SOURCE=derivedFvPatchFields/solidWallHeatFluxTemperature/solidWallHeatFluxTemperatureFvPatchScalarField.C ; g++ -m32 -Dlinux -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -O3 -DNoRepository -ftemplate-depth-40 -Ifluid -Isolid -IregionProperties -Iinclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/meshTools/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/finiteVolume/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/thermophysicalModels/basic/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/turbulenceModels/compressible/turbulenceModel -IlnInclude -I. -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/OpenFOAM/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linuxGccDPOpt/solidWallHeatFluxTemperatureFvPatchScalarField.o
SOURCE=derivedFvPatchFields/solidWallMixedTemperatureCoupled/solidWallMixedTemperatureCoupledFvPatchScalarField .C ; g++ -m32 -Dlinux -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -O3 -DNoRepository -ftemplate-depth-40 -Ifluid -Isolid -IregionProperties -Iinclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/meshTools/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/finiteVolume/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/thermophysicalModels/basic/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/turbulenceModels/compressible/turbulenceModel -IlnInclude -I. -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/OpenFOAM/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linuxGccDPOpt/solidWallMixedTemperatureCoupledFvPatchScalarField .o
SOURCE=fluid/compressibleCourantNo.C ; g++ -m32 -Dlinux -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -O3 -DNoRepository -ftemplate-depth-40 -Ifluid -Isolid -IregionProperties -Iinclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/meshTools/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/finiteVolume/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/thermophysicalModels/basic/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/turbulenceModels/compressible/turbulenceModel -IlnInclude -I. -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/OpenFOAM/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linuxGccDPOpt/compressibleCourantNo.o
g++ -m32 -Dlinux -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -O3 -DNoRepository -ftemplate-depth-40 -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/turbulenceModels/incompressible/turbulenceModel -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/transportModels -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/transportModels/incompressible/singlePhaseTransportModel -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/finiteVolume/lnInclude -IlnInclude -I. -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/OpenFOAM/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/OSspecific/POSIX/lnInclude -fPIC -Xlinker --add-needed -Xlinker --no-as-needed Make/linuxGccDPOpt/pisoFoam.o -L/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/lib/linuxGccDPOpt \
-lincompressibleTurbulenceModel -lincompressibleRASModels -lincompressibleLESModels -lincompressibleTransportModels -lfiniteVolume -lmeshTools -llduSolvers -lOpenFOAM -ldl -lm -o /home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/applications/bin/linuxGccDPOpt/pisoFoam
/usr/bin/ld: cannot find -lincompressibleTurbulenceModel
collect2: ld returned 1 exit status
make[2]: *** [/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/applications/bin/linuxGccDPOpt/pisoFoam] Error 1
make[1]: *** [pisoFoam] Error 2
/bin/sh: /home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/wmake/bin/linuxGcc/wmkdep: not found
SOURCE=porousSimpleFoam.C ; g++ -m32 -Dlinux -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -O3 -DNoRepository -ftemplate-depth-40 -I../simpleFoam -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/turbulenceModels -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/turbulenceModels/incompressible/RAS/RASModel -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/transportModels -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/transportModels/incompressible/singlePhaseTransportModel -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/finiteVolume/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/meshTools/lnInclude -IlnInclude -I. -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/OpenFOAM/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linuxGccDPOpt/porousSimpleFoam.o
SOURCE=solid/solidRegionDiffNo.C ; g++ -m32 -Dlinux -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -O3 -DNoRepository -ftemplate-depth-40 -Ifluid -Isolid -IregionProperties -Iinclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/meshTools/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/finiteVolume/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/thermophysicalModels/basic/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/turbulenceModels/compressible/turbulenceModel -IlnInclude -I. -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/OpenFOAM/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linuxGccDPOpt/solidRegionDiffNo.o
/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/finiteVolume/lnInclude/readSIMPLEControls.H: In function ‘int main(int, char**)’:
/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/finiteVolume/lnInclude/readSIMPLEControls.H:6: warning: unused variable ‘momentumPredictor’
/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/finiteVolume/lnInclude/readSIMPLEControls.H:9: warning: unused variable ‘fluxGradp’
/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/finiteVolume/lnInclude/readSIMPLEControls.H:12: warning: unused variable ‘transonic’
SOURCE=chtMultiRegionFoam.C ; g++ -m32 -Dlinux -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -O3 -DNoRepository -ftemplate-depth-40 -Ifluid -Isolid -IregionProperties -Iinclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/meshTools/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/finiteVolume/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/thermophysicalModels/basic/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/turbulenceModels/compressible/turbulenceModel -IlnInclude -I. -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/OpenFOAM/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linuxGccDPOpt/chtMultiRegionFoam.o
fluid/setRegionFluidFields.H: In function ‘int main(int, char**)’:
fluid/setRegionFluidFields.H:1: warning: unused variable ‘mesh’
fluid/setRegionFluidFields.H:5: warning: unused variable ‘K’
fluid/setRegionFluidFields.H:6: warning: unused variable ‘U’
fluid/setRegionFluidFields.H:7: warning: unused variable ‘phi’
fluid/setRegionFluidFields.H:8: warning: unused variable ‘g’
fluid/setRegionFluidFields.H:10: warning: unused variable ‘turb’
fluid/setRegionFluidFields.H:11: warning: unused variable ‘DpDt’
fluid/setRegionFluidFields.H:14: warning: unused variable ‘psi’
fluid/setRegionFluidFields.H:15: warning: unused variable ‘h’
g++ -m32 -Dlinux -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -O3 -DNoRepository -ftemplate-depth-40 -I../simpleFoam -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/turbulenceModels -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/turbulenceModels/incompressible/RAS/RASModel -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/transportModels -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/transportModels/incompressible/singlePhaseTransportModel -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/finiteVolume/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/meshTools/lnInclude -IlnInclude -I. -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/OpenFOAM/lnInclude -I/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/src/OSspecific/POSIX/lnInclude -fPIC -Xlinker --add-needed -Xlinker --no-as-needed Make/linuxGccDPOpt/porousSimpleFoam.o -L/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/lib/linuxGccDPOpt \
-lincompressibleRASModels -lincompressibleTransportModels -lfiniteVolume -lmeshTools -llduSolvers -lOpenFOAM -ldl -lm -o /home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/applications/bin/linuxGccDPOpt/porousSimpleFoam
/usr/bin/ld: cannot find -lincompressibleRASModels
collect2: ld returned 1 exit status
make[2]: *** [/home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/applications/bin/linuxGccDPOpt/porousSimpleFoam] Error 1
make[1]: *** [porousSimpleFoam] Error 2
/bin/sh: /home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/wmake/bin/linuxGcc/wmkdep: not found


Similar error messages are coming for all solvers.
Does anyone have any idea why these errors are coming?

Thanks in advance.

Regards,
Sangeeta

wyldckat September 17, 2012 16:07

Greetings Sangeeta,

:eek: it won't matter the lengthy build log, because this message says it all:
Code:

/bin/sh: /home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/wmake/bin/linuxGcc/wmkdep: not found
Run the following commands:
Code:

cd $WM_PROJECT_DIR
cd wmake/src
make

What errors did these commands output?

I can almost bet you didn't install all of the vital packages listed in the guide. Try running the following command:
Code:

sudo apt-get install git flex bison rpm g++ zlib1g-dev binutils-dev openmpi-bin libopenmpi-dev libxext-dev libxt-dev libxrender-dev libstdc++5 libgl1-mesa-dev libglu1-mesa-dev
For more on this lengthy command, you can see this post: http://www.cfd-online.com/Forums/ope...tml#post382035 post #25

Best regards,
Bruno

Sargam05 September 17, 2012 16:28

Quote:

Originally Posted by wyldckat (Post 382208)
Greetings Sangeeta,

:eek: it won't matter the lengthy build log, because this message says it all:
Code:

/bin/sh: /home/sangeeta/OpenFOAM/OpenFOAM-1.6-ext/wmake/bin/linuxGcc/wmkdep: not found
Run the following commands:
Code:

cd $WM_PROJECT_DIR
cd wmake/src
make

What errors did these commands output?

I can almost bet you didn't install all of the vital packages listed in the guide. Try running the following command:
Code:

sudo apt-get install git flex bison rpm g++ zlib1g-dev binutils-dev openmpi-bin libopenmpi-dev libxext-dev libxt-dev libxrender-dev libstdc++5 libgl1-mesa-dev libglu1-mesa-dev
For more on this lengthy command, you can see this post: http://www.cfd-online.com/Forums/ope...tml#post382035 post #25

Best regards,
Bruno


Hi Bruno,

Thanks for the quick reply. I have run following commands
$WM_PROJECT_DIR
cd wmake/src
make

Output messages after running these commands:

sangeeta@sangeeta-laptop:~/OpenFOAM$ cd OpenFOAM-1.6-ext/
sangeeta@sangeeta-laptop:~/OpenFOAM/OpenFOAM-1.6-ext$ cd wmake/src
sangeeta@sangeeta-laptop:~/OpenFOAM/OpenFOAM-1.6-ext/wmake/src$ ls
dirToString.c Makefile wmkdep.l
sangeeta@sangeeta-laptop:~/OpenFOAM/OpenFOAM-1.6-ext/wmake/src$ make
Makefile:55: /rules/linuxGcc/general: No such file or directory
Makefile:56: /rules/linuxGcc: No such file or directory
make: *** No rule to make target `/rules/linuxGcc'. Stop.

I also installed vital packages as follows:
sangeeta@sangeeta-laptop:~$ sudo apt-get install git flex bison rpm g++ zlib1g-dev binutils-dev openmpi-bin libopenmpi-dev libxext-dev libxt-dev libxrender-dev libstdc++5 libgl1-mesa-dev libglu1-mesa-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package git is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package git has no installation candidate


Does that mean it already installed in my machine?
In OpenFOAM-1.6-ext/wmake/rules there are some directories (e.g. darwinIntel64, linuxIA64l164 etc.). Does it is related to 64 bit machine? Can I install OpenFOAM-1.6-ext for ubantu 32 bit?

Could you please also suggest me installation and compiling process of OpenFOAM-1.6-ext on Ubantu 10.04 32 bit machine?

Thanks in advance.

Regards,
Sangeeta

Sargam05 September 17, 2012 16:31

Hi Bruno,

One more thing I like to mention is I have OpenFOAM171 installed in my machine. Do you think that could be the reason for compilation errors?

Thanks,
Sangeeta

wyldckat September 17, 2012 16:33

Hi Sangeeta,

Sorry, I thought you were using 12.04 32 bit.

For 10.04 32 bit, follow these instructions: http://openfoam-extend.git.sourcefor...4.3_32-bit.txt

Best regards,
Bruno

wyldckat September 17, 2012 16:39

For having more than one OpenFOAM version/variant installed:
  1. Edit the file "~/.bashrc".
  2. Find the lines you have that reference OpenFOAM.
    For example, if you have these two lines:
    Code:

    . $HOME/OpenFOAM/OpenFOAM-1.7.1/etc/bashrc
    . $HOME/OpenFOAM/OpenFOAM-1.6-ext/etc/bashrc

    Change them to these two:
    Code:

    alias of171='. $HOME/OpenFOAM/OpenFOAM-1.7.1/etc/bashrc'
    alias of16ext='. $HOME/OpenFOAM/OpenFOAM-1.6-ext/etc/bashrc'

    Or:
    Code:

    alias of171='source $HOME/OpenFOAM/OpenFOAM-1.7.1/etc/bashrc'
    alias of16ext='source $HOME/OpenFOAM/OpenFOAM-1.6-ext/etc/bashrc'

  3. Start a new terminal.
  4. On each new terminal, run only one per terminal, for the respective aliases. For example, if on one terminal you want to have OpenFOAM 1.7.1, then run:
    Code:

    of171
    As for 1.6-ext on another terminal:
    Code:

    of16ext

Sargam05 September 17, 2012 23:46

Hi Bruno,

Thank you for the valuable informations. I am following instructions as given in http://openfoam-extend.git.sourcefor...4.3_32-bit.txt.
I have not found packages in given websites for the installation of libstdc++.os.5 .
e.g. when I am using
http://packages.debian.org/lenny/i38...dc++5/download

It is showing "two or more packages specified (libstdc++5 lenny)"
Could you please suggest me from where and which packages I can install for the installation of libstdc++.os.5 .

Thanks in advance.

Regards,
Sangeeta

wyldckat September 18, 2012 16:12

Hi Sangeeta,

I think you can safely skip those particular instructions for installing "libstdc++.so.5".

You might have problems installing ParaView 3.12.0, but I haven't managed to have enough time to debug that issue. Therefore, after running AllMake int the "ThirdParty" folder, you can move on to build OpenFOAM 1.6-ext, at least until I or someone else can figure out what's wrong.


edit: Apparently there was no problem. It has built OpenFOAM 1.6-ext and ParaView 3.12.0 without any problems on the virtual machine I have with Ubuntu 10.04 32bit. The real issue was unrelated to anything else but some virtualization quirks...
Therefore, the instructions about "libstdc++.so.5" are probably outdated now! You can safely skip them.


Best regards,
Bruno

Sargam05 September 19, 2012 16:25

Hi Bruno,

Thank you for the reply. I have successfully installed and compiled OpenFOAM-1.6-ext in my machine.

Thanks a lot for the guidance.

Best regards,
Sangeeta

sasanghomi September 22, 2012 15:53

Hi..please help me
 
Hi every body
I have some errors in compilation of OP-ext 1.6 on ubuntu 12.04 LTS.
Can you help me? please help me.....
sasan.
log.Allwmake.tar.gz

wyldckat September 22, 2012 16:21

Greetings Sasan,

You didn't need to post your question in two different threads and then ask me twice via private message ;)

Anyway, I've moved one of your posts to this thread (because this one is dedicated to 12.04 and is more recent) and I then deleted the repeated question.
Inadvertently it seems that I deleted the post where your attachment was located... fortunately, you sent me the PM, so here is the extract you shared with me:
Code:

/OpenFOAM/OpenFOAM-1.6-ext/src/OpenFOAM/lnInclude  -I/home/sasan/OpenFOAM/OpenFOAM-1.6-ext/src/OSspecific/POSIX/lnInclude    -fPIC -Xlinker --add-needed -Xlinker --no-as-needed  Make/linux64Gcc46DPOpt/writePointSet.o  Make/linux64Gcc46DPOpt/writeFuns.o Make/linux64Gcc46DPOpt/writePatch.o  Make/linux64Gcc46DPOpt/setSet.o  -L/home/sasan/OpenFOAM/OpenFOAM-1.6-ext/lib/linux64Gcc46DPOpt \
        -lmeshTools    -lreadline -lncurses -lOpenFOAM -liberty -ldl    -lm -o  /home/sasan/OpenFOAM/OpenFOAM-1.6-ext/applications/bin/linux64Gcc46DPOpt/setSet
-- Loading ParaView CMake commands
-- Loading ParaView CMake commands - done
/usr/bin/ld: cannot find -lncurses
collect2: ld returned 1 exit status
make[3]: *** [/home/sasan/OpenFOAM/OpenFOAM-1.6-ext/applications/bin/linux64Gcc46DPOpt/setSet] Error 1
make[2]: *** [setSet] Error 2

make[3]: `/home/sasan/OpenFOAM/OpenFOAM-1.6-ext/applications/bin/linux64Gcc46DPOpt/setsToZones' is up to date.
make[3]: `/home/sasan/OpenFOAM/OpenFOAM-1.6-ext/applications/bin/linux64Gcc46DPOpt/splitMesh' is up to date.
-- Configuring done
make[3]: `/home/sasan/OpenFOAM/OpenFOAM-1.6-ext/applications/bin/linux64Gcc46DPOpt/splitMeshRegions' is up to date.
-- Generating done
-- Build files have been written to:  /home/sasan/OpenFOAM/OpenFOAM-1.6-ext/applications/utilities/postProcessing/graphics/PV3FoamReader/PV3FoamReader/Make/linux64Gcc46DPOpt
+ '[' '' == darwin ']'
+ make
[ 41%] Built target PV3FoamReader
make[3]: `/home/sasan/OpenFOAM/OpenFOAM-1.6-ext/applications/bin/linux64Gcc46DPOpt/stitchMesh' is up to date.
[100%] Built target PV3FoamReader_SM
+ [ -d  -a -r  ]

The solution is simple - install the missing packages:
Code:

sudo apt-get install libreadline-dev libncurses-dev
Best regards,
Bruno

edit: ooops, this thread is actually for Ubuntu 10.04...

sasanghomi September 22, 2012 17:42

thanks
 
thank you wyldckat
I am so sorry...I am a primary user...
I really appreciate your help..

sam.ho March 20, 2014 00:59

Quote:

I also installed vital packages as follows:
sangeeta@sangeeta-laptop:~$ sudo apt-get install git flex bison rpm g++ zlib1g-dev binutils-dev openmpi-bin libopenmpi-dev libxext-dev libxt-dev libxrender-dev libstdc++5 libgl1-mesa-dev libglu1-mesa-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package git is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package git has no installation candidate


Does that mean it already installed in my machine?
In OpenFOAM-1.6-ext/wmake/rules there are some directories (e.g. darwinIntel64, linuxIA64l164 etc.). Does it is related to 64 bit machine? Can I install OpenFOAM-1.6-ext for ubantu 32 bit?

Could you please also suggest me installation and compiling process of OpenFOAM-1.6-ext on Ubantu 10.04 32 bit machine?

Thanks in advance.

Regards,
Sangeeta
I am also facing the same problem but my system is 64 bit Linux Ubuntu 12.04 .
Can anybody help me to resolve this issue ?

wyldckat March 22, 2014 06:21

Greetings sam.ho,

Are you referring to this error message:
Code:

E: Package git has no installation candidate
I don't understand... wasn't this problem already solved in another thread?

Can you provide more details?

Best regards,
Bruno


All times are GMT -4. The time now is 06:33.