CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

ParaView reader module libraries do not exist

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   October 7, 2012, 02:32
Default ParaView reader module libraries do not exist
  #1
Senior Member
 
Mahdi Hosseinali
Join Date: Apr 2009
Posts: 124
Rep Power: 8
anishtain4 is on a distinguished road
When I want to use the paraFoam it complains:

Code:
FATAL ERROR: ParaView reader module libraries do not exist

Please build the reader module before continuing:
cd $FOAM_UTILITIES/postProcessing/graphics/PV3Readers
./Allwclean
./Allwmake
So I go to there and do ./Allwclean, it clears some stuff but when I want to ./Allwmake it returns

Code:
+ [ -d /opt/OpenFOAM/ThirdParty-2.1.0/platforms/linuxGcc/paraview-3.12.0 -a -r /opt/OpenFOAM/ThirdParty-2.1.0/platforms/linuxGcc/paraview-3.12.0 ]
I went down there and saw there is no paraview-3.12.0 folder there, but instead it is in the ThirdParty-2.1.0 folder, so I copied that to the subfolder, but still I get the same result.
What should I do?
anishtain4 is offline   Reply With Quote

Old   October 7, 2012, 02:51
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Mahdi,

Which Linux Distribution are you using and what instructions did you follow for installing OpenFOAM?

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   October 7, 2012, 07:22
Default
  #3
Senior Member
 
Mahdi Hosseinali
Join Date: Apr 2009
Posts: 124
Rep Power: 8
anishtain4 is on a distinguished road
Hey wyldckat, the savior is here again.
I'm using ubuntu 10.04 and I installed the OF manually as we discussed in another topic. Back then paraFoam was working fine, I have no idea how this has happened and it stopped working?
anishtain4 is offline   Reply With Quote

Old   October 7, 2012, 15:24
Default
  #4
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Mahdi,

Quote:
Originally Posted by anishtain4 View Post
Hey wyldckat, the savior is here again.
Nah, I'm just a typical Obsessive Compulsive Installer

Quote:
Originally Posted by anishtain4 View Post
I'm using ubuntu 10.04 and I installed the OF manually as we discussed in another topic. Back then paraFoam was working fine, I have no idea how this has happened and it stopped working?
It's possible that you might have installed something else that might have disturbed OpenFOAM's working environment. Perhaps you installed another version of OpenFOAM?

What do these commands output:
Code:
echo $PV_PLUGIN_PATH
ls -l $PV_PLUGIN_PATH//libPV3FoamReader_SM.so
which paraview
Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   October 9, 2012, 02:15
Default
  #5
Senior Member
 
Mahdi Hosseinali
Join Date: Apr 2009
Posts: 124
Rep Power: 8
anishtain4 is on a distinguished road
Quote:
Originally Posted by wyldckat View Post
Nah, I'm just a typical Obsessive Compulsive Installer


It's possible that you might have installed something else that might have disturbed OpenFOAM's working environment. Perhaps you installed another version of OpenFOAM?

What do these commands output:
Code:
echo $PV_PLUGIN_PATH
ls -l $PV_PLUGIN_PATH//libPV3FoamReader_SM.so
which paraview
Best regards,
Bruno
Guess it got out of service after some updates, not sure how it happened?
The output is:
Code:
/opt/OpenFOAM-2.1.1/platforms/linuxGccDPOpt/lib/paraview-3.12

-rwxr-xr-x 1 mahdi mahdi 198152 2012-10-08 19:36 /opt/OpenFOAM-2.1.1/platforms/linuxGccDPOpt/lib/paraview-3.12//libPV3FoamReader_SM.so

/opt/ThirdParty-2.1.1/platforms/linuxGcc/paraview-3.12.0/bin/paraview
I tried to install all the openfoam and paraview from the scratch, now when I want to open paraview it says: Segmentation fault

I looked it up and found another thread where you have mentioned there maybe something wrong with the Open-GL. I checked my drivers and I have the proprietary driver, but I remember I ran some command regarding to xorg guess that hit the problem. anyway I'm running the update from 10.04 to 12 LTS now, hope this helps
anishtain4 is offline   Reply With Quote

Old   October 9, 2012, 08:25
Default
  #6
Senior Member
 
Mahdi Hosseinali
Join Date: Apr 2009
Posts: 124
Rep Power: 8
anishtain4 is on a distinguished road
I believe it was a VGA issue, after update to precise things are working good.
Thanks for your patience
anishtain4 is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
paraView reader module build problem fusij OpenFOAM Installation 45 May 19, 2014 06:12
OpenFOAM-2.0.x on Ubuntu 11.10 kpsl OpenFOAM Installation 43 January 19, 2012 00:17
paraFoam reader for OpenFOAM 1.6 smart OpenFOAM Installation 13 November 16, 2009 22:41
Can someone PLEASE document the development version installation bernd OpenFOAM Installation 76 November 14, 2008 22:51
Errors running allwmake in OpenFOAM141dev with WM_COMPILE_OPTION%3ddebug unoder OpenFOAM Installation 11 January 30, 2008 21:30


All times are GMT -4. The time now is 13:58.